Microphone not working on modded Wii

Moochieone

Member
OP
Newcomer
Joined
Apr 13, 2022
Messages
11
Trophies
0
Age
49
Location
Virginia
XP
55
Country
United States
Just as the title says, I am having issues getting my Logitech microphone to work with certain Wii games, specifically Rock Band and Guitar Hero games. Right now, I'm just going to focus on Green Day: Rock Band simply because this game loads on both base 57 and base 56, but neither will recognize a microphone plugged directly into Port 1 (no hub).

For my setup, I am using a a softmodded RVL-101 Wii. I have the following apps loaded on the Homebrew Channel (all newest versions): d2x cIOS installer, Priiloader, SysCheckHDE, USB Loader GX, and WiiModLite. I currently have d2x v10.52 cIOS base 57 installed in slot 249, d2x v10.52 cIOS base 56 installed in slot 250, and d2x v10.52 cIOS base 38 installed in slot 251 (per recommendations from Wii Guide).

USB drive is a 4 TB Western Digital HDD, formatted FAT32, and installed in Port 0. USB Loader GX is set to use NAND for save games, and emunand is not currently set up (intentional since I do not want to add another layer of complications). Most games run without issues using default slot 249 [57].

I recently noticed that Band Hero would boot to a black screen, and after some research, found that after setting the loader to use slot 250 [56] for the game, it would boot. Unfortunately, I did not perform a microphone test on the game before moving on to Green Day: Rock Band. This game booted fine on slot 249, but would not recognize the microphone plugged into Port 1 (no hub). I set the loader to use slot 250, and the game booted fine, but still would not recognize the microphone. I then set the loader to use slot 251 [38]. The game booted and recognized the microphone, but would not detect my flash card. I did see some reference to using base 37 for Rock Band, so I installed d2x v10.52 cIOS base 37 in slot 248 and tested GD: RB using slot 248, and had the exact same outcome as using base 38.

I also saw a few references for using d2x v8-final, so loaded d2x v8-final cIOS base 56 to slot 250 and booted up GD: RB using that slot. Unfortunately, it still would not recognize the microphone. I did test the microphone on We Sing Pop, and it worked fine, so I know that the microphone is not defective.

I also tried running these same tests on Guitar Hero Warriors of Rock and had the same results.

I am currently out of ideas for getting my microphone to work on these games and still have access to the flash drive. Does anyone have any suggestions or ideas on what else I can try?

I've included my SysCheck for review.

SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS58 (rev 6176).

Region: NTSC-U
System Menu 4.3U (v513)
Priiloader installed
Drive date: 12.07.2010
Homebrew Channel 1.1.2 running on IOS58

Hollywood v0x21
Console ID: 170319210
Console Type: Wii
Shop Channel Country: United States (49)
Boot2 v4
Found 84 titles.
Found 48 IOS on this console. 15 of them are stubs.

IOS3 (rev 65280): Stub
IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 1032): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3608): Trucha Bug, ES Identify, NAND Access
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS57 (rev 5919): No Patches
IOS58 (rev 6176): USB 2.0
IOS60 (rev 6400): Stub
IOS61 (rev 5662): No Patches
IOS62 (rev 6430): No Patches
IOS70 (rev 6912): Stub
IOS80 (rev 6944): Trucha Bug, NAND Access
IOS222 (rev 65280): Stub
IOS223 (rev 65280): Stub
IOS249[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS250[56] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS251[38] (rev 65535, Info: d2x-v10beta52): Trucha Bug, ES Identify, NAND Access
IOS254 (rev 65281): BootMii
BC v6
MIOS v10
Report generated on 04/13/2022.
 
  • Sad
Reactions: Alexander1970

Alexander1970

XP not matters.
Member
Joined
Nov 8, 2018
Messages
14,527
Trophies
3
Age
51
Location
Austria
XP
631
Country
Austria
Good Morning.:)
Just as the title says, I am having issues getting my Logitech microphone to work with certain Wii games, specifically Rock Band and Guitar Hero games. Right now, I'm just going to focus on Green Day: Rock Band simply because this game loads on both base 57 and base 56, but neither will recognize a microphone plugged directly into Port 1 (no hub).

For my setup, I am using a a softmodded RVL-101 Wii. I have the following apps loaded on the Homebrew Channel (all newest versions): d2x cIOS installer, Priiloader, SysCheckHDE, USB Loader GX, and WiiModLite. I currently have d2x v10.52 cIOS base 57 installed in slot 249, d2x v10.52 cIOS base 56 installed in slot 250, and d2x v10.52 cIOS base 38 installed in slot 251 (per recommendations from Wii Guide).

USB drive is a 4 TB Western Digital HDD, formatted FAT32, and installed in Port 0. USB Loader GX is set to use NAND for save games, and emunand is not currently set up (intentional since I do not want to add another layer of complications). Most games run without issues using default slot 249 [57].

I recently noticed that Band Hero would boot to a black screen, and after some research, found that after setting the loader to use slot 250 [56] for the game, it would boot. Unfortunately, I did not perform a microphone test on the game before moving on to Green Day: Rock Band. This game booted fine on slot 249, but would not recognize the microphone plugged into Port 1 (no hub). I set the loader to use slot 250, and the game booted fine, but still would not recognize the microphone. I then set the loader to use slot 251 [38]. The game booted and recognized the microphone, but would not detect my flash card. I did see some reference to using base 37 for Rock Band, so I installed d2x v10.52 cIOS base 37 in slot 248 and tested GD: RB using slot 248, and had the exact same outcome as using base 38.

I also saw a few references for using d2x v8-final, so loaded d2x v8-final cIOS base 56 to slot 250 and booted up GD: RB using that slot. Unfortunately, it still would not recognize the microphone. I did test the microphone on We Sing Pop, and it worked fine, so I know that the microphone is not defective.

I also tried running these same tests on Guitar Hero Warriors of Rock and had the same results.

I am currently out of ideas for getting my microphone to work on these games and still have access to the flash drive. Does anyone have any suggestions or ideas on what else I can try?

I've included my SysCheck for review.

SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS58 (rev 6176).

Region: NTSC-U
System Menu 4.3U (v513)
Priiloader installed
Drive date: 12.07.2010
Homebrew Channel 1.1.2 running on IOS58

Hollywood v0x21
Console ID: 170319210
Console Type: Wii
Shop Channel Country: United States (49)
Boot2 v4
Found 84 titles.
Found 48 IOS on this console. 15 of them are stubs.

IOS3 (rev 65280): Stub
IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 1032): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3608): Trucha Bug, ES Identify, NAND Access
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS57 (rev 5919): No Patches
IOS58 (rev 6176): USB 2.0
IOS60 (rev 6400): Stub
IOS61 (rev 5662): No Patches
IOS62 (rev 6430): No Patches
IOS70 (rev 6912): Stub
IOS80 (rev 6944): Trucha Bug, NAND Access
IOS222 (rev 65280): Stub
IOS223 (rev 65280): Stub
IOS249[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS250[56] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS251[38] (rev 65535, Info: d2x-v10beta52): Trucha Bug, ES Identify, NAND Access
IOS254 (rev 65281): BootMii
BC v6
MIOS v10
Report generated on 04/13/2022.
Sorry to hear,it is not working....😢


Thank you for your sysCheck,looks good.😉👌

You can try to install the d2x v8 or v10 in Slot 249 with Base 56 please
and
You can try and DISABLE the emuNAND Save Option please.

Try first some Guitar Hero Games please.
So USB HDD in Port 0

796910IMGP4810.jpg

and the Microphone in the other USB Port please.
(Can you maybe test the Microphone on a PC please,to see it is ok ?)

Good luck
Thank you.😉
 

Moochieone

Member
OP
Newcomer
Joined
Apr 13, 2022
Messages
11
Trophies
0
Age
49
Location
Virginia
XP
55
Country
United States
Sorry for the delay, but wanted to make sure I tested everything.
I connected the microphone to several PCs, and it worked on all of them.
All emuNAND has been disabled and microphone connected to Port 1 (no hub) on the Wii.
I then selected 3 games to test with: Guitar Hero 5, Guitar Hero: World of Rock, and Guitar Hero: World Tour.
Below are my findings by version/slot/base:

d2x-v10.52 / 249 / 57
GH5 - black screen
GH: WoR - black screen
GH: WT - load but no microphone

d2x-v10.52 / 250 / 56
GH5 - load but no microphone
GH: WoR - load but no microphone
GH: WT - load but no microphone

d2x-v10.52 / 249 / 56
GH5 - load but no microphone
GH: WoR - load but no microphone
GH: WT - load but no microphone

d2x-v8-final / 249 / 56
GH5 - load but no microphone
GH: WoR - load but no microphone
GH: WT - load but no microphone
 
  • Like
Reactions: Alexander1970

CoolMe

Old Soul..
Member
Joined
Apr 16, 2019
Messages
2,453
Trophies
1
Age
27
XP
7,306
Country
United States
Hey, maybe Port 1 you're plugging the microphone into doesn't give sufficient power for it to work correctly, i suggest plugging into either Port 0 for testing, or use an external usb hub?
Depends on what model you're using, is the microphone compatible with the Wii, is it compatible those games? Does it have like any kind of button, sync button, or LED light that could help indicate that it's ON and working?
I assume it's wired and can't connect through bluetooth?
 
  • Like
Reactions: jeannotte

Moochieone

Member
OP
Newcomer
Joined
Apr 13, 2022
Messages
11
Trophies
0
Age
49
Location
Virginia
XP
55
Country
United States
Hey, maybe Port 1 you're plugging the microphone into doesn't give sufficient power for it to work correctly, i suggest plugging into either Port 0 for testing, or use an external usb hub?
Depends on what model you're using, is the microphone compatible with the Wii, is it compatible those games? Does it have like any kind of button, sync button, or LED light that could help indicate that it's ON and working?
I assume it's wired and can't connect through bluetooth?
Unfortunately, I cannot plug into Port 0 because the hard drive is in that port. I have attempted to move the drive over to port 1, but there are MANY configuration changes that have to be made for it to work, and I didn't want to go through all the trouble. I do know that the wired microphone works on Port 1 because I tested out the 3 We Sing games recently (249 [57]) and the microphone worked with all 3 games.
The microphone also works with the Guitar Hero games if I use base 38, but under that base, I can no longer use the SD card.

I'm starting to suspect that there is something up with base 56 that is not working correctly. In all the forum posts I've looked at, the solution was to use base 56 and all would be fine. For some strange reason, it isn't working for me, which is why I've been trying both d2x v10.52 and d2x v8-final.
 

fandango

Well-Known Member
Member
Joined
May 17, 2021
Messages
129
Trophies
0
Age
20
XP
514
Country
United Kingdom
I suggest you use 'cIOS rev21 d2x v8 final ' and if you cant find that then use 'cIOS rev21 d2x v10 r52' which is practically identical.
Both of these support the hard disk only in the lower port 0.
So plug your microphone into the upper port 1.
Then base 56 should work for you.

Do not use 'cIOS rev21 d2x v9 beta r49' because although it allows the hard disk in port 0 or 1, it has worse compatibility and so could stop some microphone games working properly.

Also be aware that when using 'cIOS rev21 d2x v8 final ' or 'cIOS rev21 d2x v10 r52', there is no plug and play, so you will need to plug the microphone in before powering on the Wii and starting the game. In fact this may be the simple reason why you couldn't get it to work?

I hope this helps. :)
 
Last edited by fandango,

Moochieone

Member
OP
Newcomer
Joined
Apr 13, 2022
Messages
11
Trophies
0
Age
49
Location
Virginia
XP
55
Country
United States
I suggest you use 'cIOS rev21 d2x v8 final ' and if you cant find that then use 'cIOS rev21 d2x v10 r52' which is practically identical.
Both of these support the hard disk only in the lower port 0.
So plug your microphone into the upper port 1.
Then base 56 should work for you.

Do not use 'cIOS rev21 d2x v9 beta r49' because although it allows the hard disk in port 0 or 1, it has worse compatibility and so could stop some microphone games working properly.

Also be aware that when using 'cIOS rev21 d2x v8 final ' or 'cIOS rev21 d2x v10 r52', there is no plug and play, so you will need to plug the microphone in before powering on the Wii and starting the game. In fact this may be the simple reason why you couldn't get it to work?

I hope this helps. :)
If you note my tests documented above, I had already tested with d2x-v8-final / 249 / 56 along with d2x v10 r52:
GH5 - load but no microphone
GH: WoR - load but no microphone
GH: WT - load but no microphone

For the cIOS installation, I used the d2x cIOS installer from the Wii guide (https://wii.guide/cios.html) which includes both v10 beta 52 and v8 final.

Also, the microphone remained plugged directly into port 1 the entire time and I rebooted the machine prior to each test.

I know it isn't the microphone, the port, or the rebooting because I can run games like We Sing! that run on base 57 which find the microphone and work just fine. I have gone through all 55 NTSC-U games that use a microphone (minus the online chat games like CoD and Conduit 2), and those that don't detect the microphone on base 57 also don't detect the microphone on base 56. In those cases, I set the games to use base 38 and they find the microphone. The downside to this is that the SD card will not work on certain games like GH on that base.

Again, I think that there may be something to the fact that cIOS base 56 works differently on RVL-101 models that hasn't been tested until now.
 
Last edited by Moochieone,
General chit-chat
Help Users
    KenniesNewName @ KenniesNewName: Nah the idiots didn't tell me my address was wrong in my profile and kept blaming att