USB Loader GX Newer Revisions not detecting USB

Discussion in 'Wii - Backup Loaders' started by WiiForgotten, Jun 20, 2009.

  1. WiiForgotten
    OP

    WiiForgotten Advanced Member

    Newcomer
    88
    0
    Mar 2, 2009
    Canada
    Well Title explains most of it
    I want to play the new games like ghostbuster on usb
    i have rev 13a installed
    i get error 002 with USB LOADER GX rev 447
    I try newer versions but it says No parition found and just exits
    but REv 447 sees the parition fine

    Its kingston 4gb USB stick
     
  2. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    I have the same problem with my Kingwin EZ-Connect adapter -- either the drive isn't detected or it says there isn't a valid partition.

    However, seeing that the last time I formatted it was with Waninkoko's loader, I'm probably due for another formatting.

    I would recommend backing up all of your games and formatting the drive. I'm pretty sure this will solve the problem, but I haven't had the patience to try it.


    EDIT: Scratch that. Revision 546(latest) is working perfectly with cIOS 249 (Waninkoko's cIOS 38 r13a). My drive was detected and the partition was read perfectly.

    Download it here: http://usbloadergx.koureio.net/downloads/revisions
     
  3. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    and ghostbusters needs the Anti 002 fix of the newest revs
     
  4. WiiForgotten
    OP

    WiiForgotten Advanced Member

    Newcomer
    88
    0
    Mar 2, 2009
    Canada
    Thanks for your replies teq
    yes i need ghostbuster working that is main reason i want to update

    I have already tried the newest rev 546
    but still same problem
     
  5. TyrianCubed

    TyrianCubed Gamer 1989 to present

    Member
    1,138
    0
    Oct 26, 2003
    Italy
    Italy
    I chatted with a couple of devs in the IRC chan the other day about this very problem. They said that changes to the code broke compatibility with usb pendrives. Maybe some work and some don't, I don't know. I'll try the newest rev later, hoping that they fixed the compatibility.

    EDIT: rev 549 works for me now, but doesn't read correctly the content of my drive. I'll try reformatting it and try again, but it's definitely a step forward. Thanks devs [​IMG]
     
  6. WiiForgotten
    OP

    WiiForgotten Advanced Member

    Newcomer
    88
    0
    Mar 2, 2009
    Canada
    Hmm darn that is no good
    will they fix the code?
     
  7. Pippin666

    Pippin666 SSF43DE Master

    Member
    1,812
    247
    Mar 30, 2009
    Canada
    Montreal, Qc
    I'm sure they won't, you know how they never fix thing right? [​IMG]
     
  8. TyrianCubed

    TyrianCubed Gamer 1989 to present

    Member
    1,138
    0
    Oct 26, 2003
    Italy
    Italy
    tried again, now the usb pendrive (kingston 8GB) is recognized but I still don't get the right game list.
    I have 3 games on that and I get the same game displayed three times, each with different (incorrect) filesizes. Tried with another pendrive (intenso 2GB) same thing, 2 games on it, same game displayed twice. BTW the game worked when launched, but I can't access the other ones.

    for everybody with this problem: get a powered usb hard drive or use an older rev with cIOS 13a to boot games like ghostbusters. I use rev 478.
     
  9. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    How are you installing the games?

    The command line WBFS works the best for me, though I don't mind not having a GUI.
     
  10. WiiForgotten
    OP

    WiiForgotten Advanced Member

    Newcomer
    88
    0
    Mar 2, 2009
    Canada
    anything beyond the rev 447 wont work for me
     
  11. TyrianCubed

    TyrianCubed Gamer 1989 to present

    Member
    1,138
    0
    Oct 26, 2003
    Italy
    Italy
    I usually install them with WBFS Manager 3.
     
  12. WiiForgotten
    OP

    WiiForgotten Advanced Member

    Newcomer
    88
    0
    Mar 2, 2009
    Canada
    Never mind Rev 549 seems to have detected my usb
    but i do the anti global fix and 002 fix on ghostbusters but still get a black screen
    have CIOS rev 13 installed