USB Loader GX 3.0 and Emunand

Discussion in 'Wii - Emulation and Homebrew' started by WilliamBaron, Aug 19, 2012.

Aug 19, 2012
  1. WilliamBaron
    OP

    Newcomer WilliamBaron Newbie

    Joined:
    Aug 19, 2012
    Messages:
    1
    So I've had my wii setup with USB Loader GX 3.0 running d2x v8 for a while now. My backups are playing perfect from my USB hard drive. Everything on that end works great.

    I'm trying to figure out how exactly the NAND emulation works. I've set all my nand paths from USB Loader GX to a new \nand folder on my usb drive. I used USB Loader to Dump the nand to the drive and I selected Everything when it gave me that option or to put in a path. I used the Install WAD to Nand from USB Loader to transfer the games to the nand backup. The games show up in my usb loader and everything like that but every time I go to run an installed wiiware I keep getting a black screen and freezing. What am I doing wrong? I can't find any decent tutorials or advice anywhere on how to so this right.

    I've had my wii hacked different ways since I learned how but I'm fresh installed with d2x cIOS and USB Loader GX. I have USB Loader GX 3.0 installed and I'm using the Forwarder Channel. I also have all the apps to play all my backups of NES, SNES, GBA and SEGA games too. They all work great, except for the emu nand stuff I'm trying to do now. I'm sure it's something stupid that I'm overlooking too. :)

    Oh yeah, running 4.3U soft modded with Indiana Pwns.

    Thanks.
     


  2. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,190
    Location:
    Michigan, USA
    Country:
    United States
    What game is it you are trying to play? Do you have the v9 Beta of the D2X cIOS's? Be More Specific.
     
  3. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    You did everything correctly, so I don't know why it would freeze.
    Some games don't work on emuNAND, but I suppose you test few games. (which one? which regions?)

    check in the Settings > Loader Settings >
    There are a setting for Channel EmuNand : Select "Full emulation"

    There's one for Channel boot : Boot.dol or content
    this one should not change anything, if you use Boot.dol and it's not found, it will use "content" automatically and boot the channel like on real Nand.
    It's used mainly to fix Ocarina.
     
  4. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Sorry. It's still me, the OP. Had to change my account.

    CheatFreak, I am using v8 of d2x cIOS. I installed it using the manual WAD installer of MMM. I just put a bunch of the games on my usb hard drive using ShowMiiWads 1.4. Sudoku works fine. I tried Bubble Bobble and it freezes on a black screen. I also tried Moto Heroz and it gets past the intro screen but when it goes to save data for the game, the Wii freezes up. The USB hard drive flashes and the Wii blue light flickers every second or so. Magic Obelisk seems to work fine.

    Cyan, when I set a game to Full Emulation, should I be setting this for every game individually? It's on full in global settings I know.
     
  5. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    Please, don't use duplicated account.
    Why couldn't you use the first one? I'll ban the 3 other accounts.
    If you (already?) forgot the password, there's a password recovery menu.


    if it's set to "Full emu" in global then it's fine.
    No need to set it individually.
     
  6. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Sorry about the account thing. I clicked on Disassociate with Facebook because that's how I logged in the first time. I wanted to change my username and there were no supervisors online. I'll be using this account from now on being it's all done already.
     
  7. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    About emuNand, please use the included Wad Manager inside the loader > settings > feature instead of ShowMiiWads 1.4.
    That way it will install the correct filenames.

    Like you saw some games are working, while other don't.
    Not all games are working from Emulated Nand.
     
  8. Catastrophic

    Member Catastrophic Perfectly Normal

    Joined:
    Apr 28, 2012
    Messages:
    660
    Location:
    Somewhere
    Country:
    Iceland
    I know that black screens can occur on VC if it isn't forced to the appropriate video mode or if IOS is missing, but when it comes to Nand emulation I really have no clue. Have you exhausted every setting?
     
  9. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    I really can't think of any other settings to change. Ok here's the new info:

    I had Motoheroz installed on my SD card through the actual Wii. All legit and well. I then copied a WAD of it and installed it on the Hard Drive with ShowMiiWads. Using USB Loader to run it, it froze up on creating a save file. My save files are set to still go on the Wii. Perhaps I should change that to be safe. Anyway, I deleted Motoheroz off the SD card AND the USB Loader, then I reinstalled it using USB Loader WAD installer. Now, it kicks right to the loader again instead of trying to run. I know I did something wrong here. I need a correct order of events to create this NAND properly and install the WADS to it. I tried running other random games and none of them work 100% yet. I get into loading the game sometimes and it freezes. Sometimes it will freeze up on the Wiimote white screen, and sometimes it just freezes black from the start. I kind of want to just scratch out my nand folders on the hard drive and all the installed wiiware as well and just start this thing over. I did it just trying to figure most of it out on my own and now it's just a pain. It's such a shame that Nintendo's onboard memory is so small. It's pathetic and a real pain in the gonads copying things to the sd card one at a time. Plus waiting for them to load sucks too.

    Any good tutorials you guys can link me with to do this right?
     
  10. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Oh, and this too:

    I used the USB Loader GX Dump Nand -> Everything to create the Nand folder on the USB hard drive. Is that the best way to do it? Does it even matter? The thing is I still have the original NAND and KEYS backup files that I got off the Wii before I first modded it back in 2011. Should I be using these for emuNand? Or is it best to dump and use my current Nand with USB Loader GX?
     
  11. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    it's best to make it from GX.
    The one done with another homebrew will not work fine as it's not using the same filename convention.

    No, if you are using Emulated Nand, it doesn't go to the Wii.
    It's saved to the emulated Nand.

    A thing you should know too:
    If you already had games Stored on the SD card using the real SD menu from nintendo on your Real Wii, before dumping the NAND to EmuNAND, these games will be displayed as if they were installed on emuNAND, but they are not.
    It's only the information that you had the game on SD card, but you can't launch them. It will not work as the data of these games are not on emuNAND.

    You need to reinstall the Wad to EmuNAND, using the Wad tools inside the Feature menu of the loader.
    But, I think this is what you did, right?


    correct order:
    Delete your nand/ folder on the SD card
    Create a new dump using the dump menu of the loader
    Install wads using the Wad install menu of the loader
    Enabled the listing of games from the EmuNand in the Title's origin menu.
    that's all.
     
  12. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Ok, so what am I looking at for order of events here....

    1. Start with fresh USB drive (Well, it has a WBFS folder for my other backups is all, but it is FAT32 formatted)
    2. make a \nand folder on the drive
    3. Dump Nand using USB Loader GX 3.0 and choose the Everything setting. (Do I choose Everything? Also, I didn't dump the SYSCONFIG. Do I need that too?)
    4. Put wads I want to install on the drive or sd card or wherever, and install them using USB Loader GX's Install WAD to Nand feature.
    5. Games should show up fine, download covers and away I go?

    Does that sound like what I should be doing?


    Sorry to be a pain. I just want to make sure I do it right. I really love my Wii, and I want to keep using it.

    Edit: haha. Just posted this probably at the same time as you Cyan (from FF VI, great game by the way. One of my favorites.) Thanks for your help. I will redo all of this probably tomorrow and let you know how it goes. Most games should work though, right? I realize that there are some that will not.
     
  13. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    yeah, use the "Everything" option. no need to dump sysconf as it's done "everything".
    the other steps you mentioned are correct.

    you don't have a SD card?
    try to put the /nand/ folder on SD card instead of USB.


    The saves go to EmuNAND (use "full" in the "EmuNand Channel" Loader setting)

    yeah, most games should work.
    For better compatibility, you can update d2x to v9 and use a base 56.
     
  14. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    what's the newest d2x v9? Is r47 the one I want to download?

    I have an SD card, but there's not enough room for the wiiware I want to put on it. That's why I want to use the usb drive for it. It shouldn't matter though I suppose. It reads off of the hd just fine. Just a matter of rinse and repeat the install. I'm going to clean it all out and start the emu nand from scratch.
     
  15. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Ok, so I did the emu nand from scratch. It seems though that still more than half of my games do not work at all.

    These work so far: Crystal Defenders R1, Fluidity, Adventure Island, Space Invaders get Even.

    These kick me back to the menu: Motoheroz, Sonic 4, World of Goo, Bomberman Blast, Gradius Rebirth.

    I've tried using different IOS too but the non-working games still kick me back. There's gotta be something I have wrong for this many games not to work. I also tried forcing NTSC too but that didn't help.

    Will the new d2x beta v9 help compatability?

    Here's a system check. I'm not sure which one to post because I did both and the Dop-Mii check. Let me know if you need anything else.

    Warning: Spoilers inside!
     
  16. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    The syscheck is fine.

    I guess it's just games that doesn't work on EmuNAND.
    You can add Castlevania to your list.


    Someone should really make a wiki list of non working games on EmuNAND.
     
    lastninjagaijin likes this.
  17. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Ok then. I haven't upgraded to d2x v9 beta yet because the d2x installer for some reason doesnt pick up past version 6 for me. When I put v8 on I did it manually with MMM. Problem currently is that I can't find v9 WAD files yet. So, I'm using ModMii as we speak to download and patch v9 into wad files for manual install. I'll let you know if any of those above games work for me after the update. It's a shame because they are the ones I want the most! haha!

    Oh well, until the compatibility is better I'll have to just install the ones that won't work to SD memory using MMM and copying it from the Wii to SD. Thanks a lot for your help! :)
     
  18. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    I forgot to ask this: I've never used ModMii before. I noticed in my COPY TO SD folder, it's making a list of cIOS where one list is 249 and one is 250, all with matching bases. Should I only install the 249 files?
     
  19. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,458
    Location:
    Engine room, learning
    Country:
    France
    yes, you can install only the 249 (which might be base 56), and 250 (which might be base 57).
    the other one are not required.
     
  20. Relic1882

    Newcomer Relic1882 Member

    Joined:
    Aug 19, 2012
    Messages:
    11
    Country:
    United States
    Damn. I might have to roll back to d2x v8 here. After installing v9, USB Loader holds up when detecting my hard drive. Then if I unplug it, it holds up on Mounting USB 1.
     

Share This Page