Updated A9LH, but still have to boot with SD Card

Discussion in '3DS - Flashcards & Custom Firmwares' started by Agent Moose, Jan 4, 2017.

  1. Agent Moose
    OP

    Agent Moose GBAtemp Fan

    Member
    308
    78
    Dec 6, 2014
    United States
    So it's been many months since I've updated anything on my 3DS, and I decided to do so today.
    I followed the 3ds.guide: https://3ds.guide/updating-a9lh

    It updated my Luma (which I was far behind on) and seems to updated A9LH because nothing went wrong, my console still boots up like normal with the SD card in.

    But when I got to Section 4 "CTR NAND Luma Update", I followed it exactly. I even see the arm9loaderhax.bin on my CTR NAND, but when I boot the console with no SD card, it just shuts off like it used to on the old A9LH.

    Any clue why it won't let me boot into sysnand without my SD card?
     
  2. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,452
    1,952
    Jun 23, 2014
    United States
    Indiana
    I know it's kind of a stupid suggestion, but how sure are you that you haven't been inadvertently booting emunand with luma all this time (instead of sysnand)?
     
  3. Agent Moose
    OP

    Agent Moose GBAtemp Fan

    Member
    308
    78
    Dec 6, 2014
    United States
    ...Well then.

    I didn't think about my emunand :P
    I do use emunand, but I figured that if there was no SD card, it would automatically just boot sysnand, since it can't detect an emunand. I guess that is not the case?
     
  4. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,452
    1,952
    Jun 23, 2014
    United States
    Indiana
    What I meant is, is your sysnand bricked? Can you boot sysnand with the sd in?
     
  5. Hyoretsu

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,578
    296
    Jan 17, 2016
    Brazil
    You gotta open FBI and copy your arm9loaderhax.bin to your CTRNAND's root.
     
  6. Agent Moose
    OP

    Agent Moose GBAtemp Fan

    Member
    308
    78
    Dec 6, 2014
    United States
    Ahh, yes, I can boot my sysnand with the SD card in.
     
  7. Hyoretsu

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,578
    296
    Jan 17, 2016
    Brazil
    Just do what I said. You need to do that in order to boot it without your microSD.
     
  8. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,452
    1,952
    Jun 23, 2014
    United States
    Indiana
    It definitely seems like your a9lh did not get updated for whatever reason. I don't know why.
     
  9. Hyoretsu

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,578
    296
    Jan 17, 2016
    Brazil
    I'm telling you, you have to copy arm9loaderhax.bin to your CTRNAND. I even updated my guide with steps on doing so.
     
  10. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,452
    1,952
    Jun 23, 2014
    United States
    Indiana
    He wasn't following your guide, read what he said in the OP "I followed [Plailect's guide] exactly. I even see the arm9loaderhax.bin on my CTR NAND, but when I boot the console with no SD card, it just shuts off like it used to on the old A9LH."
     
    Quantumcat likes this.
  11. Hyoretsu

    Hyoretsu Itosugi Masahiro's Loyal Reader

    Member
    1,578
    296
    Jan 17, 2016
    Brazil
    That can also happen with other CFWs that don't support arm9loaderhax.bin in CTRNAND.
     
  12. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,452
    1,952
    Jun 23, 2014
    United States
    Indiana
    But he's using luma and updated his a9lh to support ctrnand booting. It's a strange problem.
     
  13. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,079
    595
    May 16, 2011
    United States
    Were you on EmuNAND when you used FBI to copy arm9loaderhax.bin to CTRNAND? If so, it's on your EmuNAND'S CTRNAND and not being very useful. :)
     
  14. Agent Moose
    OP

    Agent Moose GBAtemp Fan

    Member
    308
    78
    Dec 6, 2014
    United States
    Found out the problem. I feel extremely stupid right now.

    So what happened, Yes, I did copy the arm9loadhax.bin to CTR NAND on my EMUNAND. Not sysnand. I didn't think that one through at all, but all is working now!

    Thanks for the help though! So yeah, make sure if you use emunand to copy that file to the sysnand CTR Nand because you know, it must read from sysnand since the SD card isn't in...
     
    nechigawara, Quantumcat and x65943 like this.