1. JT_Maston

    OP JT_Maston Newbie
    Newcomer

    Joined:
    Sep 14, 2019
    Messages:
    7
    Country:
    Romania
    Hi.
    Long story short. I left my switch in a safe for about a year, because I had to leave town. When I left it, it was charged to 100%, but over time the battery must have lost charge, because when I took it out, it was down to 0%.

    Problem is, after charging to 100%, the battery is very unreliable, draining normally to until 80% then rapidly dropping to 1% and staying that way for about an hour of gaming.
    I have power-cycled the console about 3 times. No difference.
    Hekate keeps reporting different battery capacities every time. When I pulled it out of storage, it had a max 3666mAh. I thought it normal. But today, three days later, it's at 2700mAh.
    Even so, at 0.0% (in Hekate), it doesn't turn off, and the battery's voltage is way above the empty voltage (screenshot attached).

    What should I do? I'm afraid to let it discharge in hekate, since it's already on negative current (what black magic is that??).

    Thanks.
     

    Attached Files:

  2. zxr750j

    zxr750j GBAtemp Advanced Fan
    Member

    Joined:
    Sep 29, 2003
    Messages:
    566
    Country:
    Netherlands
    Last edited by zxr750j, Jul 14, 2020 - Reason: typo
  3. The Real Jdbye

    The Real Jdbye *is birb*
    Member

    Joined:
    Mar 17, 2010
    Messages:
    21,087
    Country:
    Norway
    I think Hekate has an option to fix battery calibration.
     
  4. ZachyCatGames

    ZachyCatGames GBAtemp Psycho!
    Member

    Joined:
    Jun 19, 2018
    Messages:
    3,237
    Country:
    United States
    Hekate's battery fix is for something completely different and unrelated.
     
  5. PiracyForTheMasses

    PiracyForTheMasses GBAtemp Regular
    Member

    Joined:
    Sep 25, 2018
    Messages:
    288
    Country:
    United States
    you need to drain the battery in Horizon and then drain it the rest of the way in Hekate.
     
  6. Sora Takihawa

    Sora Takihawa GBAtemp Psycho!
    Member

    Joined:
    Oct 11, 2015
    Messages:
    3,595
    Country:
    Germany
    my switch is same since its on 10.0.4....it suddently drained after 20 min (from 100 to 0)....max voltage was 950 mAh but i powercycled it now its on 3700....iguess i need to do it few times more
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - strangely, behaving, battery