Supercard Mini SD - BIG problem

Discussion in 'GBA - Hardware, Devices and Utilities' started by Wingz136, May 22, 2009.

May 22, 2009
  1. Wingz136
    OP

    Newcomer Wingz136 Member

    Joined:
    Jan 30, 2009
    Messages:
    21
    Country:
    United Kingdom
    Hi, I got my Supercard Mini SD for my Gameboy micro 2 days ago, took me 2 hours(ish) to get running and all was well.

    The next day I tried using the real time save (oh no!). It 'crashed' i.e a white screen.

    I reset it and the menu returned but most of the text is messed up completley.

    I can load .gba files but can't read which one they are due to the text problem.

    Also, it often does not register that the cart is in the gba at all (this started at the same time as the text problem i.e i think the cause is the same)

    Is there a .gba file that I can run which will fix it? or is there another alternative?

    All help and suggestions are very much appreciated.
     
  2. how_do_i_do_that

    Member how_do_i_do_that Blue Wizard is about to die.

    Joined:
    May 16, 2008
    Messages:
    4,809
    Country:
    Antarctica
    use the service mode settings, it will tell you if you got any hardware problems.

    If your going to ask how to do it, get them off the supercard website.
     
  3. nicky041192

    Member nicky041192 GBAtemp Maniac

    Joined:
    Mar 9, 2008
    Messages:
    1,433
    Location:
    UK
    Country:
    United Kingdom
    installed the latest firmware 1.85?
     
  4. Wingz136
    OP

    Newcomer Wingz136 Member

    Joined:
    Jan 30, 2009
    Messages:
    21
    Country:
    United Kingdom
    just tried to upgrade to v1.85 and now the gba doesnt register that it's there at all. any advice?
     
  5. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    Does anything happen when you hold L+R upon startup?

    I've seen a lot of these issues lately, where the Supercard works fine at first, then turns Chinese, then stops working entirely (especially after a firmware upgrade). Seems to be a bad batch. Try and get a replacement if you can.
     
  6. Wingz136
    OP

    Newcomer Wingz136 Member

    Joined:
    Jan 30, 2009
    Messages:
    21
    Country:
    United Kingdom
    No result holding L + R,

    managed to restore it partially, but the text is still messed up
     
  7. joewoodcock

    Newcomer joewoodcock Newbie

    Joined:
    Jul 24, 2009
    Messages:
    1
    Country:
    United States
    How did you restore it partially?

    My GBA also doesn't register a cartridge and I can't send it back.

    Need help badly.
     

Share This Page