SD2Vita Problems - Bubbles Gone after copying to SD (can be restored), No PSP Bubbles

Discussion in 'PS Vita - Hacking & Homebrew' started by Advanced User, Jul 29, 2017.

  1. Advanced User
    OP

    Advanced User Member

    Newcomer
    33
    6
    Jan 20, 2014
    So, I got an SD2Vita adapter, made a backup of my Vita memory card, set the SD2Vita up as shown here (except I copied the contents of my Vita MC to my PC using USB (Vitashell) because that's much faster). After completing the installation and booting, all non-system bubbles were gone. The games/apps were still there (on the sd card), I could see their paths using Vitashell, the bubbles just weren't there. So I used Vitashell's new 'Refresh livearea' feature, and it did restore some, but not all (I think one Vita game didn't show up again), and as it says on github "This will NOT refresh PSP games". Yes, it didn't. So Adrenaline is inaccessible.
    I tried reinstalling it, but it's not possible: Every time you install the necessary PSP game, Vita reboots, and after restarting Henkaku, no PSP bubble is visible on the livearea.

    Am I the only one this happened to? BTW, I tried installing SD2Vita twice, with different SD cards. Each time I created a new (full!) backup of my Vita memory card first, which I then copied to the microsdxc.
    As I said, I followed the guide, set the path to ur0:tai/gamesd.skprx and put the driver to mount into ur0:tai/

    Does it work for you? Are the bubbles there for you after installing? Are PSP bubbles visible? Can you use Adrenaline?
     
  2. Advanced User
    OP

    Advanced User Member

    Newcomer
    33
    6
    Jan 20, 2014
    Update: looks like enso solves this problem.

    Update 2: thank you Yifan Lu! Everything works now!
     
    Last edited by Advanced User, Jul 29, 2017
  3. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,672
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    How did enso solve the problem?
     
  4. Advanced User
    OP

    Advanced User Member

    Newcomer
    33
    6
    Jan 20, 2014
    I had gone back to using my Vita memory card (by adding a # in front of the path), so the homescreen was updated to my card's contents after I rebooted. Then enso was released and I installed it. I removed the # from the path, rebooted, enso loaded and all bubbles are still there, PSP, too. The reason is, because with enso booting directly and going straight to the sd card, Vita doesn't switch to the internal memoy first and thus doesn't index what's in there.
    So yes, enso makes SD2Vita fully usable.
     
    Last edited by Advanced User, Jul 29, 2017