1. israelsaan

    israelsaan Member
    Newcomer

    Joined:
    Jul 25, 2013
    Messages:
    24
    Country:
    Mexico
    Woah thank you! I have already installed hiyacfw by borrowing a friend's computed as I figured out the problem was on my laptop, not the program itself, but its nice to know the exact issue anyway, i'll try this.
     
    alexander1970 likes this.
  2. cykevii

    cykevii Newbie
    Newcomer

    Joined:
    Jan 3, 2019
    Messages:
    2
    Country:
    Sweden
    I'm stuck at the "Downloading latest HiyaCFW release...." part.. How long am i supposed to wait?
     
  3. mondul

    OP mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    113
    Country:
    Colombia
    Which version and OS are you using?
     
  4. kramerino

    kramerino Newbie
    Newcomer

    Joined:
    Mar 12, 2019
    Messages:
    1
    Country:
    United Kingdom
    Hi! I am using a Mac to run HiyaCFW_Helper, I'm able to download the latest HiyaCFW release but when the helper tries to extract I get "ERROR: Extractor failed". Any ideas how to get around this?

    I've tried to extract HiyaCFW manually, then run the helper, but I'm still getting the error.

    Thanks!
     
  5. mondul

    OP mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    113
    Country:
    Colombia
    You have to run it from the Terminal using the Python 3 installed with Homebrew. Make sure to run it from the same folder as the .py tries to locate the Darwin folder there.
     
  6. Flicker

    Flicker Member
    Newcomer

    Joined:
    Mar 18, 2019
    Messages:
    14
    Country:
    Brazil
    I'm on Windows 10, and downloaded the 64bit version of the Helper. When I run HiyaCFW_Helper.exe, it doesn't do anything. I have a SSD and a HD. In both drives, it does that. Does anyone have any idea of what could be the issue?

    Tried to download the 32bit version, and it opens a CMD window, but fails because the architecture is not compatible.

    UPDATE: I could run it on Windows in Safe Mode, but I got the "ERROR: Mounter failed" even with OSFMount open (maybe related to safe mode as when I try to manually mount it, it gives me an error: service can't be shared in safe mode)

    UPDATE 2: Tried it on my mother's laptop, same thing happens.

    UPDATE 3: Same thing on my sister's laptop. All of them Windows 10 64. I'll try a lower version of the Helper.

    UPDATE 4: Same thing happens on version 2.9.9.5 of the helper. I think I hit a wall. :(

    FINAL UPDATE: I was able to do it from another computer with Windows 10 and also from a Windows 7 computer. It didn't work with my 2GB SD Card, but then it worked with another 4GB card + twilight menu.
     
    Last edited by Flicker, Apr 2, 2019
  7. Puffball

    Puffball Newbie
    Newcomer

    Joined:
    Apr 8, 2019
    Messages:
    2
    Country:
    Australia
    Hi All,
    I am getting an error when I run the HiyaCFW Helper Application, which reads 'This script requires OSFMount to run', even though I have it installed. I tried with OSFMount open, same error. I have tried on 2 computers, both Win 10 x64.

    Thanks in Advance :)
     
  8. Puffball

    Puffball Newbie
    Newcomer

    Joined:
    Apr 8, 2019
    Messages:
    2
    Country:
    Australia
    Nevermind!
    It suddenly started to work!
     
  9. mondul

    OP mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    113
    Country:
    Colombia
    Hi, it seems OSFMount was updated and the latest version does not work with the helper. I found a solution for Windows that doesn't require it and will implement it in the next couple of days.
     
    alexander1970 likes this.
  10. alexander1970

    alexander1970 Jodelhoiti....
    Member

    Joined:
    Nov 8, 2018
    Messages:
    12,921
    Country:
    Austria
    Hello.:)

    Yes i can confirm it.With an older Version its ok but sadly another Issue appears at he moment:

    https://gbatemp.net/threads/hiyacfw-help.535714/#post-8589105

    "Could not get TWiLight Menu++"

    Thank you for reading.
     
  11. Robz8

    Robz8 Coolest of TWL
    Developer

    Joined:
    Oct 1, 2010
    Messages:
    14,220
    Country:
    United States
    @mondul The repo for TWiLight Menu++ has moved to the DS-Homebrew organization.
    Because of that, the helper fails to download TWiLight Menu++.
    Can you please fix the links so that they show "DS-Homebrew", instead of "RocketRobz"?
     
  12. astrocapsule

    astrocapsule Member
    Newcomer

    Joined:
    Jul 14, 2018
    Messages:
    15
    Country:
    Argentina
    Hi! I'm getting the error "This script requires OSFMount to run", and saddly the OSFMount was updated today (April 17th) so I'm not sure if the error relies on the Hiyahelper by not recognizing the new version or I'm doing something wrong.
    Any idea?? Thanks!!
     
  13. mondul

    OP mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    113
    Country:
    Colombia
    Hi, I have been busy with work and personal stuff, hope I can fix that on Sunday
     
  14. Chris_0

    Chris_0 Newbie
    Newcomer

    Joined:
    Apr 20, 2019
    Messages:
    4
    Country:
    Italy
    Hello, I'm having a problem installing Hiyacfw: after i installed it from hiyacfw helper (I've tried multiple times even with different NAND backup from my Nintendo dsi) and inserted the microsd in the nintendo, hiyacfw doesn't show up in unlaunch. I'm using the unlaunch's 1.8 version and i've followed the guide cfw.guide.
     
  15. mondul

    OP mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    113
    Country:
    Colombia
    Sorry for the delay, but I finally updated the helper with the new URL for TWiLightMenu++ and removed the OSFMount dependency on Windows. Now it depends on 7-Zip to extract the decrypted NAND. You can grab it from the releases page.
     
  16. AstralVoodoo

    AstralVoodoo Newbie
    Newcomer

    Joined:
    Jan 12, 2011
    Messages:
    6
    Country:
    recived this error "open error: can not open the file as [fat] archive"
     
  17. mondul

    OP mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    113
    Country:
    Colombia
    If the previous version does not work for you then your dump is corrupted
     
    alexander1970 likes this.
  18. AstralVoodoo

    AstralVoodoo Newbie
    Newcomer

    Joined:
    Jan 12, 2011
    Messages:
    6
    Country:
    I update 7zip to latest 19 version, and install all fine, without error
     
    KEHT and alexander1970 like this.
  19. alexander1970

    alexander1970 Jodelhoiti....
    Member

    Joined:
    Nov 8, 2018
    Messages:
    12,921
    Country:
    Austria
    I can confirm you have to use the LATEST Version from 7z.I would have the same issue as @AstralVoodoo.
    After update it wokrs.

    Thank You.:)

    @mondul
    Thank you for this great tool for making the whole process quicker and easier for us. :bow:
     
    mondul likes this.
  20. YotiReal

    YotiReal Advanced Member
    Newcomer

    Joined:
    Aug 2, 2012
    Messages:
    81
    Country:
    Russia
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - [Release], platform, HiyaCFW