RCMLoader

Discussion in 'Switch - Backup Loaders & Modchips' started by pegasus123, Sep 26, 2019.

  1. pegasus123
    OP

    pegasus123 Newbie

    Newcomer
    1
    Jul 12, 2019
    Philippines
    Hi, When i plug my RCMLoader on computer it just blink twice like when you are pressing the + button. Its not turning white so i can update the payload.

    Tried with laptop and PC and different cables, all the same.

    No issues with injecting payload though. Any idea?
     
  2. lieder1987

    lieder1987 Advanced Member

    Newcomer
    5
    Sep 24, 2017
    United States
    Is your switch hackable?
     
  3. wurstpistole

    wurstpistole I got 8 warning points

    Member
    12
    Nov 19, 2015
    Gambia, The
    Did you read what he wrote?
     
    DCMaxxx and zxr750j like this.
  4. Itsuki235

    Itsuki235 GBAtemp Regular

    Member
    1
    Jun 13, 2019
    United States
    Plug it in using the micro-usb port on the "bottom" using the included cord, not the USB-C port. If that does not work, what OSes are you using?
     
  5. Sora Takihawa

    Sora Takihawa Planeptunes Male CPU

    Member
    7
    Oct 11, 2015
    Germany
    Planeptune
    dont plug in the usb c port on pc its not for data writing only loading use the micro usb port thats for pc
     
  6. lieder1987

    lieder1987 Advanced Member

    Newcomer
    5
    Sep 24, 2017
    United States
    Apparently not. Please disregard all dumb questions of dumb people.
     
    zxr750j likes this.
  7. pegasus123
    OP

    pegasus123 Newbie

    Newcomer
    1
    Jul 12, 2019
    Philippines
    No no i know how to plug it. i plug it in the micro usb, i dont have USB C port on my PC.

    I'm using Windows 10. I am trying to update the Payload but when i plug it in my computer using the included micro usb to the "bottom" and plugging USB to PC, it just blink twice. It's not turning to mass storage.

    Not sure if there is solution just checking though. No issues with injecting payload to switch though now im stuck with hekate 5.0.1.
     
    Last edited by pegasus123, Sep 27, 2019
  8. Itsuki235

    Itsuki235 GBAtemp Regular

    Member
    1
    Jun 13, 2019
    United States
    Try a different OS maybe? A linux boot disk might make it mount normally.
     
  9. pegasus123
    OP

    pegasus123 Newbie

    Newcomer
    1
    Jul 12, 2019
    Philippines
    I tried using ubuntu, didn't work. I guess this is dead and stuck forever.

    Looks like it doesnt matter where i plug it, i plug it on power bank and it does the same, just blinking twice instead of "white" charging color. Thanks!
     
  10. Yiffna

    Yiffna Member

    Newcomer
    5
    Mar 7, 2017
    UK
    Are you using the supplied short cable. I had this problem when using a longer cable.
     
  11. pegasus123
    OP

    pegasus123 Newbie

    Newcomer
    1
    Jul 12, 2019
    Philippines
    I tried multiple cablea and the included one all does the same. Tnx i think this is stuck now :)
     
  12. Retroboy

    Retroboy GBAtemp Addict

    Member
    9
    May 28, 2015
    check device manager in win10 make sure its installed drivers for it, or if its showing as unkown device
     
  13. Teletron1

    Teletron1 Space Tech Engineer

    Member
    4
    Jan 4, 2019
    United States
    EARTH
    what firmware is on the RCMLoader?

    Firmware update instruction
    1.Download the firmware file
    2.Unzip the firmware file.
    3.Connect the RCMloader one to your Computer via the MicroUSB cable.
    4.Copy the IAP folder to the root of USB drive.The file like this, USB DRIVE:\IAP\FIRMWARE.BIN.
    5.Un-plug the MicroUSB cable.
    6.Plug the MicroUSB cable again, the RCMloader will auto upgrade in 3 seconds, then the IAP folder in USB DRIVE should be auto deleted.
     
  14. ClickCLK

    ClickCLK Member

    Newcomer
    6
    Oct 21, 2009
    Serbia, Republic of
    Seems like microusb port connector inside your dongle is damaged or partially desoldered from board.

    If you have multimeter you can check this by connecting cable to microusb and check resistance to ground on D+ and D- pins (look for usb pinout on google). If one or both of them have very high resistance (more than 1mOm if I remember correctly) then it is indeed the problem.
     
Quick Reply
Draft saved Draft deleted
Loading...