R4 won't load themes

Discussion in 'R4 DS' started by emuart, Dec 15, 2007.

  1. emuart
    OP

    emuart Newbie

    Newcomer
    4
    0
    May 5, 2007
    United States
    Unknown
    Hi there,
    I hope this post isn't redundant, though I haven't been able to find a similar post in the forums. For whatever reason my R4 has stopped using
    the themes on the micro SD card and is only allowing my to use a really ugly one I assume is hidden somewhere in firmware or something. I've tried
    reloading several versions of the R4 software to fix the problem but nothing seem to work. Also some homebrew that requires support files such as fonts and such can't find their support files in the root directory, which I suspect is related to what is causing the skinning problems. Has anyone faced similar problems? Any help would be much appreciated. Thanks! Oh and I'm using mac osx.
     
  2. ZAFDeltaForce

    ZAFDeltaForce Specialist

    Member
    2,786
    208
    Sep 9, 2006
    Senegal
    Are the sizes of the images 144KB?
     
  3. AndreXL

    AndreXL GBAtemp Advanced Fan

    Member
    514
    0
    Dec 28, 2006
    Do check if you have the following folders on the root of your MicroSD:
    _system_\themes\theme01
    - where theme01 is from 01 to 12
    if not that's what you are missing.
    Firmware 1.11 has these folders in. The others do not have it in by default.
     
  4. emuart
    OP

    emuart Newbie

    Newcomer
    4
    0
    May 5, 2007
    United States
    Unknown
    All the folders are there. I should clarify, I had themes that I downloaded working and for some reason they stopped working.
     
  5. iritegood

    iritegood GBAtemp Advanced Fan

    Member
    759
    0
    May 15, 2007
    United States
    Do you have twelve? I think (I don't remember well) that if you have a missing theme the R4 ignores the theme folder altogether.
     
  6. callmebob

    callmebob The Grandpa of Awe!

    Member
    634
    68
    Jan 24, 2007
    Germany
    Bitburger Brewery (a lot)
    That is odd that it just stopped working.

    Have you tried, while still in the games/media/slot 2 menu, pushing select then A (over and over again) to manually cycle through the 12 themes?

    As far as I know, if you haven´t manually selected a theme, it will automatically skip to the next theme. (that being the next calender month. 12 themes 12 months.)

    Hope it´s some help, and if not, that someone else can. [​IMG]
     
  7. emuart
    OP

    emuart Newbie

    Newcomer
    4
    0
    May 5, 2007
    United States
    Unknown
    Yep, there are 12. Thanks though. When I push select and A it just goes to the games menu.
     
  8. DarkAura

    DarkAura Offline

    Member
    2,388
    17
    Aug 20, 2007
    Canada
    Over there.
    Uhh, are the images named background1, background2, icons and logo? There should be a theme ini, but it's not necessary.

    If nothing works, just reformat your Micro SD and try again.
     
  9. AndreXL

    AndreXL GBAtemp Advanced Fan

    Member
    514
    0
    Dec 28, 2006
    Yes, reformat and make sure you delete the file _DS_MENU.SYS
    It will create a new one.
    If you have the original theme from v1.11, test that as well.
     
  10. callmebob

    callmebob The Grandpa of Awe!

    Member
    634
    68
    Jan 24, 2007
    Germany
    Bitburger Brewery (a lot)
    If your were already in manual mode and you push select and A, it´s normal that you return to the menu, but now your in the automatic mode.

    Repeat the procedure, and it should show you a theme. You have to accept it. Repeat the procedure again, and it will show you the next available theme. Again accept it, and keep on repeating the procedure till you find the theme you want to keep.

    If you found your theme, you should now be back in manual form.

    I renamed all pics, like dark_aura said, and overwrote the files to the theme 12 folder. Then manually selected theme 12.

    If worse comes to worse, then do what the others said, and reformat and start from scratch.
     
  11. DarkAura

    DarkAura Offline

    Member
    2,388
    17
    Aug 20, 2007
    Canada
    Over there.
    Also know that the automatic mode changes depending on the month. (Like the 12th month is on the 12th theme). I didn't even notice that until lately.

    And also make sure that the image are in 24-bit bitmap format.
     
  12. emuart
    OP

    emuart Newbie

    Newcomer
    4
    0
    May 5, 2007
    United States
    Unknown
    Thanks for all the replies and help. I attempted to reformat the micro sd and now it won't work at all. I suspect that the key to my troubles is that I only have access to Mac osx. I can't figure out how to format to libfat in OSX, I hate to ask more of all of you but is there a secret to formating a micro sd card in OSX that I may be missing? I miss my DSorganize
     
  13. springah

    springah GBAtemp Regular

    Member
    117
    0
    Aug 1, 2006
    Sydney, Australia
    had the same problem,

    rename _system_ and everything under it in CAPS. fixed my problem.