Question about Cubic Ninja and boot loading

Discussion in '3DS - Flashcards & Custom Firmwares' started by spinner09, May 19, 2015.

  1. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    I have an old 3DS XL which has been primed with the blue cart DS mode profile hack (which is required to use Gateway and 3DS-Link, etc). I have since sold my flash cart, but my 3DS is still primed to boot the launcher on the SD card, if I need to. Is there anyway I can use this to launch CFW or Ninjahax without a copy of Cubic Ninja?

    If not, is there anything I can do at the moment (hacking/modding wise) without having to purchase another flash cart or Cubic Ninja?
     
  2. dedChar

    dedChar (ノಠ益ಠ)ノ彡┻━┻

    Member
    260
    66
    May 5, 2015
    Gambia, The
    If the CFW you want to use is available to launch through the DS Profile Exploit, you can launch it that way. You can't launch Ninjhax without cubic ninja. (At the moment at least)
     
  3. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    MSET + O3DS = Probably 4.X.
    Check this thread and see if you can get something working, just note it won't be perfect.
     
  4. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
  5. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Thanks for the link, but one question;

    Is this still the case? I have never downloaded anything from the eShop, but my cart has connected online in the past.
     
  6. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    That's what I get for not paying attention...
    I recall something about using I think the MT-Card launcher (or one of the clones that didn't require a card be inserted) to launch EmuNAND, which is why it wasn't compatible to latest.
    I don't know more than that, perhaps others know more or that info suffices to search.

    Alternatively, you can google the small realm of "Legit CIAs" and find those, which work even when signature checks aren't disabled. You could then use something like RxTools to get to a 9.7 EmuNAND, though without arbitrary CIA installation.
     
  7. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Wow, so complicated.... So all that just to install a game from the eShop so I can follow the guide above to install devmenu, so then I can install Cubic Ninja cia, so then I can install custom firmware. Am I right? I'm pretty much screwed. :(
     
  8. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    Nah, that wasn't for much of anything, what I last said was to have a hackable sysnand and an updated emunand with a small collection of cia games.

    Perhaps this thread is more on the vein of what I was thinking originally. (This for CFW, not what I just said above)
     
  9. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Okay, ty. Thanks for the help. Is there any way to use this method to install a Cubic Ninja cia, so I can run ninjahax? Like what was posted here: http://www.maxconsole.com/maxcon_fo...-Dual-boot-Emunand-CFW-(NinjaHax)-one-SD-card
     
  10. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
  11. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Okay, I followed all the steps in this guide. I have the CFW running, I have BigBlueBox (devmenu), and I installed the Cubic Ninja cia. But every time I run it, it either drops to a blank screen, or gives the "SD card has been removed" error. WTF?
     
  12. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    I would not happen to know, unfortunately. I've never tried 4.5 CFW myself, only seen enough to know it exists.

    Provided your setup is working and you're booting it properly, it shouldn't hurt to experiment, (some homebrew is available in CIA, for example) I just don't have any directions.

    If it's booting the CFW, though, the hard part is over. Some thought and testing should hopefully lead to a good setup.
     
  13. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Okay, but my goal is to eventually get Pasta CFW installed. The one here: https://gbatemp.net/threads/pasta-c...d-on-old-and-new-3ds-required-ninjhax.388925/

    It says it requires Ninjhax, which is what I'm trying to achieve. Can you help me out?

    Is it impossible to get Pasta installed without a legit Cubic Ninja cart? There's no way to install it via Devmenu in the 4.5 CFW I just installed?
     
  14. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    That'd be redundant. A 4.5 CFW can already run unsigned CIAs (which is presently the only thing Pasta does), though since 4.5 CFWs typically use EmuNAND DSi/GBA won't work.
    If those are what you're after, you'd want PBT in this situation, still not particularly necessary to have Pasta, though without an EmuNAND you'll be running 4.5 on both ends (not that the GBA or DSi titles care)

    If you still specifically want Pasta it'd be simplest to get a CN/Sky and update to 9.2 somehow. The only use of a CN CIA I presently see is running NTR from Pasta, which doesn't apply to O3DS units anyway.
     
  15. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Good news, I finally found a working Cubic Ninja cia (I downloaded a different one from elsewhere), and I just managed to get it installed and working. I was thrilled for a moment, then I read your post dkabot, and realized it was all for nothing. :(

    Oh well, it was a learning process. Thanks for the help. Can you link me to any guides/tutorials for PBT? I don't really care for DSi/GBA games, so I could stick with this Palantine CFW that I have installed. The only problem is, that it takes about 5 attempts to get it to run from the DS profile exploit (Most of the time it crashes, and I have to hard reset my 3DS). And also, I read elsewhere that CIAs are very touch and go (many don't work based on how they were compiled). Plus, since the CFW is 4.5, I'd assume I can't run newer games either. So what would be the best solution for me?
     
  16. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    I'd say the only solutions at this point are either go legit (theoretically) and update, learn how to work with the CFW you just installed or buy something (Sky, GW, CN, whatever).
    Since going legit defeats the purpose here and the 4.5CFW is apparently lacking, the remaining option is to purchase something.
    If we're going into the land of SOON(TM), you could wait it out and see if someone somehow manages MSET for Pasta, then you'd need only borrow CN/send the 3DS to a trusted member with it. (Though that's not a promise it'll happen.)
     
  17. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    Thanks a lot for all your help man, I think I'll just wait it out and learn to work with this CFW. You've been a big help, I really appreciate it.

    I have one last question; is there anyway to run a CFW for a higher Emunand version (say 9.2) that can run unsigned CIAs with devmenu?
     
  18. dkabot

    dkabot Better With Others' Systems Than Their Own

    Member
    1,000
    349
    Sep 9, 2014
    United States
    The title of the second link says it's a 9.4 EmuNAND, so what you have can but as far as I know nothing else can (sans GW itself and RxTools which lacks unsigned CIA support), but remember that this method may never be capable of > 9.4
     
  19. spinner09
    OP

    spinner09 GBAtemp Regular

    Member
    140
    100
    Nov 11, 2013
    United States
    There's something faulty with his guide though. I was stuck at the first section (after updating emunand to 9.7) only to learn that you can't boot emunand's higher than 7.0 without a physical Gateway card.

    I will try the RxTools method shortly.