Problem with R4i 3DS

Discussion in 'R4 DS' started by wiismodrome, May 11, 2013.

  1. wiismodrome
    OP

    wiismodrome flubber

    Member
    553
    63
    Feb 7, 2012
    Sweden
    I bought an R4i 3DS for my friend's daughter for Xmas which was purchased from www.zhuzhuchina.com and appears to be one of the problematic (www.r4ids.cn) Revision C cards. But that has not been an issue because she does not have a 3DS and does not require a newer firmware for compatibility with her DSi XL. The R4i card has version 1.4.5U and displays the Metroid Prime Hunters Demo icon.

    Up until just recently, it has been working well with her DSi XL. Unfortunately, something has changed and now whenever the Metroid icon is selected the DSi displays the "An error has occurred..." message.

    To my knowledge, no one has tried to update or change anything on the inserted micro SD card. I've tried loading firmware updates, but keep getting the same error message, without being able to select anything. Is there an easy fix for this, or has the card failed? It doesn't need the most recent firmware, just something to get it working with the DSi once again. I'm not very familiar with flashcards. Any help would be appreciated.

    Thanks!
     
  2. TackyPie

    TackyPie GBAtemp Fan

    Member
    304
    43
    Jul 4, 2012
    United States
    try reformatting the sd card
     
  3. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Firmware updates do not take effect by simply placing them on the MicroSD (unlike game compatibility updates)... but it's not certain the firmware version is the issue here.
     
  4. wiismodrome
    OP

    wiismodrome flubber

    Member
    553
    63
    Feb 7, 2012
    Sweden
    OK... tried reformatting with SD Formatter. Still getting the "An error has occurred..." message.

    From other threads, I got the impression that it might be worthwhile to flash it with an older firmware, then update it again.
     
  5. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You'll need an older DSi/XL or any DS Lite in order to do any sort of flashing/updating to the firmware of the cart.
     
  6. wiismodrome
    OP

    wiismodrome flubber

    Member
    553
    63
    Feb 7, 2012
    Sweden
    The card is being used in a DSi XL. I'm not sure I understand. Won't that work? I'm not using the R4i with a 3DS, just an old DSi XL.
     
  7. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    As I pointed out, simply placing files on a MicroSD is not doing a firmware update. You need to RUN the update in order for it to... you know, update. :P

    But you can't run it, right? So you need to be able to run it to do anything.

    Which means an older DS that does not block flash carts.
     
  8. wiismodrome
    OP

    wiismodrome flubber

    Member
    553
    63
    Feb 7, 2012
    Sweden
    Still not quite sure...

    AFAIK, this DSi XL has never been on the net nor has it been updated from Nintendo. It has only been used offline and should still have the original firmware. So, I'm not sure that the DSi XL is actually blocking the cart.

    If I can get an update to run, which update should I use?

    Thanks for the help!
     
  9. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    The DSi XL is blocking the cart. That error message is from the DSi XL, and is what it says when it actively refuses to run a cart.

    The DSi XL came out November 2009, but firmware 1.4.5 came out in December 2012. if you got the DSi XL earlier than that, then 1.4.5 isn't the base firmware. Regardless, we have seen instances of carts fucking their own bootloader/firmware for various technical reasons. If this happens and it's not a contact issue or MicroSD issue, the firmware needs to be re-written via an update (the "updates" just re-write the whole thing at once each time) anyways.

    But in order for the firmware update to actually take place, you need to RUN THE UPDATE, which means the flash cart needs to start. But right now it cannot, because the DSi XL will not start it. So you need another DS that will start it so that you can run it.
     
  10. wiismodrome
    OP

    wiismodrome flubber

    Member
    553
    63
    Feb 7, 2012
    Sweden
    Thanks for the more detailed explanation. That makes sense. Perhaps she (or more likely her older brother) enabled Wi-Fi and updated the DSi's firmware? Will see if I can find an older DS....

    What is the best firmware for a Rev C R4i 3DS?
     
  11. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Even attempting to access the DSiware/e-shop will make you update before you get in.

    Firmwares are cart-specific, you get it from the site printed on the cart.
     
  12. wiismodrome
    OP

    wiismodrome flubber

    Member
    553
    63
    Feb 7, 2012
    Sweden
    Borrowed an old DSi from a friend and ran the January 23, 2013 R4iGold_NDSi145_Patch from www.r4ids.cn, plus installed the latest Wood v1.58. I was somewhat concerned that this Rev C card might not be upgradable, but the update worked without issue and the flashcard works once again in the DSi XL. It displays a new icon: "DORASU". Thanks for the help Rydian; this will make a little girl very happy!