Problem with loading roms from DVD

Discussion in 'Wii - Emulation and Homebrew' started by Selim873, Mar 6, 2011.

Mar 6, 2011
  1. Selim873
    OP

    Member Selim873 Nunnayobeesnes

    Joined:
    Jul 31, 2010
    Messages:
    1,132
    Location:
    Chillin' with Bob Ross
    Country:
    United States
    Hey guys, I've had a collection of Roms with me, so I decided to burn a data disc. I burned it with IMGBurn on the "Write Files/Folders To Disc" mode on a DVD-R at 3x. Here is what the disc's file system is like, the whole code box is the root folder.

    Code:
    GENESISÂÂ>ÂÂ(Roms Here)
    |
    SNESÂÂ>ÂÂ(Roms Here)
    |
    NESÂÂ>ÂÂ(Roms Here)
    |
    PSXÂÂ>ÂÂ(ISOs Here)
    The latest version of WiiSX is perfect, but the other three emulators won't read the DVD... It's a 50 out of 50 (No joke, out of 4 tries each emulator [​IMG] ), I either get an Unrecognized DVD Format error, or a code dump... WiiXplorer refuses to read it as well, it'll just show a blank directory. When I hit remount, code dump... Wii64 is able to read the discs, but it was made from the same developers as WiiSX, plus, I don't have N64 roms so it'd be pointless, but I decided to try to expand on my issue a bit.

    I obviously have DVDX installed, and I can run Wii and Gamecube (Single and MultiGame) flawlessly.

    I also have a second question, WiiSX always refuses to save my game to the SD card, and when I tell the saves to go to my GCN Memory Card Slot A, the whole console freezes, out of both of my flash drives, my 4GB holds 5 games as a WBFS storage device, and my other one is a 2GB MicroSD card that powers my R4DS. So I can't try to save on USB.

    EDIT: Tried using my last DVD-R by burning every rom except the PSX ISOs onto the root, no folders, and at a slower speed... Didn't work, yet the WiiSX emulator can access it as well.
     
  2. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    Only WiiSX and Wii64 still support DVDX, other emulators doesn't anymore and use the HBC "AHBPROT" feature instead.

    To enable it, make sure the meta.xml files for your emulators have the line. All these things are pretty well explained in the user manual of said emulators so go read them.
     
  3. Selim873
    OP

    Member Selim873 Nunnayobeesnes

    Joined:
    Jul 31, 2010
    Messages:
    1,132
    Location:
    Chillin' with Bob Ross
    Country:
    United States
    They already have the line. What do I do now? I read the emulator's readme's and manuals from their sites, but nothing helped.

    EDIT: Hold on, I think I misunderstood you at first, give me a few minutes.

    EDIT2: Didn't get anything... :\
     
  4. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    Most likely, you didn't burned the DVD in the correct format (ISO9660).
    WiiSX/Wii64 might use a different library to access DVD which could be less restrictive, I don't know, I have no trouble loading ROMs from DVD in any of these emus.

    ALso, i'd unconnect my WBFS formatted drive if I were you since no emulators is going to recognize it anyway and it could be the cause of your crashes/freezes
     
  5. Selim873
    OP

    Member Selim873 Nunnayobeesnes

    Joined:
    Jul 31, 2010
    Messages:
    1,132
    Location:
    Chillin' with Bob Ross
    Country:
    United States
    For now, I'm just going to export all the games from my USB drive and keep them stored in my PC and hold my roms in that same drive until I get something figured out with the DVD issue, because I'm sure that I burned it in ISO9660 Format, as that is IMGBurn's default.

    Once I get it figured out I'll edit this post, if anybody else has suggestions, please post! [​IMG]

    Plus, unplugging the drive while it was in WBFS format didn't fix it either...
     

Share This Page