Pokemon HeartGold Lag Problem?

Discussion in 'NDS - Console and Game Discussions' started by BBqBanana, Apr 3, 2010.

Thread Status:
Not open for further replies.
  1. BBqBanana
    OP

    BBqBanana Member

    Newcomer
    19
    0
    Apr 3, 2010
    Hello peoples,
    I used to play Pokemon HeartGold on the normal R4 with YSmenu and it worked perfectly with it patched, but after my R4 broke, I cannot play it properly.

    So right now... I bought a R4i Gold with the latest firmware 1.31b and I wanted to try Pokemon HeartGold on it, after I boot up the game and loaded my save file, the game works, but it is really delayed and slow... :|
    EDIT: I actually use R4i Gold with the site R4iGold.cn. With patch 1.8b

    For example when I load it, it takes a while to load up to the place, when I go in my item screen, it has a 1-2 second delay while selecting items (even in battles) and each time when I walk into a new area, the black screen comes up and it takes forever to load.

    I used Rudolph's Universal Child's Play patch for HG(U).

    I was told that I needed a clean/dump rom of HeartGold to patch it, but the one I used is Xenophobia...(Which I'm quite not sure if it is clean or not.)

    So can anyone please help me here?

    [​IMG] I'm on the seventh badge and about to battle the last one.

    Thanks [​IMG]
     
  2. altorn

    altorn GBAtemp Advanced Fan

    Member
    600
    0
    Jul 15, 2007
    Canada
    Toronto, Ontario
    did you try other games if they play slow too? if so, its ur microSD card/flashcart's firmware.
    if its the pokemon game only, its your rom.
     
  3. The Pi

    The Pi Lurker

    Member
    1,638
    67
    Mar 18, 2010
    Scotland
    Xenophobia is the handle of the person who dumped the rom ... it's a clean rom i had the Xenophobia dump myself but swapped to the BAHAMUT dump since its the euro ver.


    the lag is because of the patch use a clean dump on a ak2i + akaio ... go buy one

    problem solved [​IMG]
     
  4. BBqBanana
    OP

    BBqBanana Member

    Newcomer
    19
    0
    Apr 3, 2010
    Ah thanks for the replies guys, I figured out the problem, my microSD card was 4gigs, which made my R4 run quite slow.
     
  5. Tac 21

    Tac 21 GBAtemp Advanced Fan

    Member
    553
    1
    Feb 2, 2008
    Canada
    I noticed a sluggish menu and battle preform my r4i gold with an old 2gb kingston

    used a U1 samsung 32GB.... holy man... platinum and soul silver ran super fast! its the SD card for sure- even modded games run super fast
     
    Last edited by Tac 21, Nov 20, 2017
  6. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,069
    4,750
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    thread from 2010, will be locked after i comment.
    just want to finish the thread, i own the original games and they are have delay\lag by default. it is something that bothers me when i start to play but eventually get used to it...

    as for knowing if the rom is a clean dump, you can use a checksum tool (i recommend installing hashtab, a really cool free tool that implements checksum testing when you see the proprieties of files in windows)
    and compare the hash (either md5 or sha-1, doesn't matter which) with this database: http://datomatic.no-intro.org
    (search for the game name, in heartgold case, search for heartgold, select the rom you have, usually it's the US version, compare the numbers)
     
Thread Status:
Not open for further replies.