Please Help!!

Discussion in 'R4 DS' started by V!olaPlayer, Jan 22, 2008.

Jan 22, 2008

Please Help!! by V!olaPlayer at 11:07 PM (719 Views / 0 Likes) 2 replies

  1. V!olaPlayer
    OP

    Member V!olaPlayer GBAtemp Regular

    Joined:
    Jan 8, 2008
    Messages:
    246
    Location:
    Central Florida
    Country:
    United States
    Hi,
    I recently got my R4 from Volumerate (Not there anymore), and ever since, it has been working perfectly fine.
    2 days ago, I was going to play Trauma Center, and then about a minute into the game, the DS just shut off. So, I turn it on again, and a white screen pops up for a millisecond, then the DS turns off. I panick. I apply compressed air on the connectors, then put it back it, and it works again, but the same problem happens. It's not the power, or the DS itself but the r4,

    Any suggestions on what to do?

    Please help!! :'(
     
  2. DarkAura

    Member DarkAura Offline

    Joined:
    Aug 20, 2007
    Messages:
    2,388
    Location:
    Over there.
    Country:
    Canada
    Maybe the air that you sprayed on killed it. Air corrodes the connectors, as I learned not too long ago. Or you may want to try the paper trick.
     
  3. V!olaPlayer
    OP

    Member V!olaPlayer GBAtemp Regular

    Joined:
    Jan 8, 2008
    Messages:
    246
    Location:
    Central Florida
    Country:
    United States
    Well, thanks for posting, but it didn't solve the problem. The R4 isn't the source of the problem. It is the actual DS. There is a wire connecting something that is not connected whenever I open the DS (while on) to its full extent. About one CM from opening it fully, the DS turns off.

    Now I know my DS is damaged, and I don't have my warranty anymore. Any good (cheap) and reliable places to repair it??
     

Share This Page