PKMN Black Hacking: Negative Colors?

Discussion in 'NDS - ROM Hacking and Translations' started by supagokuman2, Jun 5, 2012.

Jun 5, 2012
  1. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    So I'm trying to do a hack for Pokemon Black, and right now I need to edit Cheren and Bianca's sprite. In BWME, their mugshots (Vs sprites) are in negative colors or something. When I replace them with my own mugshot, it glitches up completely (While in BWME!)

    In BWSE, I can't even find Cheren or Bianca. I will find them soon, but they will also be negative, I bet. I've heard that you must use the image's original colors on your own mugshot so that it doesn't glitch, but how am I supposed to do that?

    I know how insert my narcs into my game and do everything just fine, I'm just stuck on these negative colored sprites :(

    Please Help?
     
  2. Sora de Eclaune

    Member Sora de Eclaune Baby squirrel, you's a sexy motherfucker.

    Joined:
    Feb 15, 2011
    Messages:
    2,785
    Location:
    123 Fake Street
    Country:
    United States
    A friend had a similar problem with a 2D game. Have you tried loading the palettes, if you can?
     
  3. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    I beg your pardon? :S
    I know what they are, just don't know how to edit them.
     
  4. Sora de Eclaune

    Member Sora de Eclaune Baby squirrel, you's a sexy motherfucker.

    Joined:
    Feb 15, 2011
    Messages:
    2,785
    Location:
    123 Fake Street
    Country:
    United States
    Well when this problem arose for my friend, they tell me it was because they loaded in the wrong palette or didn't load one at all. It's not that you edit them, it's that you just have to load them.
     
  5. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    Well, I have a mugshot ready to replace Cheren, and it was made from scratch (or from another base, I'm guessing) how do I make it so that I can replace Cheren's mugshot? When I imported it, it glitched up MASSIVELY, the mugshot was no longer visible, lol. I tried using negative colors on it, still nothing. If I knew how to edit the colors so that they match the original one's I would do it, it's probably why it doesn't work.
     
  6. KazoWAR

    Member KazoWAR GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2008
    Messages:
    1,749
    Location:
    Winter Haven
    Country:
    United States
    what image are you trying to import.
     
  7. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    Images. not image:
    [​IMG]
    [​IMG]
    And 2 others (For Bianca)
     
  8. KazoWAR

    Member KazoWAR GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2008
    Messages:
    1,749
    Location:
    Winter Haven
    Country:
    United States
    the mug shot contains 233 colors due to all the artifacts on the image, did you save it as a jpg at one point?
     
  9. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    Yeah I got it to 16 colors fixed.

    But now when I use it in-game he is REAALLY messed up. There are no transparent spots, just color glitches.
    Same goes for Bianca and Hilbert, who I also edited. They are all in 16 colors. I used Save for Web & Devices and it says Colors right there, so I edited it to 16.
     
  10. KazoWAR

    Member KazoWAR GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2008
    Messages:
    1,749
    Location:
    Winter Haven
    Country:
    United States
    did you compress the sprite data?.... actually let me go update BWME to use dsdecmp.


    *edit*
    https://dl.dropbox.com/u/3706406/Files/BWME%201.1.rar
     
  11. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    Nice! But, I can't seems to find Cheren and Bianca's sprites. If I continue on after 14, it says DSDecmp failed to decompress the file.
    Plus, why are the files' colors all weird?
    [​IMG]
    If it's supposed to be this way, then maybe that's why my mugshots won't work.
    Although Hilbert wasn't color-weird before, Cheren and Bianca always have been this way to me.
     
  12. KazoWAR

    Member KazoWAR GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2008
    Messages:
    1,749
    Location:
    Winter Haven
    Country:
    United States
    try starting over with a clean, unmodified narcfile.
     
  13. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    Still the exact same.

    Here is a comparison to how the 2 BWME versions show Cheren's mugshot (NOTE: I used kiwi.ds decompressing for these, NOT Tinke. It does not even show Cheren's mugshot using Tinke)

    [​IMG]
    And this is my NEW fixed mugshot:
    [​IMG]

    WHAT am I gonna do? :(
     
  14. KazoWAR

    Member KazoWAR GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2008
    Messages:
    1,749
    Location:
    Winter Haven
    Country:
    United States
    send me the folder you use in the program
     
  15. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    I PM'd you the folder.
     
  16. KazoWAR

    Member KazoWAR GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2008
    Messages:
    1,749
    Location:
    Winter Haven
    Country:
    United States
    the images are loading perfectly fine, i have no idea what could be causing such a weird glitch. try importing your sprite and testing it ingame.
     
  17. supagokuman2
    OP

    Member supagokuman2 YouTube Gamer

    Joined:
    May 7, 2012
    Messages:
    146
    Location:
    San Antonio, TX
    Country:
    United States
    Ok I don't know WHAT is going on with my PC, I extracted the 0 folder that was in the 180.rar and loaded it onto BWME v1.1, and it loaded the images perfectly.

    EDIT: I think I know what is the problem, I did LZ Bacth Decompress on 0_000, 0_002, and 0_003 using kiwi.ds like I did with BWME v1.0 (and I placed the decompressed files in the 0 folder), this time I loaded the 0 folder straight into BWME after extracting it.
     

Share This Page