My x360 can't play L4D 2

Discussion in 'Xbox 360 - Games & Content' started by Revolution89, Nov 18, 2009.

  1. Revolution89
    OP

    Revolution89 Member

    Newcomer
    33
    0
    Sep 13, 2009
    Somewhere in My Room
    My uncle give me a modded x360 after my examination and he also said that the firmware already been updated. Yesterday, he gave me the new L4D 2 game(pirated), but when i run the game,the console alwys telling me to update my 360. The only way i can play the game is by removing the hardrive and it can only play the single mode. I wanted to play the multiplayer mode with my brother.Can anybody help me?
     
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,859
    9,766
    Nov 21, 2005
    United Kingdom
    Several things could have happened here:
    1) the game has been patched to wave 3 (I ventured onto the torrent sites and was shocked at what I saw going on). You can check the disc with abgx360 and it will tell you if you.
    The game however looks for what is the current dashboard update and will tell you it needs to be updated before it can play (if you have patched to wave 3 this update will not be included), removing your hard drive probably just makes the game fall back to a "compatibility mode" of sorts which will allow basic play.

    Two options here:
    a) If it is not homebrew capable or you just do not care for it then update by hand: http://www.xbox.com/en-US/support/systemus...stemupdates.htm

    b) If by some miracle you are still on a 7 series kernel then I would suggest sorting homebrew out and using the rebooter app (development has slowed but a homebrew capable 360 is set to be a wonderful thing- region free and beyond). This is in the territory of full blown homebrew though and somewhat complex.

    2) You have a 1.61 on a samsung or benq drive or a hitachi drive with 1.51 (the only modern hacked firmwares that can boot wave4 and seemingly beyond unaided) and have been blocking the update by yourself. Let it happen if you want.
     
  3. Revolution89
    OP

    Revolution89 Member

    Newcomer
    33
    0
    Sep 13, 2009
    Somewhere in My Room
    Thanks for the information.
     
  4. Maz7006

    Maz7006 iSEXu

    Member
    3,636
    35
    Aug 2, 2008
    No intention of hijacking this thread but what is the possible solution for people with ixtreme 1.6 on lite-on.
     
  5. KirovAir

    KirovAir Dutch Alcoholic Programmer

    Member
    587
    24
    Dec 7, 2006
    Netherlands
    Netherlands
    None yet, wait for iXtreme LT.

    Or, temporary replace you drive.
     
  6. martin88

    martin88 GBAtemp Advanced Fan

    Member
    990
    1
    Dec 18, 2005
    Canada
    Can't you just use activate.iso to play Wave 4/5 games on Liteon iX 1.6?
     
  7. Maz7006

    Maz7006 iSEXu

    Member
    3,636
    35
    Aug 2, 2008
    So activate ISO will work fine with wave 5 games as well with lite-on ix 1.6?
     
  8. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,859
    9,766
    Nov 21, 2005
    United Kingdom
    Activate.iso disables checks (although it will still use/comply with stealth if it can) which are what is triggered when attempting to play a wave not officially supported.
     
  9. moosh01

    moosh01 GBAtemp Fan

    Member
    306
    0
    Nov 9, 2008
    United States
    @ OP. Just update. If you are playing online then it is just a game patch. If offline it is just a dashboard update.