Mother 3 keeps freezing on my EZ-Flash IV

Discussion in 'GBA - Flashing Hardware and Software' started by MM6, Aug 5, 2016.

  1. MM6
    OP

    MM6 Member

    Newcomer
    11
    1
    Aug 5, 2016
    Western Aussie
    Hey everyone, I'm new to GBAtemp. Hopefully I'll make a good first impression ;)

    One of the reasons I joined the site was to try to figure out a way around a crash I keep getting during the beginning of chapter 7 (on the mother 3 English translation v1.2)

    The crash occurs just after the cutscene of the first needle getting pulled. And when Aeolia disappears the game locks up. I'm assuming the effect used in the cutscene is not compatible with my firmware installed on my EZ-Flash IV. I'm running 1.77 which is the latest.

    So any ideas guys? Mabey you have been experiencing the same problem too?
     
    Last edited by MM6, Aug 5, 2016
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,204
    8,970
    Nov 21, 2005
    GBA supercards aside the firmware of a GBA flash cart should have no bearing on this sort of thing -- it is not like emulation or anything like that and there are no chips it might not emulate properly.
    I have not heard of this one so it is not likely to be a fault with the patched ROM, though if you want to get there in an emulator and check then it would not be a complete waste of time.

    Three reasons likely for it
    1) Contacts on your EZ4 and/or GBA are not great. Clean them (rubbing alcohol or pure acetone nail polish remover or non automotive contact cleaner, basically a solvent/cleaner that is not going to leave anything behind) and it might come back. Poor man's equivalent is removing and inserting the cart a bunch of times. You might also want to take the case off, double up a bit of paper and put it between the case and the back side of the contacts to try to force better contact.
    2) You lost contact momentarily when writing it to the NOR. Delete it and write it again. You can also try cleaning the mini/microSD slot and the contacts on your cart.
    3) Your NOR section is corrupted somehow. Not terribly likely but not impossible. There is not a lot you can do to demonstrate it, short of writing many different sized things and seeing what is corrupted.
     
  3. MM6
    OP

    MM6 Member

    Newcomer
    11
    1
    Aug 5, 2016
    Western Aussie
    I see, thanks for your suggestions. I have a feeling it's a crappy ROM file. I'm going to rewrite to the NOR as well and give everything a good clean with some uvex alcohol wipes I've got.

    The game has had some music playback issues at some points too, anyways I'll let you know how it all goes in a bit :)
     
  4. MM6
    OP

    MM6 Member

    Newcomer
    11
    1
    Aug 5, 2016
    Western Aussie
    OK, so guys if you ever have an issue like this, re-writting the NOR will probably fix it. After rewriting I was able to get past the crash point. Thanks a lot Fast6191!

    I have had some issue with the NOR before too. seems to be working fine at the moment though.
     
    Last edited by MM6, Aug 6, 2016
    VinsCool likes this.
  5. Lemmy Koopa

    Lemmy Koopa M3 Perfect fanboy

    Member
    347
    282
    Sep 17, 2012
    United States
    Ohio
    So, first EZ4 I bought actually had a really bad problem with the NOR. It would degrade/corrupt overtime after a write. I found out about this when writing PocketNES to NOR, and the sprites would pop up as garbled garbage when starting an NES game. It would be garbled and after a certain amount of time, it would go to normal, kind of like the sprite was loading mid-game or something?

    As time went on, the wait for the sprites to no longer be garbed got longer, and longer, and longer.

    My solution: Buy another EZ4 with a proper NOR. Problem was fixed.


    Anyways, my point being, maybe you have this problem. It's terribly fucking annoying, and it's really bad on EZ4's part. That is bad quality control. I know it's a chinese product, but seriously.
     
  6. MM6
    OP

    MM6 Member

    Newcomer
    11
    1
    Aug 5, 2016
    Western Aussie
    Ahh man that's horrible. I really like the EZ4 but it is pretty rough around the edges. Menu system is in three different types of measurements for bits and bytes and the text dosn't even wrap properly.

    Hopefully my NOR isn't buggered :(