NULL

Laptop only wakes from sleep within a short period of time

Discussion in 'Computer Hardware, Devices and Accessories' started by EmulateLife, May 26, 2019.

  1. EmulateLife
    OP

    EmulateLife GBAtemp Advanced Fan

    Member
    3
    May 13, 2019
    United States
    Weird thing I have a laptop that I have hooked up to my TV with HDMI so I can watch streams and things like that. I want to be able to keep it in sleep and just wake it up any time with my wireless mouse. If I just put it to sleep I can, but if it's been awhile (like 1 hour+ or maybe less than that) the mouse does not wake it up and I have to get up and hit a button on the laptop to wake it up. There is nothing in the bios about waking from usb when I looked.

    Edit: just checked in Device Manager > Mouse and "Allow this device to wake the computer" is checked already.
     
    Last edited by EmulateLife, May 26, 2019
  2. MythicalData

    MythicalData GBAtemp Advanced Fan

    Member
    5
    May 11, 2017
    United States
    Might be in your power and sleep settings. "In addition, go to Control Panel-> Power Options-> Change plan settings-> Change advanced power settings -> Sleep -> Hibernate after -> here put both "never". There you can set after how many minutes the computer goes into hibernation mode andsleep mode. Change the time for hibernation"
     
  3. gooeywreck

    gooeywreck Member

    Newcomer
    4
    Aug 23, 2016
    United States
    mine does the same thing i still haven't figured it out, i just set it to not fall asleep when it's plugged in and it solved my problem for now. It's under the power plan settings.
     
  4. EmulateLife
    OP

    EmulateLife GBAtemp Advanced Fan

    Member
    3
    May 13, 2019
    United States
    Well I'm putting it to sleep intentionally. So the only solution is to NOT let it sleep? That seems like a bug to me if a mouse can wake it within a few minutes it should be able to wake it any time.
     
  5. gooeywreck

    gooeywreck Member

    Newcomer
    4
    Aug 23, 2016
    United States
    MythicalData was right its the hibernation setting, i never turned it off
     

    Attached Files:

    Last edited by gooeywreck, May 26, 2019
  6. EmulateLife
    OP

    EmulateLife GBAtemp Advanced Fan

    Member
    3
    May 13, 2019
    United States
    My hibernating setting was off. But I think I solved it

    Change Advanced power settings > Sleep > Allow wake timers was set to "only important times" or something like that. I changed it to enabled. But I need to give it awhile like an hour and see if it wakes.
     
  7. gooeywreck

    gooeywreck Member

    Newcomer
    4
    Aug 23, 2016
    United States
    is your usb shutting off that could also be the problem
     
  8. EmulateLife
    OP

    EmulateLife GBAtemp Advanced Fan

    Member
    3
    May 13, 2019
    United States
    Yeah I think that's it because i just tried it and it won't wake again. How would I prevent usb from shutting off?

    — Posts automatically merged - Please don't double post! —

    Under my mouse in Power Management "Allow this computer to turn off this device to save power" is unchecked but unselectable.

    — Posts automatically merged - Please don't double post! —

    You never know with Windows 10 but I think I solved it this time. Advanced Power settings > usb settings> USB selective suspend setting > Disabled.

    Windows can make something that should be simple be so difficult.

    — Posts automatically merged - Please don't double post! —

    Still didn't work LOL Fucking Windows. I'm just going to not put it to sleep like you guys said and then turn it off at night.
     
  9. gooeywreck

    gooeywreck Member

    Newcomer
    4
    Aug 23, 2016
    United States
    yeah sorry man like i said i could never figure it out either lol
     
  10. MythicalData

    MythicalData GBAtemp Advanced Fan

    Member
    5
    May 11, 2017
    United States
    "When the Device Manager window opens, expand the Universal Serial Bus controllers branch, then right-click the USB Root Hub device and select Properties. Click the Power Management tab. If you want USBports to keep supplying power in sleep mode, just uncheck “Allow the computer to turn off this device to save power“ I would only do this for the ones you are actively going to be using though
     
  11. EmulateLife
    OP

    EmulateLife GBAtemp Advanced Fan

    Member
    3
    May 13, 2019
    United States
    I selected all 4 USB Roots because the mouse is the only thing I have plugged in to any usb. All 4 had "Allow the computer to turn off this device to save power" checked, so I unchecked them. Still wouldn't wake from sleep after a few minutes.
     
Loading...