IOS15 v257 and boot2v4

Discussion in 'Wii - Hacking' started by illinialex24, Oct 21, 2009.

  1. illinialex24
    OP

    illinialex24 GBAtemp Advanced Fan

    Member
    968
    0
    May 26, 2009
    United States
    The Midwest
    Does this brick your Wii. Having a downgraded IOS15 on startup of the Wii (from the trucha bug restorer, after downgrading IOS15 so you can run a patch on IOS36), does that cause boot2v4 to brick the system menu and will that affect the recovery menu if it does?
     
  2. SifJar

    SifJar Not a pirate

    Member
    6,022
    891
    Apr 4, 2009
    I'm pretty sure it doesn't brick the Wii, but you should still update IOS15 with TBR once you've patched IOS36.
     
  3. illinialex24
    OP

    illinialex24 GBAtemp Advanced Fan

    Member
    968
    0
    May 26, 2009
    United States
    The Midwest
    I know but from what I understand because I had preloader but specifically with the diagnostic disc check off and the block update patch running off an IOS with no trucha bug to run Brawl from the recovery menu and then load stack smash and then run TBR. The thing is, when it exits, it code dumps so the install is fine but it resets the Wii. So I need a way to make sure it doesn't brick if its downgraded.... And I dont have boot2v4.
     
  4. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    IOS15 has nothing to do with the System Menu. At worst that particular IOS would cease to function if it was left downgraded, but I don't think that even happens.
     
  5. illinialex24
    OP

    illinialex24 GBAtemp Advanced Fan

    Member
    968
    0
    May 26, 2009
    United States
    The Midwest
    I know that but from everything I have heard about boot2v4 is that the new boot2 version checks IOS versions and the system menu version in a manner of speaking, is it just the system menu and the system menu IOS or is it more to see if its downgraded past a certain point, which is why you can't have 3.3U or stuff on a boot2v4 Wii.
     
  6. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    It's not even that it "checks" if an IOS is below a certain version or not. It's an inherent incompatibility between older versions of IOS and boot2v4. If anything it's more like how stuff built for Windows 3.1 doesn't work on Windows 7 or things like that.

    Read this here:
    http://hackmii.com/2009/08/timing-is-every...ftmoddable-wii/
     
  7. illinialex24
    OP

    illinialex24 GBAtemp Advanced Fan

    Member
    968
    0
    May 26, 2009
    United States
    The Midwest
    Answered my questions perfectly thanks.