If you get a File Write error on your DS Linker

Discussion in 'Other Flashing Hardware & Software' started by Popin, Jan 28, 2008.

Jan 28, 2008
  1. Popin
    OP

    Member Popin GBAtemp Regular

    Joined:
    Aug 21, 2007
    Messages:
    190
    Country:
    Canada
    Symptoms :
    - No more games load and a "File Write Error!" message appears
    - In USB Mode you can see multiple .sav files with same name.

    Solution (Win XP) (please make backup before deleting, or maybe an admin could confirm it's the right way) :
    - Enter usb mode
    - Delete 1 of the multiple .sav file, don't select them all, Win will ask you if you want to delete each files
    - Delete LASTSAVE.SDB in DSYSTEM, which contains name of last save
    - Delete SYSTEM.SDB in DSYSTEM, which contains (I guess but not sure) content of last SRAM

    - From DS Linker webbie
     
  2. yus786

    Member yus786 GBAtemp Fan

    Joined:
    Oct 28, 2006
    Messages:
    304
    Location:
    Bradford
    Country:
    United Kingdom
    wow i was just about to come on here and write a topic about this file write error i was having, luckily i saw this

    this works using vista too as i just tried it.

    yus786
     
  3. Rizsparky

    Member Rizsparky Saiyan Prince

    Joined:
    Aug 13, 2007
    Messages:
    1,479
    Location:
    The Future
    Country:
    United Kingdom
    hmmm..... i will try this and bvylooking at the ds linker forum link i might work

    If it works my 'file right error' nightmare is over!!! [​IMG]
     
  4. TheLaw

    Newcomer TheLaw Newbie

    Joined:
    Feb 1, 2008
    Messages:
    2
    Country:
    Ireland
    After many hours trying to figure this out, I finally got "my sims" to work.

    Like many people who own N-cards or clones at some stage or another they have experienced the "file wrie error" fault. There have been people who had just got bad roms, bad save files or just needed to reformat.
    However in my case none of the above would work. I purchased 3 fire cards from DX about 3 weeks ago and put a nice one together for a niece of mine for her birthday. The game she wanted the most was My Sims.
    There was about 30 roms on it so there was plenty of space, and all the roms worked fine until I tested My sims. BAM File write error. I deleted the D-system folder and all save files to get it back running but it did not solve my problem of wanting mysims on the card. I tried everything including d/l from numerous sources, tried all regions, reformatted, new firmware, old firmware, n-card, fire and linker firmware, new card, new cable, different pc, new gba adapter, usb1.1 and usb2.

    To solve this I just got the save file from another rom (256k).
    Saved a copy of it on the card
    Renamed it my sims.sav
    And voila, done.
    No more file write error.

    The issue is with how the firmware creates the .sav file during the first play of the game.

    Has anyone got the fault with non-EA games as all the games I hear this happening to are EA?
     
  5. avi58

    Newcomer avi58 Advanced Member

    Joined:
    Aug 7, 2007
    Messages:
    61
    Country:
    Spain
    I've had problems with contra 4 and n+. The problem was a bad transfer of the rom to the cardridge that make the rom corrupt with savegame problems, i deleted the lastsave file and replaced the roms and everything is fine since them.
     

Share This Page