How do I convert from rxTools 11.0 to Luma?

Discussion in '3DS - Homebrew Development and Emulators' started by ShinyMK, Oct 3, 2016.

  1. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    Last edited by ShinyMK, Oct 3, 2016


  2. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,376
    19,720
    Sep 13, 2009
    Antarctica
    Between insane and insecure
  3. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
  4. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,376
    19,720
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Do you have an old3DS or new3DS?
     
  5. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    old
    its currently on 9.2 so thats all good
    should I just follow the steps from part 2?
     
  6. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,376
    19,720
    Sep 13, 2009
    Antarctica
    Between insane and insecure
  7. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    Lilith Valentine likes this.
  8. Shah Isah

    Shah Isah Advanced Member

    Newcomer
    94
    14
    Sep 7, 2016
    Is the downgrade neccessary? To 2.1.0 to install luma?
     
  9. zac122

    zac122 GBAtemp Fan

    Member
    301
    133
    Sep 7, 2015
    United States
    He also wanted a9lh. If you just want to switch from rxtools to Luma 3ds there's no reason to downgrade.
     
  10. Shah Isah

    Shah Isah Advanced Member

    Newcomer
    94
    14
    Sep 7, 2016
    I'm thinking about the switch and i've read many guides. The downgrade part always puts me off..
     
  11. TimX24968B

    TimX24968B "That guy"

    Member
    1,344
    273
    Oct 28, 2015
    United States
    Nowhere
    for A9LH, the second downgrade is required. If you just want to switch to luma without the A9LH, its as simple as replacing your rxtools files with the luma files and running luma instead of rxtools.
     
  12. zac122

    zac122 GBAtemp Fan

    Member
    301
    133
    Sep 7, 2015
    United States
    If you're using a new 3ds there's a new method in the works that doesn't require a downgrade. It's only for the n3ds though, so if you are using an o3ds the switch to a9lh will probably always have downgrading as a requirement. However with the recent improvements to the process you can have everything done within an hour. Very painless now compared to when a9lh first came out.
     
  13. ShinyMK
    OP

    ShinyMK known as @initPRAGMA

    Member
    1,492
    511
    Dec 29, 2015
    127.0.0.1
    for A9LH yes

    — Posts automatically merged - Please don't double post! —

    I have a n3DS but im doing this for my sisters o3DS and got it setup perfectly fine in about 2 hours
     
  14. cravas

    cravas GBAtemp Advanced Fan

    Member
    864
    229
    Jul 30, 2016
    Oeiras
    Even the New3DS requires a downgrade if your above 9.2 FW.
    FYI.
     
  15. zac122

    zac122 GBAtemp Fan

    Member
    301
    133
    Sep 7, 2015
    United States
    nope, new method out there for n3ds that uses the OTP hash iirc instead of the actual otp, so no need for downgrade. limited to n3ds only because the o3ds doesn't have the same secret sector or something like that. it's still in the testing phases, but looking very promising so far.

    edit: http://gbatemp.net/threads/coming-s...-no-2-1-downgrade.443187/page-16#post-6715919

    link for your convenience. thanks for calling me out though =P
     
    Last edited by zac122, Oct 4, 2016
  16. xtheman

    xtheman GBAtemp Guru

    Member
    5,843
    5,253
    Jan 28, 2016
    It doesn't work on 11.0/11.1 does it?
     
  17. zac122

    zac122 GBAtemp Fan

    Member
    301
    133
    Sep 7, 2015
    United States
    no, you still have to be on 9.2, but there was some talk of it being compatible with 9.4/5 with some work i think? still takes a kernel exploit
     
  18. cravas

    cravas GBAtemp Advanced Fan

    Member
    864
    229
    Jul 30, 2016
    Oeiras
    I probably didn't explained properly:
    If you are on a New3DS above FW 9.2, you still have to downgrade to 9.2, to do the OTPless A9LH install.
    That is the downgrade I was refering to. NOT the 2.1.

    And, as hacking goes, it is the downgrade that has all the risk (either 2.1 CTR-transfer or 9.2 clean downgrade)

    In here, you just confirm what I said, ;)
     
  19. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,477
    2,663
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    Actually, I've never had a 2.1 downgrade fail or softbrick, but several 9.2 downgrades softbricked (the people who wanted it done did not want me to format before doing the 9.2 downgrade so I couldn't eliminate that risk...)
     
  20. cravas

    cravas GBAtemp Advanced Fan

    Member
    864
    229
    Jul 30, 2016
    Oeiras
    Yes, the ctr-transfer isn't that prone to give troubles but, downgrading is downgrading.
    Like Murphy's law, if things have to go wrong, they will go wrong.