Help with DSLinux wifi not working

Discussion in 'NDS - Emulation and Homebrew' started by Dirbaio, May 2, 2011.

May 2, 2011
  1. Dirbaio
    OP

    Member Dirbaio GBAtemp Regular

    Joined:
    Sep 26, 2010
    Messages:
    158
    Location:
    Spain
    Country:
    Spain
    I'd like to use DSLinux on my FlashMe'd DS Lite. I have an R4 SDHC (from r4sdhc.com) and an EZFlash IV.
    The R4sdhc supports DLDI perfecly, it gives no problems. The EZFlash gives 16 MB of extra RAM: typing "free" reveals like 14 MB of RAM free, so it's okay.

    It all works perfectly but wifi. When I want to connect to wifi, I follow the steps, and when connecting it seems to work okay until DHCP: it fails with "Info: no lease, failing." error message.

    It happens with *every* wifi AP I've tried, independantly of the distance, the WEP encryption or not... So it's not a problem of my AP neither.
    Also, I've downloaded the DSLinux DLDI build from here: http://kineox.free.fr/DS/, unzipped and coped everything in the root of the microSD card as the instructions say.

    Since the DSLinux wiki is down, and I can't find any other source of information on this, I thought I'll just ask here...

    (By the way, does somebody know of a mirror or a backup of the wiki? I remember visiting it some time ago before I had the EZFlash and could use DSLinux, and I remember it had lots of info on DSLinux. It'd be a shame if it's lost forever.)

    Does anyone have the same problem? Does anyone have a clue on how to solve it?
    Any help is really appreciated! [​IMG]

    (Edited: reworded and fixed typos)
     
  2. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    It could be a problem with the DHCP implementation. I'm able to connect to wifi with DSLinux, but this is using a Linksys router from around 2002 (only supports wifi-B, no -G or -N even), but more importantly, using static IP info rather than using DHCP. This is actually the main reason why I still continue to use this router.

    Try using this script, which I got from the DSLinux forums a few years ago: http://www.zumodrive.com/share/9ZE9ZWEyMD - put this in /usr/bin

    "wifi" by itself will show the various options. "wifi -c" will let you connect using manual settings. If you've set up your router correctly, this *should* work. Hopefully.
     
  3. Dirbaio
    OP

    Member Dirbaio GBAtemp Regular

    Joined:
    Sep 26, 2010
    Messages:
    158
    Location:
    Spain
    Country:
    Spain
    Many thanks!! You were right, it was because I had to choose static IP addressing [​IMG]
    I'm now online! Yay [​IMG]

    That script didn't work for me, though... I tried it but it was still DHCP-ing after I told it to use a static IP.
    I got it to work by setting up the static IP in dslinux's own config utility, wnc .

    Thanks a lot [​IMG]
     

Share This Page