Gaming Help: Do I have to softmod before playing downloaded ISOs?

noyou

New Member
OP
Newbie
Joined
Jan 3, 2009
Messages
4
Trophies
0
XP
-9
Country
United States
Hi, all,

I bought a USA wii with 3.3U menu, couple of days ago.

I also saw & downloaded NTSC-USA wii games on RapidShare/MU site (links from WIISO.)

In order to play those games, which things I need to do then?
  • Do I have to patch those downloaded NTSC-USA ISOs?
  • Do I have to install Homebrew first?
  • Do I have to switch back to 3.2 menu too?
which is essential? Thanks a lot, guys!
 

noyou

New Member
OP
Newbie
Joined
Jan 3, 2009
Messages
4
Trophies
0
XP
-9
Country
United States
Thank you Screamq3

I checked two posts, which requires all homebrew channel installed first, cause I don't have the twilight game.

Is there some alternative way to just patch NTSC-U ISOs to make the game work?
 

screamq3

Well-Known Member
Member
Joined
Nov 23, 2008
Messages
188
Trophies
0
XP
45
Country
nope not possible m8. just rent zelda and follow instructions
smile.gif
simple step by step guides
 

IOwnAndPwnU

Well-Known Member
Member
Joined
Jul 31, 2008
Messages
1,120
Trophies
0
XP
141
Country
Canada
First thing I was thinking. RapidShare can't count, technically because it doesn't allow you to search.

As for your questions, for softmod:
1-Yes, I believe you do have to patch them. You also should change the region to NTSC-U (if their not already), and remove any updates. For the region changer, search for RegionFrii and for the update remover, search for WBB (Wii Brick Blocker). Here are the links:
RegionFrii
Wii Brick Blocker (WBB)
For softmod, you don't have to really do this but I recommend that you do, or risk getting your Wii bricked. Upto you.

2-For the softmod, yes, you do have to install the HBC (Homebrew Channel) which will allow loaders to be downloaded. Then you insert the game through the loader.

3-With the softmod, you'll have to downgrade to 3.2U anyway (and it's recommended anyway because it's the best firmware for the Wii so far, for softmod). And this will allow you to install Starfall.

Hope that helps.
smile.gif
 

screamq3

Well-Known Member
Member
Joined
Nov 23, 2008
Messages
188
Trophies
0
XP
45
Country
no you dont have to patch them, the softmod loaders have force pal and force ntsc option. as for the updates if you just install starfall on 3.2, that has a feature built in to skip disc updates (option 6 i think) good luck
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    K3Nv2 @ K3Nv2: I wanna start a fake fast food hoax burger King selling Eagle meat or something