Help: Acekard2 + 3in1 = Corrupt GBA saves

Discussion in 'NDS - Flashcarts and Accessories' started by Misterboy, Sep 22, 2008.

Sep 22, 2008
  1. Misterboy
    OP

    Newcomer Misterboy Newbie

    Joined:
    Sep 21, 2008
    Messages:
    7
    Country:
    United States
    Hi all,

    I am having an incredibly frustrating problem. I am running a new Acekard 2.1, and an EZ 3in1 combination. I am experiencing the same problems with both the Acekard official firmware 4.08 and AK-AIO 1.2. A slightly different but related problem occurs when using GBA Exploader.

    :EDITED HEAVILY:

    No responses [​IMG] Maybe I'm posting in the wrong area, but surely someone has some pointers for me?

    I've continued to play around and I've updated this post with my latest findings:

    I seem to be experiencing a problem with GBA save files. I can load games into either the PSRAM or NOR of the 3in1 and roms will play. However, once a save file is created, the next time I try to run a ROM, AK-AIO and Acekard 4.08 hang at the message "Loading GBA Save...". If I use GBA EXploader to load GBA games, the save seems to load, but once the game is running I get a "Save is corrupt" message.

    It's pretty clear the issue involves either the reading of, or the initial writing of my GBA save files. So these are my theories, and I need some help trying to narrow this down:

    1) Maybe I am not using my 3in1 correctly. I believe I am, but maybe I'm missing some important component. As far as I can tell after many hours of reading loads of forums: with the Acekard 2.1 and a 3in1, I should be able to take an unpatched backup ROM in any folder (I tend to use /GBA/) and run it. The Acekard should take care of the rest. I have tried disabling all patches and I get the same problems...well, if I disable the sRAM patch the game won't even load, but that seems expected considering the sRAM patch is what enables saves to work in the first place).

    2) Perhaps my 3in1 has faulty sRAM. The PSRAM appears to be okay because when no save file is present, ROMs load into the PSRAM okay and play fine. The NOR seems okay, because I can load games into it as well, and can boot the ROM as if it were a GBA cart. However, save files are screwy, and as far as I have been able to research, the 3in1 uses the sRAM for save files while in PSRAM AND NOR (am I right?). I should also point out that while I haven't fully tested it, I do seem to be getting buggy situations with save games while playing a ROM in NOR. I now believe my 3in1 battery is okay because using GBA Exploader, it does list an entry where it tells you what is in the save slot (you know...and you can use the B button to save that as a *.sav file). Still, the battery seems to be a likely culprit.

    3) Maybe my SDHC is bad? I have a new ADATA 8gb SDHC Class 6. I have experienced one crash which required a reformat. I also at one point got a blue screen of death when deleting files from it after one round of testing. I haven't had a BSOD in a LONG LONG LONG time. However, I kind of doubt my micro SD is the problem because it works in general, and NDS roms load fine, their saves work fine, everything else seems fine. I would assume that if my SD is buggy, I'd be experiences an array of weird behavior. (Maybe the 3in1 isn't compatible with SDHC???)

    4) Finally, maybe my Acekard 2.1 has gone bad somehow? I doubt this as well, but it is a possibility. All of these components, (DS, AK2.1, 3in1 etc) are new.


    Now specifically what I need help with is eliminated some or all of the above possibilities, so I know what parts to reorder, or in the case of number 1, what I am doing wrong. I have done as much research as possible, reading anything I can find, but most forums deal with other combinations of Slot1/2 devices, or deal with very old firmware etc. One thing I am fuzzy on is the option to set the 3in1 to "Boot in GBA Mode" or "Run in Passme mode". Changing this doesn't seem to affect my problem though sometimes one or the other makes the GBA rom hang at a white screen.

    So this is getting long, but if you are one of these GBATemp Gurus, bear with me: Do I or don't I have to use some sort of 3rd party patching program to setup a GBA rom to run in the 3in1? My understanding is that the AK 4.08 and AKAIO1.2 does everything for me. But I've seen a lot of references to old setups requiring patches when using GBA Exploader. Part of this has to do with difference SAVE file sizes. Everything I've read indicates that this is an old way of going, but as I am having save game problems I can't help but wonder if I have to setup each rom with the correct save format or something?

    I am running ROMS from the internet of GBA games I own. I own the Mario Advance games so am using them to test things. Are there problems with the ROM images possibly? I've downloaded them from several sources and have stuck with ROMs which appear to be unpatched (I have seen and tried a few patched ones as well). Maybe there are weird specific issues with Mario Advance 2 and 4?

    Well, I'm at my wits end. I may just try to return my SD card, the Acekard 2.1 and the 3in1 and hope that it wasn't my ignorance that was causing the problem. But that will take weeks and my guess is that I'm either screwing up or it's just one component that needs to be returned.

    Surely there are some people out there that know this stuff forwards and backwards. I'm new to this whole scene, but have seen a great community of helpful people here.

    Sorry for the length of this post, but I've noticed that answers to questions aren't forthcoming when specific information isn't given. Thanks for your time and patience.

    Oh, one final note. The DS Opera Browser works, as does the rumble function of the 3in1. So in general the 3in1 seems okay. If it is the 3in1, I'm guessing it is specifically bad sRAM.

    Thanks again,

    Misterboy
     
  2. Lactose_Intolera

    Newcomer Lactose_Intolera Newbie

    Joined:
    Jan 31, 2008
    Messages:
    8
    Country:
    United States
    i've had similar problems. I had a crash of my nds when I was playing the neo geo emulator and my microsd got corrupted. Now i can't save my games on my ez 3-in-1. I even replaced the battery in my 3-in-1 thinking that was the problem.
     
  3. estebangh

    Newcomer estebangh Member

    Joined:
    Aug 22, 2006
    Messages:
    36
    Country:
    Colombia
    First one thing must be clear: I don't have an AK2 or 3in1... yet.

    I had same message "Save is corrupt" using a DSTT and SuperCard Lite with YSMenu GBA loading function (loaded from DSTT not from SC Lite slot), the game was: The Legend of Zelda: Minish Cap". I worked around this using GBATA which provides you an SRAM Patcher.

    You say GBAExploader patches on the fly maybe something is wrong with it, but that would be weird.

    Also be sure your ROM has no intros (scenes in that time really enjoyed intros), with GBATA you can work this out too.

    So my suggestions are:
    Try removing intros first, so to be sure ROM is really clean.
    Patch ROM's SRAM and disable patch on the fly.

    YSMenu can be used with AK2 take a look around the forum for a tutorial and have in mind that YSMenu doesn't patch on the fly. If this works, problem is GBAExploader but if not problem is with your 3in1's SRAM.


    I'll check Super Mario Advance games you mentioned earlier, as I mentioned above I don't have AK2 or 3in1 but I ordered them few months ago from DX and they should be here by this or next week. I'll let you know by then... anyway PM if you want to.

    Hope it works.
     

Share This Page