Help! 3DS won't update Games or System on BS9 Luma 9.0

Discussion in '3DS - Homebrew Development and Emulators' started by ApolloX44, Dec 27, 2017.

  1. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    Hey guys, I'm having update error problems on my 3DS. I'm on BS9 Luma 9.0 and sys 11.2.0-4U.

    When i try to update games i first run cttrpwn to bypass the system update prompt, then i begin the update process. The problem is the bar goes about half way before I get a message that says "Error Code: 026-3010 the connection to the server has timed out due to user inactivity." So then i restart the 3DS and try updating the firmware, the bar gets to 99% before i get the message "An error has occurred. Unable to update. The system will now be restarted."

    I've tried the following fixes to no avail:

    1) Restart my 3DS
    2) Change DNS settings (primary to 8.8.8.8 and secondary to 8.8.4.4)
    3) Disable Firewall on Router
    4) Hold 3DS as close to router as possible.

    Also, I know that the issue isn't with cttrpwn and that I'm not banned by Nintendo from online because i can still use cttrpwn to access Pokemon Bank. That would not be the case if i was banned.

    Any suggestions?
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    6,609
    2,830
    May 11, 2008
    United States
    Is there a reason why you don't want to update to 11.6?
     
  3. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    It's the only thing i haven't tried to fix my pokemon ultra sun and ultra moon update problem. it would save me having to use cttrpwn. Plus, it's concerning to me that i can't.....
     
    Last edited by ApolloX44, Dec 27, 2017
  4. Lacius

    Lacius GBAtemp Guru

    Member
    6,609
    2,830
    May 11, 2008
    United States
    There's no reason not to update to 11.6 if using Luma3DS v9.0.
     
    Extrasklep and Quantumcat like this.
  5. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    I guess. Although is there a reason I can't? Btw i just managed to update Super Smash Bros....so think i might be a problem with the CIA's for Pokemon Ultra Sun and Ultra Moon.
     
    Last edited by ApolloX44, Dec 27, 2017
  6. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    So i managed to update Pokemon Ultra Sun and Ultra Moon using CIA files of the updates. But i still can't play online because i need a system update and that doesn't work. I've tried using sysupdater but that isn't working.....any ideas?
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    6,609
    2,830
    May 11, 2008
    United States
    If you are using Luma3DS v9.0, then you can update the system by going into the System Settings and performing an update there. If that doesn't work, what is the error you receive?
     
    Quantumcat likes this.
  8. I pwned U!

    I pwned U! GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    I pwned U! is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    854
    1,124
    Jun 14, 2013
    United States
    I recently installed B9S and Luma 9.0 on my red O3DS and had the same problem when trying to do a system update.

    I guess I am not the only one with this problem...

    Try updating it with an older version if Luma.
     
  9. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    The bar makes it to like 99% then it says "An error has occurred. Unable to update. The system will now be restarted."

    — Posts automatically merged - Please don't double post! —

    What do you mean by this? I'm talking about the system version not the Luma version. I just updated to Luma 9.0 today, but even before that when i was on 8.1 the system update still wasn't working.
     
    Last edited by ApolloX44, Dec 27, 2017
  10. Quantumcat

    Quantumcat Dead and alive

    Member
    12,343
    6,703
    Nov 23, 2014
    Australia
    Canberra, Australia
    Try using a mobile phone hotspot. And make sure you're not blocking any Nintendo servers on your net (if you have a Wii U you may have done this).
     
  11. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    I tried it at a Starbucks last week. No difference. I just tried to install the update CIAS with FBI. Looked like it worked for a second. Then it bricked my 3ds. Luckily i have Decrypt9 and Godmode so i'm doing a NAND restore.....fml.....
     
  12. Quantumcat

    Quantumcat Dead and alive

    Member
    12,343
    6,703
    Nov 23, 2014
    Australia
    Canberra, Australia
    What do you mean by it bricked it? Did you use the right region and type?
     
  13. GizmoTheGreen

    GizmoTheGreen GBAtemp Advanced Fan

    Member
    501
    138
    Oct 8, 2009
    isn't this what happens when your FW has been modified? like if you patched home menu or some TWL firm directly instead of letting luma do it? maybe you should try a ctr transfer or something, I think there are 11.6 ones around.
     
    Quantumcat likes this.
  14. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    Yes, i used the files for the correct region. I even saw that it had updated to the correct version in system settings, but then suddenly the screen went black to the error dump. I couldn't boot into the 3ds. Luckily Godmode and Decrypt9 were loading so i did a NAND restore. Lost some CIA's but i had backed up my save files. Unfortunately I'm back on Luma 7.1 and have to upgrade back to 9.0. I'd appreciate help with that.

    — Posts automatically merged - Please don't double post! —

    Thanks, I'll try looking for this if i can get my Luma updated back to 9.0. Right now I'm struggling with that as I've been following the guide but can't boot into Luma configuration just by powering up like I'm supposed to in step 2.
     
  15. GizmoTheGreen

    GizmoTheGreen GBAtemp Advanced Fan

    Member
    501
    138
    Oct 8, 2009
    Hold select on boot, it only boots to config by itself if there' isn't one already

    but wait how did a nand restore throw your luma back to 7.1? do you have luma 9.0 boot.firm on SD?
     
  16. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    I had an older NAND from when i was on 7.1 that i used to restore my system. I do have a 9.0 boot.firm on SD. But when i did the Luma update it failed. I think I have to install BS9 again. Too lazy to do it right now. I've spent all day on this. Either I'll do it later tonight or tomorrow, for now the 3DS is working again and i can at least breathe a sigh of relief on that front.
     
  17. GizmoTheGreen

    GizmoTheGreen GBAtemp Advanced Fan

    Member
    501
    138
    Oct 8, 2009
    a nand restore shouldn't do that... I'm not sure what you have messed up this time. you must still have b9s, but it should load the same 9.0 boot.firm from your SD. I still don't recommend using luma updater tools, just download the release and manually replace the boot.firm file.
     
  18. Quantumcat

    Quantumcat Dead and alive

    Member
    12,343
    6,703
    Nov 23, 2014
    Australia
    Canberra, Australia
    Lacius likes this.
  19. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    So i managed to restore my 3ds using the boot.firm from the latest Luma nightly and the latest files for bootstrap 1.3. I'm now back to running Luma 9.0! I just need to reinstall some games and reinsert the save files using JKSV and then I'll be back where i started. Hopefully i will be able to update the system firmware this time, if not I'll need suggestions.
     
  20. ApolloX44
    OP

    ApolloX44 Member

    Newcomer
    37
    2
    Apr 13, 2017
    Canada
    Ok everyone, so I'm back to square one. I'm on 11.2.0-4U and Luma 9.0 but i can't system update and that prevents me from going online on certain games that needs a system update. Any ideas?