goflex HD stops working at all after working fine for a day

Discussion in 'Wii - Backup Loaders' started by tehsquirrel, Oct 9, 2011.

  1. tehsquirrel
    OP

    Newcomer tehsquirrel Newbie

    Joined:
    Oct 9, 2011
    Messages:
    6
    Country:
    United States
    I got one of the seagate freeagent goflex 500g usb3.0 drives from walmart (STAA500105 and PN:9ZFAN6-570). I used the software to disable the spindown feature and then used wii backup manager to format the drive. I installed many games and they worked flawlessly. Later on I copied my vba roms to the drive (using the standard windows 7 file manager 64bit) and went to plug it in and not recognized anywhere, reformatted it (several times, using windows, using wii backup manager, some gui partioner, and easus partition manager) and each time the device just does not show up at all on the wii. I tried plugging it in and then powering the wii, powering the wii first, then plugging it in, plugging it in and out at the usbloader screen, tried it in all my emulators, etc. I plug in my 16gb usb stick and it shows up fine, games run fine. I plan on returning it and getting one of the Western Digital 500GB My Passport Essential USB 2.0/3.0 External Portable Hard Drive Model#: WDBACY5000ABKSN tomorrow. Wonder if anybody has any tips for the goflex or should I just go with the WD?
     
  2. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    I agree, return the drive.
     
  3. VashTS

    Member VashTS Beat it, son

    Joined:
    Mar 14, 2009
    Messages:
    3,654
    Location:
    Upstate NY
    Country:
    United States
    i tend to stay away from seagate as much as possible. i got a 250gb external from walmart on clearance for $25. i figured i'd tear it apart and use it in my ps3. before i got the chance the drive shit the bed somehow. Luckily they have a good warranty, even though I took it apart they still replaced it. drive works great now in my ps3, but it seems like when you connect/disconnect it a few times, they die for some weird reason. its probably really sensitive to that. may need to safely remove properly.

    go with WD, I've got 4. 2 2tb on my pc and 2 1tbs for my game systems, 1 for ps3 and 1 for wii. also had a 500gb that i sold to get the 1tb, friend who i sold it to still uses it and it works great. i've also got 2 internal WD drives, 1.5tb and 500gb. i would recommend and stick with WD for life.
     
  4. tehsquirrel
    OP

    Newcomer tehsquirrel Newbie

    Joined:
    Oct 9, 2011
    Messages:
    6
    Country:
    United States
    I took the seagate back and got a WD passport essential 500gb and it has worked like a charm, seems to transfer files more quickly and load faster as well. The WD was about 14$ more but I'd say well worth it and works in every wii app I have (usb loaders and emulators).
     

Share This Page