RELEASE Fluffy - A Tinfoil and Goldleaf GUI

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by fourminute, Jan 15, 2019.

  1. vree

    vree GBAtemp Regular

    Member
    4
    Sep 12, 2005
    United Kingdom
    Is it normal this makes my switch crash if going back to home menu? Even if I use it or not.
    So for example boot up tinfoil or goldleaf while fluffy is open. But did not select anything in fluffy. Press home button on swith to get out of tinfoil or goldleaf. Bam crash of switch. This does not happen if not conected.
     
  2. hippy dave

    hippy dave BBMB

    Member
    14
    Apr 30, 2012
    United Kingdom
    Are you on firmware 7.x? There's a known bug with usb homebrew on that firmware, doesn't happen on lower or higher firmware.
     
  3. MrWhosHacking

    MrWhosHacking GBAtemp Regular

    Member
    2
    May 3, 2018
    United States
    You can try nut Clint from here: https://gbatemp.net/threads/nut-gui-usb-and-network-installer-for-tinfoil-and-sx-installer.531327/ or direct https://github.com/blawar/nut/releases that if works on your firmware if not upgraded cfw to 8.0.1 or lower then yours
     
    Last edited by MrWhosHacking, May 25, 2019
  4. fourminute
    OP

    fourminute GBAtemp Regular

    Member
    3
    Jan 15, 2019
    United States
    Hey guys, v2.9.0 is out! And for me personally, this release is very special to me. I spent a long time making the code better, more object oriented, and squashing some annoying bugs.


    [​IMG]

    What's New in 2.9.0:
    • Added: Goldleaf v0.6 Compatibility
      • Including all file-handling features.
    • Added: Goldleaf: File access security.
      • Default protections are place to safe-guard users from a potentially compromised Goldleaf file.
      • Default: File operations such as file creation, deletion, renaming will result in a user-prompt(yes or no).
      • Default: Read-only access for all files.
      • Default: Read/write to non-NSP files are restricted.
      • All of these security restrictions are changeable in fluffy.conf.
    • Added: Windows Executable(.exe), should help many users that struggle to run Fluffy.
    • Added: About dialog with credit list, find your name there!
    • Fixed: Scaling issues with Fluffy logo on certain resolutions.
    • Fixed: Improved install aborting. Proper thread elimination.
    • Fixed: Improved multi-threading. All threads are now daemons.
    • Fixed: No more false error messages when canceling a task.
    • Fixed: usb.core.NoBackendError: Revert to Network Mode, stops crash.
    • Fixed: Dark Mode checkbox will remain checked despite being off in some scenarios.
    • Changed: Config and log files for linux users now stored in $HOME.fluffy folder.
    • Misc: Code overhaul. Significantly more object oriented. Improved logging and exception handling. So many changes. Such wow.

    Also, this is the first release to include a Windows Executable(.exe)!
    If you previously had issues with USB.Core No Backend or PyQT5 Not Found, etc. Try out the Fluffy.exe. It may solve your issue.


    https://github.com/fourminute/Fluffy
     
    Last edited by fourminute, May 26, 2019
  5. Osga21

    Osga21 Full Time Idiot

    Member
    3
    Jun 9, 2013
    Portugal
    Margem Sul
    Love seeing such a big release of this program. An .exe is a great idea for noobs, but if you had the python version working you may as well keep using it since it loads faster.
    Anyway, @fourminute you mentioned compatibility with Goldleaf 0.6 and I was unable to find it until I saw you mentioned at the very bottom of the release post that you meant the nightlies. Could you please put a link to the recommended Goldleaf version on your README.MD? I actually submitted a pull request
     
    fourminute likes this.
  6. fourminute
    OP

    fourminute GBAtemp Regular

    Member
    3
    Jan 15, 2019
    United States
    Done! Good suggestion.
     
  7. mikymax972

    mikymax972 Member

    Newcomer
    1
    Sep 18, 2008
    United States
    Hi,i'm on mac and i have error for the dark mode

    problem fixed
     
    Last edited by mikymax972, May 27, 2019
  8. ReikaRin

    ReikaRin GBAtemp Regular

    Member
    3
    Mar 21, 2018
    Indonesia
    when i selected multiple nsp and begin transfer, only 1 file showed up in tinfoil. Is this bug?
     
  9. dreambottle

    dreambottle Member

    Newcomer
    2
    Mar 2, 2016
    Whenever I start it, my cpu usage goes crazy. (on macos with latest python from brew) Is it mining bitcoins in background? :D
     
  10. fourminute
    OP

    fourminute GBAtemp Regular

    Member
    3
    Jan 15, 2019
    United States
    Never(and feel free to look at the source code). And yeah the CPU usage isn't something I've had time to tinker with. Maybe in the future I'll reduce it by a great margin, though.


    I've never had that happen neither has any of my testers. Could possibly be a bug though. If so submit a github issue and I'll take a look at it.
     
    Last edited by fourminute, May 29, 2019
  11. mdmachine

    mdmachine GBAtemp Regular

    Member
    4
    Jun 15, 2009
    United States
    I get high CPU usage as well. OSX 10.14.4. I figured it wasn't optimized.
    And I get only 1 option for files in tinfoil if doing the network install, USB is fine.
     
  12. chr0m

    chr0m GBAtemp Fan

    Member
    4
    Oct 9, 2007
    Australia
    I've been using Fluffy without issue for the last few months and now suddenly started getting usb.core.NoBackendError: No backend available error.

    Tried downloaded the latest version, still get the same error, but it just boots in Network mode. Tried reinstalling pyusb and libusb1, but no luck. Not sure what's happened. The only thing I can think of is the latest Windows 10 May 2019 update has broken it.

    The Windows .exe is working ok, but would rather get the Python version working.
     
    Last edited by chr0m, May 31, 2019
  13. Howdy,

    I'm a bit confused now, because with older versions of Goldleaf I could select "USB Install" from the menu, then in Fluffy go to the Goldleaf tab and select NSP.

    Now, that has never actually worked to install anything for me so I've stuck with OG Tinfoil and multiple NSP installs, works great.

    But with the new 2.9.1 Fluffy and the nightly Goldleaf I figured I'd try it again, see if there was any speed difference. Except now Goldleaf doesn't have a USB Install option in the menu any more, and Fluffy doesn't have a way to select NSPs on the Goldleaf tab, just a picture of logo.

    What am I missing here?

    EDIT: Unrelated, I just noticed the application says 2.9.0 in corner still, where I definitely downloaded the 2.9.1 release from Github. Cheers!
     
    Last edited Jun 1, 2019
  14. Deleted-380242
    This message by Deleted-380242 has been removed from public view by Quantumcat, Jun 2, 2019, Reason: Requested.
    Jun 2, 2019
  15. Big_Ddog

    Big_Ddog Newbie

    Newcomer
    1
    Aug 13, 2013
    Canada
    I'm having a problem.

    I have installed everything on the first page, downloaded the release and goldleaf/tinfoil.nro's from the page suggested.


    When I use fluffly and tinfoil on USB, My begin transfer button flashes between switch detected and not detected extremely fast. Is that something on my end? I have tried different cables and they do the same thing.


    And if I use fluffy to install over network, It reads the files, starts to download one installs it then tells me all 150 files are installed and closes?

    Reinstalling drivers fixed that issue. I still can't seem to install more then 1 file at a time without an error in tinfoil
     
    Last edited by Big_Ddog, Jun 2, 2019
  16. LyfeOnEdge

    LyfeOnEdge Advanced Member

    Newcomer
    2
    Feb 24, 2019
    United States
    @fourminute with fluffy when you try to launch it from another script it causes the conf and log files to appear in the working directory of the script that launched it, could you add a launch option so if it's called with a given argument it initializes its conf and log files in its own directory instead? Something like this:
    Code:
    Original:
    try:
        if "win" in sys.platform[:3].lower():
            initial_dir = os.getcwd() + "/"
        elif "linux" in sys.platform.lower():
            if not os.path.exists(os.path.expanduser('~') + "/.fluffy"):
                os.makedirs(os.path.expanduser('~') + "/.fluffy")
            initial_dir = os.path.expanduser('~') + "/.fluffy/"
        else: # MacOS. A little help here would be great.
            initial_dir = os.getcwd() + "/"
    except:
        initial_dir = os.getcwd() + "/"
        pass
    
    Example:
    useBaseDir = passedArg
    try:
        if "win" in sys.platform[:3].lower():
            if not useBaseDir:
                initial_dir = os.getcwd() + "/"
            else:
                initial_dir = sys.path[0]
    etc...
    
     
  17. alimao

    alimao Advanced Member

    Newcomer
    5
    Mar 26, 2009
    Brazil
    switch not detected . fluffy to linux only works usb ports 3.0 ?
     
  18. yikkyon

    yikkyon GBAtemp Regular

    Member
    4
    Sep 20, 2008
    United States
    I scoured the entire internet for this and it just comes down to the fact that the Goldleaf nro is actually outdated. Use the one provided by the Fluffy download page. Yes, I know both of them say 0.5 but they are entirely different. One is presumably the old but stable one and the provided one is most likely the nightly build that works.
     
Loading...