RELEASE Fluffy - A Tinfoil and Goldleaf GUI

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by fourminute, Jan 15, 2019.

  1. Dragonx41

    Dragonx41 GBAtemp Regular

    Member
    3
    Jun 9, 2018
    United Kingdom
    ???? What are you running on your switch what's the error log
     
  2. dempseyromeo

    dempseyromeo Newbie

    Newcomer
    1
    Mar 2, 2019
    United States
    Sorry, I didn't notice. Yesterday I tried nut/goldtree/fluffy/sx server, every app crashed when i installed games via USB
    I even deleted all of those folders and reinstalled atmosphere with no luck
     
  3. fourminute
    OP

    fourminute GBAtemp Regular

    Member
    4
    Jan 15, 2019
    United States
    Looks like you need to re-install Python with PATH selected.

    Try reformatting your SD card to FAT32. Also Network Install is great, I use it more than USB you should try it. See if it fixes your issue.

    Shout-out to @Dragonx41 for helping everyone while I've been busy. Thank you.
     
    Last edited by fourminute, Mar 23, 2019
    Dragonx41 likes this.
  4. shivoooooo

    shivoooooo Member

    Newcomer
    2
    Feb 14, 2019
    Japan
    I had similar errors and this happened because I installed the program on another hard drive with greater capacity, in the end I ended up installing the program on the route that delivered the same program (unmodified) and it was solved. For commands you should only write them in CMD as indicated by the instructions, without assigning any route. Just write it as it is in the instructions on page 1

    How-To-Use
    • Download and Install Python 3 from https://www.python.org/downloads/. Ensure no previous version of Python is installed. This may cause an error "PyUSB not found". Do not use the 64-bit version of Python 3 with Fluffy.
    • Open Terminal/CMD
    • Run "pip3 install pyusb" and "pip3 install pyqt5" and "pip3 install libusb" and "pip3 install libusb1"
    • MacOS users must also run "brew install libusb". For more info on brew, head to https://brew.sh/.
     
  5. psiko74

    psiko74 Advanced Member

    Newcomer
    2
    Jan 22, 2009
    United States
    tinfoil keeps crashing when i try to run it. Im using Atmospere 0.85 on 7.0.1
     
  6. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    It just opens and instantly closes back down on my PC. No idea what's wrong

    EDIT: Ok so i got past that but now i get stuck on awaiting transfer request, then i get an error on Tinfoil and the Switch crashes
     
    Last edited by Ashura66, Mar 27, 2019
  7. Dragonx41

    Dragonx41 GBAtemp Regular

    Member
    3
    Jun 9, 2018
    United Kingdom
    which version of Tinfoil?

    — Posts automatically merged - Please don't double post! —

     
  8. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    The recommended one
     
  9. Dragonx41

    Dragonx41 GBAtemp Regular

    Member
    3
    Jun 9, 2018
    United Kingdom
    so Tinfoil 0.2.1 and not Tinfoil 1.0 right?
     
  10. ker

    ker Member

    Newcomer
    5
    Apr 29, 2014
    Is it compatible with GoldLeaf 0.5?

    Enviado desde mi SM-G950F mediante Tapatalk
     
  11. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    Dragonx41 likes this.
  12. Dragonx41

    Dragonx41 GBAtemp Regular

    Member
    3
    Jun 9, 2018
    United Kingdom
  13. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    The log is blank. All it says is "DEBUG:root:Fluffy Log: If you see nothing here. Good!"
     
  14. mikymax972

    mikymax972 Member

    Newcomer
    1
    Sep 18, 2008
    United States
    Hi,I try reinstall fluffy but i have this message
    Your program is still running do you want to kill it,no fluffy gui,mac os el capitan,someone can help me thanks



    DEBUG:root:Fluffy Log: If you see nothing here. Good!

    ERROR:root:dlopen(/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyQt5/QtWidgets.so, 2): Symbol not found: __os_activity_create
    Referenced from: /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyQt5/Qt/lib/QtCore.framework/Versions/5/QtCore (which was built for Mac OS X 10.12)
    Expected in: /usr/lib/libSystem.B.dylib
    in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyQt5/Qt/lib/QtCore.framework/Versions/5/QtCore
    Traceback (most recent call last):
    File "/Users/mikymax97/Downloads/fluffy.pyw", line 65, in <module>
    from PyQt5 import QtWidgets
    ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyQt5/QtWidgets.so, 2): Symbol not found: __os_activity_create
    Referenced from: /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyQt5/Qt/lib/QtCore.framework/Versions/5/QtCore (which was built for Mac OS X 10.12)
    Expected in: /usr/lib/libSystem.B.dylib
    in /Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyQt5/Qt/lib/QtCore.framework/Versions/5/QtCore
     

    Attached Files:

    Last edited by mikymax972, Mar 28, 2019
  15. linuxares

    linuxares I'm not a generous god!

    Moderator
    17
    Aug 5, 2007
    Sweden

    You're missing QtCore.

    Do the following:
    brew install libusb
    brew reinstall python --with-tcl-tk
    pip3 install configparser
     
  16. mikymax972

    mikymax972 Member

    Newcomer
    1
    Sep 18, 2008
    United States
    Thanks but i have a error with brew reinstall python --with-tcl-tk
    Error: Invalid option: --with-tcl-tk

    problem solved thanks
     
    Last edited by mikymax972, Mar 28, 2019
  17. borngborn

    borngborn Advanced Member

    Newcomer
    4
    Jun 6, 2018
    United States
  18. LightBeam

    LightBeam GBAtemp Regular

    Member
    3
    Oct 1, 2018
    France
    Same, doesn't work with goldleaf .5
     
  19. LapCheong

    LapCheong GBAtemp Regular

    Member
    2
    Mar 6, 2019
    Australia
    GoldLeaf has some USB protocol changes

    All previous version of NS-USLoader is not compatible with past GoldLeaf releases. OP has to update i guess
     
    rommy667 and Dragonx41 like this.
  20. Rushhour77

    Rushhour77 Advanced Member

    Newcomer
    4
    Aug 1, 2007
    Netherlands
    NL
    Question, it seems that long filenames can crash tinfoil with fluffy, atleast thats my experience. Anyone knows how long filenames can be?

    Great tool. Very user friendly imo.
     
Quick Reply
Draft saved Draft deleted
Loading...