Feeling a little lost... Can't install PriiLoader

Discussion in 'Wii - Hacking' started by empee, Sep 20, 2010.

Sep 20, 2010
  1. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Hello, gents.

    Picked up a black Wii today (4.2U) and was excited to get started with the hacks. Ran HackMii, got the Homebrew Channel loaded, installed BootMii as an IOS, backed up my NAND.

    Next step was going to be installing PriiLoader so I have some measure of brick protection -- I know BootMii in boot2 is the best, but obviously that isn't an option -- but that's where I'm having issues.

    Following the Complete Softmod Guide, I got to reintroducing the Trucha bug by downloading IOS36 v3351 through the NUS Downloader. Ran IOS236 Installer, which seems to have patched everything successfully. No error messages that I could see.

    However, when I go to install PriiLoader, here's what I get:

    "ES_Identify failed, error 429496679. IOS61 not patched with ES_DIVerify?"

    Reran IOS236 Installer and repatched successfully. Checked DOP-Mii's system analysis and found that though IOS36 v3351 had installed, it's not fakesigned.

    What gives here? All I want to do is get PriiLoader installed for some hacks and brick protection and make sure I can run a USB loader so I can play backups of my old, scratched up games. Am I even doing the right thing?

    Any help is greatly appreciated!
     
  2. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Here's something I just noticed:

    When I run the PriiLoader installer, the text in the upper left corner reads "IOS61 rev 5405."

    In this guide I found, it says "IOS36 rev 65535" (screenshot: http://bit.ly/bJjrHK). Is that some sort of hint as to what's going on? Why's it using IOS61 on my Wii?
     
  3. manvslife12

    Newcomer manvslife12 Member

    Joined:
    Feb 11, 2010
    Messages:
    12
    Country:
    Vietnam
    1st sorry my english too bad
    I found this for you
    Code:
    http://gbatemp.net/t249491-priiloader-and-ios58-problem
    http://gbatemp.net/t249424-using-preloader?st=0&p=3060244
    I hope it work for you [​IMG]. Last week i have this problem, and the way i did is repatched ios36. and load it in MMM and -> app -> priiloader -> it ok.
     
  4. 75UR15

    Newcomer 75UR15 Advanced Member

    Joined:
    Jul 5, 2010
    Messages:
    82
    Country:
    United States
    One, installing IOS236 (36 patched) installer will not change anything in IOS36, it takes the original IOS36 and modifies it, then installs the modified version in the slot 236, the 36 slot remains untouched. If you want a text only laymens term for how to install priiloader on 4.2 I most like my guide (which is specific to 4.2 and uses the most compatible cIOS I have tried) which can be found here. It tells you not only what to do, but what each part is for.
    The main stickied guide for the site would also work, just check above your post to find that one.
    I would recommend not using the cIOS it installs with that guide, r17 (what my guide uses) is 100% wad friendly, installs a maxed version to slot 250 (just in case) and thus far hasn't caused me a single problem. r20 (sticky guide) is not wad friendly (gives another option in 250 instead though) and doesn't max version number on either slot (which limits ability to let ninty install over it if you lose your mind and update). Either of course is personal preference.
     
  5. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Thanks for the responses.

    manvslife12: Thanks for the links. I'll check them out if 75UR15's instructions don't work. I think his guide is the closest to my situation.

    75UR15: Looks great. I'll have to give it a shot when I get home from the office today.

    Out of curiosity, do you know if restoring a NAND backup from a PriiLoader -> BootMii IOS boot is safe? I'm seeing a lot of conflicting reports and I'd like to get your feedback since you're knowledgeable.

    Thanks again!
     
  6. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Confused here. Your guide's link to the TBR is dead, so I found it elsewhere (http://gbatemp.net/index.php?showtopic=165489). When I launch TBR, it asks me which IOS to load, with a default of IOS36. Is this where I select IOS15 ("first screen")? I didn't have to press 1 to load the application, so am I using the wrong version? My Wii also didn't restart after I launched it. Very hesitant to move forward.

    The upper-right corner reads "IOS61 rev 5405," if that's of any help.
     
  7. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    From the TBR page on WiiBrew:

    Guessing there's some reason that I shouldn't be using this...?
     
  8. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    This is an excerpt from one of ModMii's custom guides. This will help u install Priiloader.

    If u run into any other problems with anything else, I suggest u use ModMii as it will likely lead to the simplest/fastest solution.

    Code:
    #) INSTALL PRIILOADER
    
    Launch Multi-Mod Manager (MMM) via the Homebrew Channel
    
    Note: IOS236 should be loaded automatically.
    If it isn't, select "Load another IOS" and select IOS236
    (or any IOS you know is patched).
    
    In Multi-Manager Mod's main menu, go down to select "App Manager",
    Then select the "Priiloader installer".
    After the Priiloader Installer loads, press + to install it using the loaded IOS.
    
    Priiloader may give the following two 'yellow' errors. These are expected and are not an issue.
    loader.ini couldn't delete error -106 
    password.txt couldn't delete error -106 
    
    After successfully installing Priiloader, access it by powering off the wii,
    then powering it back and holding reset while it's booting until you see the Priiloader menu.
    
    You should install some system menu hacks now (by going to System Menu hacks option).
    
    RECOMMENDED HACKS: Block Disc Updates, Block Online Updates, Replace Health Screen, Auto-Press A at Health Screen, Disable Deletion of some important channels, Region-Free Everything, remove no copy save file protection, and Move Disc Channel.
    
    The priiloader menu is white by default, you can change it to black in the Priiloader settings if you prefer.
    
    One of the special functions of Priiloader is that it can autoboot any app/file instead of the system menu. Some apps (like crazyIntro) can't be used without it.
    For details on how to do so, visit http://www.completesoftmodguide.tk/system-hacks/priiloader
     
  9. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Nasty. This does the job for me, no other WADs/etc. necessary?
     
  10. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    if u already have successfully installed a patched IOS236, all u need to install Priiloader is MMM to reload to IOS236 and launch the Priiloader Installer... nothing else is required.
     
  11. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Do I need an internet connection? Hopefully last question. Thanks!
     
  12. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
  13. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Got PriiLoader installed via MMM, but if I'm following what's going on, now I have PriiLoader but no Trucha bug, which means no USB backups or emulators, correct?

    I was able to get the IOS249/250 stubs uninstalled through IOS236, but I don't know what's going on now or what I need to do or have done.
     
  14. Arm the Homeless

    Member Arm the Homeless Custom Title

    Joined:
    May 26, 2008
    Messages:
    1,762
    Location:
    /home/andy/
    Country:
    United States
    You don't need the trucha bug.
     
  15. borissaid

    Member borissaid GBAtemp Regular

    Joined:
    Sep 27, 2008
    Messages:
    116
    Country:
    United States
    For the usb loading you'll need one, or all, of these cios's 222,223,224,249,250 - depending on what loader you use and what games you are trying to play. You should be able to install either using their respective installers and selecting ios236 as the ios to load when doing the installation.
     
  16. Hozu

    Member Hozu GBAtemp Regular

    Joined:
    Aug 25, 2010
    Messages:
    239
    Country:
    Canada
    You need to find an installer for cIOS rev 20b and use it to install 249/250. It will ask you which base IOS to use/modify and then which slot to install it in. I hear using 56 as the base works the best but I don't know the difference. Most apps that require a cIOS run off of 249 by default but they can usually be changed.
     
  17. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    You say "cIOS rev. 20b" -- do you mean cIOSX rev. 20b?
     
  18. empee
    OP

    Newcomer empee Member

    Joined:
    Sep 20, 2010
    Messages:
    10
    Country:
    United States
    Alright, you guys are the Straight Up Real Deal.

    It's the end of the day and I'm hanging out in USB Loader GX after installing a patched IOS56 to IOS249 via IOS236. Anyway, I think that's the correct terminology. It's working.

    I'm sure I'll break something else, but this is a great place to be. Thanks to everyone for the help.
     

Share This Page