Hacking DSI XL 1.4.1 and DSTTi Gold firmware v1.17a12sp8

sylviebi

Well-Known Member
OP
Newcomer
Joined
Nov 24, 2010
Messages
48
Trophies
0
XP
30
Country
Canada
Hi,

I have a DSI XL with v1.4U and a DSTTi Gold (www.ndstti.cn) with v1.17a12sp8 which I downloaded from the previously mentioned site. It's works great.

I know it's the fake one and please don't tell me to buy a real one. I was cheated and now I am trying to make the best of it.

My questions is does anyone have this card running on a DSI v1.4.1? I know what the site says but they are a knock-off company so there goes their credibility in my eyes. I want to here from people who actually have this scenario.

Oh and I don't know if this helps but the card comes up as Alex Rider Stormbreaker THQ. Does that mean anything to anyone?

Thanks for your time,
Sylvie
PS: I know the golden rule is to not update but what if I really wanted to?! :-)
 

bitonio6

Well-Known Member
Member
Joined
Sep 30, 2009
Messages
1,801
Trophies
0
XP
47
Country
Swaziland
if you have starwars on your DSi screen before your start your DSTTi gold = 1.4.1 will not work with it
But DSTTi GOLD exist in 1.4.1 compatible, but the old one cant be upgraded!!!
 

sylviebi

Well-Known Member
OP
Newcomer
Joined
Nov 24, 2010
Messages
48
Trophies
0
XP
30
Country
Canada
ok. I decided I could live without the data management and went ahead and updated my dsi to 1.4.2u and it worked. yeah. I must say it was a pretty long 2 minutes from the time I started the update to the time I tested my dstti gold card.

before anyone jumps in I just bought this card on 26 oct 2010 and the site did claim that it worked. So now it's confirmed in my eyes anyway.

thanks, Sylvie

PS: I tested it on my daughter's dsi first as she doesn't know about or use the card yet and she would have been none the wiser. lol
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    FAST6191 @ FAST6191: I think that means you have hit middle age at least +1