DSi 1.4.

Discussion in 'R4 DS' started by SenutiAi, Nov 27, 2009.

  1. SenutiAi
    OP

    SenutiAi Advanced Member

    Newcomer
    63
    0
    Oct 1, 2009
    United States
    Alright I was stupid enough to update my DSi to the firmware 1.4, I didn't know it was going to do anything bad. But now that my R4i ultra won't work, I don't know what I should get.
    Should I get the R4i SDHC V 1.4?
    http://www.dealextreme.com/details.dx/sku.22584
    Or another flash cart?
    And my second question is will that flash cart work even though I already upgraded to 1.4
     
  2. SenutiAi
    OP

    SenutiAi Advanced Member

    Newcomer
    63
    0
    Oct 1, 2009
    United States
    I really can use all the help I can get right now
     
  3. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Don't get a R4 at all.
    Get a M3i0 or a Ez flash vi if you need 1.4 compatability out of the box. (M3i0 requires flashing but doable from outside of ds) No flashcarts won't work unless they have the 1.4 update. If you have another ds that can flash a flashcart you could for with an Acekard 2i as well.
     
  4. SenutiAi
    OP

    SenutiAi Advanced Member

    Newcomer
    63
    0
    Oct 1, 2009
    United States
    Alright, so the EZ FLASH VI, works right out of the box?
    And is there a) links to that, and b) proof?
     
  5. elixirdream

    elixirdream GBAtemp Legend

    Member
    10,007
    2
    May 27, 2008
    Malaysia
    6th Dimention
    its on dealextreme [​IMG]
     
  6. Leonidas

    Leonidas GBAtemp Fan

    Member
    479
    0
    Aug 27, 2009
    Slovenia
    sLOVEnia
    I'm pretty sure the Ez-Flash Vi requires external patching (another DS console), just like the Acekard 2i. If you want a fully upgradeable flashcart without the need for another DS, then you will probably want to buy the M3i Zero, which comes with a special USB connecting cable.
     
  7. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
  8. SenutiAi
    OP

    SenutiAi Advanced Member

    Newcomer
    63
    0
    Oct 1, 2009
    United States
    I don't have another DS console, so should I just get the M3i Zero?
     
  9. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Well if you don't like to check gbatemp for info on updates yes. [​IMG] Doesn't really matter though but if you keep accidently upgrading your firmware yeah get a M3i0. Either way both are good carts.
     
  10. SenutiAi
    OP

    SenutiAi Advanced Member

    Newcomer
    63
    0
    Oct 1, 2009
    United States
    Alright thanks a lot for your help, I'll probably be back very soon with M3i Zero questions, especially how to use it for the first time....lolz...and I should get it from dealextreme?
     
  11. elixirdream

    elixirdream GBAtemp Legend

    Member
    10,007
    2
    May 27, 2008
    Malaysia
    6th Dimention
    If thats your case, it would be better you get m3i0 or scds1i/2

    who knows accident do happen [​IMG]
     
  12. SenutiAi
    OP

    SenutiAi Advanced Member

    Newcomer
    63
    0
    Oct 1, 2009
    United States
    Now that I think about it, I should just get it out of the way and get the firmware now, where do I go to get the firmware?
     
  13. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
  14. anubiss

    anubiss Member

    Newcomer
    41
    0
    Aug 5, 2008
    United States