DS lite won't boot -- both screens flash

Discussion in 'NDS - Console and Game Discussions' started by []KAOS[]Casey, Jun 14, 2015.

  1. []KAOS[]Casey
    OP

    []KAOS[]Casey Member

    Newcomer
    2
    Jun 2, 2009
    United States
    I just swapped a working DS lite into a new shell, and initially the top screen flashed when turning it on so I reseated the bottom LCD, and now it flashes both LCDs and turns on, gets a brighter green light, then turns off.

    The fuses look okay, but the EM10 filter is cracked (I can actually lift it apart!) so I can't charge.. but that does explain why it was flaky on charging before... I thought it was the connector, silly me.

    If I disconnect the wifi module the unit stays powered on but I get no video. Is it possible that the wifi module broke and is causing this issue or are there other things I can check?

    Thanks for any help.
     
  2. VashTS

    VashTS Beat it, son

    Member
    7
    GBAtemp Patron
    VashTS is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 14, 2009
    United States
    Upstate NY
    might be the screen connector ribbon cable. i know that happens with DSi's at least.
     
  3. []KAOS[]Casey
    OP

    []KAOS[]Casey Member

    Newcomer
    2
    Jun 2, 2009
    United States
    That is what I suspect, as it does have a small crease in the cable.. Damn that thing was difficult to thread in and out. If no one else has any suggestions i'll buy a cable and report back.
     
  4. Retro_Mod_Gamer

    Retro_Mod_Gamer Member

    Newcomer
    1
    Nov 3, 2015
    Canada
    The WiFi card doesn't even have to be connected for it to work. Did you test it before putting it back together?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice