Downgrade Custom Firmware, is it possible?

Discussion in '3DS - Flashcards & Custom Firmwares' started by WiiHoney, Jun 11, 2016.

  1. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    After following this guide https://github.com/Plailect/Guide/wiki by @Plailect , I succeeded in installing the Luma3DS CFW on my 9.2 O3DS, I dont hold anyone on this forum accountable for my own action.

    I was under the impression that i would be able to play my games through the Gateway RED cart. but i was surprised to find out that there is no such thing. I copied GW4.0b files: arm9loaderhax.bin, Launcher and boot.3ds to root SD card and GW folder to /3ds. but all i was getting is black screen upon powering up the system.

    As it was mentioned in the guide, I have HBL.cia installed, so opening the HBL and clicking on the Plaisysupdater_v04 to downgrade my system from "sys. 11.0.0-33" (notice that CFW will say sys. instead of ver. ) to fw9.2. I clicked on Y than the screen stuck on "INIT HAX..."
    I have updates folder in the root of the SD card with Firmware 9.2

    My questions:

    Has anyone succeeded in using GW red cart with Luma3DS? if so, can you please provide the steps that a noob like me can follow?

    How can i restore sysNAND_original.bin fw 9.2 back to my O3DS? I dont mind loosing A9LH.
     
    Last edited by WiiHoney, Jun 11, 2016


  2. Lia

    Lia is this the real life

    Member
    1,501
    2,928
    Jan 29, 2016
    United Kingdom
    Did you copy the 'luma' folder to your SD Card. That might let you power on the system.
    Also how are you getting to the hbl cia if you can't power on your system?
    And if you can power on your system, install the plaisysupdater cia, it will allow you to downgrade.
     
    Last edited by Lia, Jun 11, 2016
  3. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    I can boot the system fine, but i cant boot when i copy the gateway files and folder
     

    Attached Files:

  4. Lia

    Lia is this the real life

    Member
    1,501
    2,928
    Jan 29, 2016
    United Kingdom
    I'm not sure how this gateway stuff works, I've never dealt with it before. But, did you install A9LH with gateway? Or did you just install the A9LH on Plailect's guide? If you installed it without gateway, you don't really need your card anymore, since you can just install CIAs or tickets. These are much less hassle as you don't need a card, you don't need a pc, you don't need roms. Just CIAngel/TikDevil/FreeShop/etc
     
    Last edited by Lia, Jun 11, 2016
  5. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    I followed Plailect's guide to the tee. The whole process was success, system boots with no problems but i cant access GW Red cart no matter what i tried.

    downgraing and trying to restore back to fw 9.2 result in INIT HAX... screen and nothing else
     
  6. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    Using the red cart "with Luma" is impossible, you have to use it with the Gateway CFW.
    But using the arm9loaderhax.bin file provided by Gateway and by having the Launcher.dat at the root of the SD card, you should be able to boot to Gateway through a9lh.

    The stupidest way to get to that point is just to replace the arm9loaderhax.bin file at the root of the SD card with the one provided by Gateway (make a backup of your old arm9loaderhax.bin file, in case you have an a9lh setup that is incompatible with the arm9loaderhax.bin provided by Gateway).

    Other ways are for example to rename it "x_GW.bin" and put it in the /luma/payloads/ folder so that it boots with X pressed and Luma boots by default, whatever suits you.
     
    Xenon Hacks, WiiHoney and CrispyYoshi like this.
  7. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    You don't need to do that: liomajor provided a solution for users like you. However, I think luma can do it without the mod, but I'm not sure. I'll edit this post in a moment with the URL: I'm on a mobile phone...

    EDIT: Ninja'd, forget about the URL. Should work with Luma payloads folder if the previous poster is right.
     
    Last edited by CrispyYoshi, Jun 11, 2016
    WiiHoney likes this.
  8. Lia

    Lia is this the real life

    Member
    1,501
    2,928
    Jan 29, 2016
    United Kingdom
    If you're on A9LH 11.0, put away your card xD. You really won't need it. Just install CIAs. Much less hassle. If you really want it, downgrade using the PlaiSysUpdater CIA file, but you can just install CIAs now. Much better than roms.
     
    WiiHoney likes this.
  9. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    @Hayleia i tried what you suggested and none worked, I wish i know the Luma3DS isnt compatible with GW

    — Posts automatically merged - Please don't double post! —

    I have so many games on my GW mSD card that it wont fit on 8GB SD Card, also the 1000's of hours spent plaung those games with family members. I prefer to find a way to use GW saves.
     
  10. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Luma lets you redirect to GW through its payloads folder, but can't use the GW card if you already boot into the home menu in Luma.

    If you put GW's a9lh.bin in SD:/luma/payloads, then rename it correctly like X_GW.bin, you can boot GW on power on if you hold X (or whatever you rename the hot key to. Don't share the hot key with another payload!)
     
  11. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    Did you just follow Plailect's guide right now ? Because I've heard it now uses a9lh v2 and that one is incompatible with Gateway. You'd have to use a previous a9lh.
    And I can tell it is supposed to work, I can boot my Gateway CFW.

    And btw, that makes me smile a little. Like
    gateway makes their own a9lh implementation, incompatible with existing payloads
    everyone complains
    gateway gives an arm9loaderhax.bin payload compatible with existing a9lh implementations
    people update the regular a9lh implementation and it's now incompatible with gateway's payload

    Well I suppose it was not done on purpose (unlike GW who clearly tried to make people think they were the one who created the "Gateway Fast Boot" method and reduce the "real" a9lh to a mere "aka") but still, I found it funny...
     
    WiiHoney likes this.
  12. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    WiiHoney likes this.
  13. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    @Hayleia correct, i did the CFW last night. it does use v2.
    @CrispyYoshi I tried those suggestions but nothing happened after replacing Launcher.dat with GW's own

    Plaisysupdater not working here, stuck at HAX INIT...

    — Posts automatically merged - Please don't double post! —

    I cant do this:

    Booting Luma3DS will not let me load the GW Red cart.
    Plaisysupdater wont let me downgrade from CFW 11.0 to fw 9.2
    Replacing files with GW Launcher and a9lh.bin renamed it to X_GW.bin or down_GW9.bin will result in black screen after power is pressed.
    :-(

    I cant create emuNAND sd card cause i cant access emuNAND9 or Gateway throught HBL. it will reboot back to the main menu
     
    Last edited by WiiHoney, Jun 11, 2016
  14. gbatemplloyd

    gbatemplloyd Advanced Member

    Newcomer
    80
    8
    Mar 29, 2016
    Italy
    1.just follow plailect guide to the end.
    2.go to gateway site,and download launcher.dat and put it in the root of sd card.download also the arm9loaderhax.bin and rename to up_GWa9lh.bin and put it in luma payload folder.
    3.hold and press up while powering your 3ds to boot automatically in gateway sysnand.
     
    Last edited by gbatemplloyd, Jun 11, 2016
    WiiHoney likes this.
  15. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    I just want to be clear, so you only copied arm9oaderhax.bin.
    no Launcher.dat or GW folder to /3ds?
     
  16. CheatFreak47

    CheatFreak47 Complex Donut

    Member
    1,340
    902
    Oct 11, 2011
    United States
    Michigan, USA
    Reading the original post, @WiiHoney what setup do you wish to have going with your 3DS?
    Gateway with an EmuNAND would probably work fine for you, and plus you won't have to bother with any downgrading, more than likely. (:

    If so, you should create an EmuNAND on your SD Card (I guess using the GW Launcher?) and flash the 9.2 firmware to it with Decrypt9WIP. (Make sure you boot it with Arm9LoaderHax as a payload, not from homebrew launcher)

    In theory, it should just work, regardless of what the SysNAND is on. Once you have A9LH installed, it is irrelevant what firmware the sysNAND is on because anything A9LH runs has full Arm9 access.
     
    WiiHoney likes this.
  17. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    What you should do then is
    -restore a pre-a9lh sysNAND backup, like the 9.2 sysNAND backup you should have made before downgrading to 2.1
    -install an "old" a9lh (you don't lose any feature for now, you may just miss future features)
    -do whatever anyone said in that topic like rename GW's payload to x_GW.bin and put it in /luma/payloads/ or put it at the root of the SD card or whatever

    You need Launcher.dat at the root and arm9loaderhax.bin somewhere but the 3ds folder is useless.
     
  18. gbatemplloyd

    gbatemplloyd Advanced Member

    Newcomer
    80
    8
    Mar 29, 2016
    Italy
    i edited my post sorry for that....... you also need the launcher.dat
     
  19. WiiHoney
    OP

    WiiHoney GBAtemp Regular

    Member
    102
    2
    Mar 22, 2010
    United States
    Thank you! i was doing all wrong, i was booting to the sysNAND and clicking the HBL icon.
    I just pressed "start" and power to reboot to the hourglass9 NAND

    Now i am doing a sysNAND restore back to FW 9.2. wish me luck

    @Hayleia and @gbatemplloyd i am hoping that restoring back to FW9.2 will make my life easier until there is a solid support for Luma3DS and Gateway
     
  20. Hayleia

    Hayleia GBAtemp Maniac

    Member
    1,485
    1,135
    Feb 26, 2015
    France
    Depends what you call "solid". I'm on the good old a9lh with both Luma and Gateway working and I don't have anything to complain about ;)
    Maybe someday a revolutionary feature will be exclusive to a9lh v2 but for now, it doesn't bring anything new for real.