does SXOS 2.1 or 2.0.1 work with creating emunand from 2.3.0 OFW?

Discussion in 'Switch - Backup Loaders & Modchips' started by weatMod, Oct 13, 2018.

  1. weatMod
    OP

    weatMod GBAtemp Addict

    Member
    8
    Aug 24, 2013
    United States
    as title says can i use the new SXOS 2.1 or 2.0.1 update to create an emunand if my switch official sysnand firmware is on 2.3.0 OFW
    i want to keep my switch on 2.3.0 sysnand and update emunand to 6.0 ?
     
  2. GeraltOfRivia

    GeraltOfRivia Advanced Member

    Newcomer
    3
    Jul 25, 2018
    Italy
    Sure you can, why not? Install Sx os 2.1 and set up emunand. Once you have done, through the emunand use choidujourNx and install 6.00 fmw offline.this won't affect your original nand. And you will have a dual boot system.
     
    jakkal likes this.
  3. weatMod
    OP

    weatMod GBAtemp Addict

    Member
    8
    Aug 24, 2013
    United States
    th
    anks yeah i know i just was reading reports of emunand not working on FW below 3.01 with SXOS 2.0 i was not sure if it got fixed or not in the new update
     
  4. jakkal

    jakkal GBAtemp Addict

    Member
    12
    Apr 27, 2018
    United States
    do you need a second micrsd card for the emunand?
     
  5. GeraltOfRivia

    GeraltOfRivia Advanced Member

    Newcomer
    3
    Jul 25, 2018
    Italy
    It depends on you and how you want to use it. I try to explain better: once I created the shadow nand, I factory reset my sysnand to unlink and separate from the"emunand". All the games and save stayed untouched and I continued to use them in emu, because from now on I will use only this. My sys stays clean to 4.1 ofmw meanwhile the shadow at 6.00, so for now I use only one sd card. If you choose to use both sys and shadow, you'll need two SD cards, otherwise all files will be wiped away and messed up cause they share the same "Nintendo" folder. I hope I got myself explained ;)
     
    kamesenin888 likes this.
  6. jakkal

    jakkal GBAtemp Addict

    Member
    12
    Apr 27, 2018
    United States
    explained perfectly
    i figure you can use one sdcard by renaming the sysnand Nintendo folder to Nintendo.bak then changing it back to its original folder name when you go back to using the sysnand
    The same could be done for the emunand Nintendo folder as well

    maybe tx could implement something in their next update that automatically renames the Nintendo folders each time you change between original nand and emunand. SO ultimately youd have 2 Nintendo folders on your micro sdcard

    @garyopa what do you think?
     
    Last edited by jakkal, Oct 14, 2018
  7. GeraltOfRivia

    GeraltOfRivia Advanced Member

    Newcomer
    3
    Jul 25, 2018
    Italy
    Yeah, you got it! Your method of renaming folder is a good one if you want to keep everything on a big SD card ;) changing SD every time can be a real pain in the ass sometimes..it would be great if the cfw recognise the right folder !

    — Posts automatically merged - Please don't double post! —

    Don't know for sure to be honest.. but I can say that many people are happy now with the fixes! The 2.0 version was very unstable and buggy, many games constantly freezes during gameplay or loading menus and there were issues with firmware compatibility. I think this "emunand" totally deserve a try, you can always erase everything if you don't like it ;)
     
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Yeah, it's fixed.
     
    weatMod likes this.
  9. weatMod
    OP

    weatMod GBAtemp Addict

    Member
    8
    Aug 24, 2013
    United States
    ok thanks , so one more question how do i set an emunand up with 2.3.0 if i want to use my 256 gb card formatted to exfat ,i have a virgin 256gb evo plus i want to format to exfat
    right now i am using a 32 gb fat 32 formatted card on SXOS (1.6 i think)

    so since 2.3.0 does not recognize exfat then should i use my fat32 formatted card to make the emunand put the newSXOS boot.dat on it and then just put in the new 256 gb exfat formatted card with the SXOS 2.1 boot.dat after i select enable emunand?
    or will i still be able to do it all with my 256 gb card?
    like if i format 256gb card to exfat and put the new SXOS 2.1 boot.dat on it and boot my switch will it even boot? ,does SXOS boot from efat and can it backup nand and create emunand like that ,does it have its own drivers for the card reader or does it depend on drivers from horizon?
    or is it it's own separate thing and can perform the nand dumping nad emunand creation without needing the current FW to support exfat?
     
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    You should be able to load the boot.dat even when the card is exFAT formatted. Once on emuNAND you can install the exFAT update. But you might want to use a FAT32 card temporarily for setting up, as you need a working card to use ChoiDujourNX (there is still ChoiDujour for PC but that's more effort)
     
    finn112 likes this.
  11. mikefor20

    mikefor20 GBAtemp Advanced Fan

    Member
    6
    Jan 12, 2009
    United States
    Mushroom Kingdom
    What about the Game Cart slot fuse? If he is in 2.x(or 3.0.1 like me) and he updates EmuNAND to 6.X won't that burn the GC slot fuse? Will the slot still function when he is using his 2.X Nand? I assume it will not function on 2.X(Or 3.X)
     
  12. weatMod
    OP

    weatMod GBAtemp Addict

    Member
    8
    Aug 24, 2013
    United States
    why would it if i only update the emunand to 6.0 and my sysnand stays on 2.3.0
    i hope that should not burn an efuse
     
  13. weatMod
    OP

    weatMod GBAtemp Addict

    Member
    8
    Aug 24, 2013
    United States
    when you say install the exfat update, how do i do that exactly do i need to to that with choidujour or is the exfat update now included in the FW update like 6.0 ?
    like if i only update my emunand to 6.0 do i still need to install the exfat driver separately to sysnand or emunand or both? i only plan on booting into emunand with this card (my only purpose for emunand is to preserve 2.3.0 without need for updating and later downgrading with choidujour) so will it still work with my card formatted to exfat
    or do i need to install the exfat drivers on sysnand with choidujour ?
     
  14. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Using ChoiDujourNX to update the firmware, you can choose if you want exFAT or non-exFAT version.
    I would not recommend installing it to sysNAND since the idea is to keep sysNAND clean.
     
  15. mikefor20

    mikefor20 GBAtemp Advanced Fan

    Member
    6
    Jan 12, 2009
    United States
    Mushroom Kingdom
    But booting in to Firmware higher that 4.1 burns a Game Cartridge Slot fuse. Will that happen in this instance? I don't think SXOS protects the cart slot. Won't that mean booting in to EmuNAND in 5.X or higher render the cart slot useless when you boot in to the SysNAND still on 2.X?
     
    weatMod likes this.
  16. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    You are right, it doesn't. But on 2.x you won't be able to run most games anyway. IMO the best use of emuNAND is just to keep sysNAND clean for online use with both NANDs updated. But if you want to keep sysNAND on old firmware for future exploits then you are pretty much stuck with using emuNAND only, and no online.
     
    weatMod likes this.
  17. weatMod
    OP

    weatMod GBAtemp Addict

    Member
    8
    Aug 24, 2013
    United States
    oh ok so if the cart slot fuse gets burned then i can still use the cart slot but just not on a lower FW than what i have on my emunand is that right?
    so if say a cold boot exploit becomes available for 2.3.0 only i won't need to worry because i can boot my emunand and the cart slot will still work on emunand and if we never see a cold boot exploit for 2.3.0 then i can still update my sysnand to the lastest FW and go online with legit carts ?
     
  18. GeraltOfRivia

    GeraltOfRivia Advanced Member

    Newcomer
    3
    Jul 25, 2018
    Italy
    Sorry if I sneak into your discussion :) I made emunand keeping my sys at stock ofmw 4.10 and updated emu at 6.00.. so Am i screwed with cart reader too? I made cart reader useless ? Sorry but I didn't understand very well this point. Thank you in advance for your help.
     
    weatMod likes this.
  19. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Yeah.
    I think it only applies to sysNAND < 4.0.
     
    GeraltOfRivia likes this.
Loading...