Do I need to buy a new R4 or just need to update?

Discussion in 'R4 DS' started by deltascourge, Jul 26, 2016.

  1. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    So, my old DSi XL has a huge crack in the top LCD screen, and some weird ink is slowing out of it, creating a huge black spot on it. I've had this for years now, and haven't touched that DSi in years either.

    Now, yesterday, I decided to buy myself a new DS, but also one that could play 3DS games because that's what all the new games gets made on. I ended up deciding on a 2DS for price reasons (Student life, yo)

    Upon doing a quick inspection of my old DS, I found that my old R4 card claims it works on a 3DS, but upon trying to use it on my 2DS, however, it claims it doesn't work and tells me to restart. Thinking it was probably due to its age, I quickly recharged my old DSi to a point where it would start, and tried my R4 on there, and it worked without issue.

    Now, after doing a quick google search, this R4 card is apparently not the best one you can get, in fact, most people apparently say its garbage, and that its quite common for it to arrive dysfunctional. However, since I've used it for a couple years, and it still works on my old DSi, I'd still like to give it a try.

    My question is, is this simply a case of old firmware, or is it falsely advertised as being able to work on a 3DS (because if so, I'll just get my LCD screen fixed and gift them to my 12 year old brother for now)

    This is the card I have: http://www.r4i3d.com/
     
  2. blaisedinsd

    blaisedinsd GBAtemp Maniac

    Member
    1,023
    118
    Dec 6, 2012
    United States
    try to update it. Some 3DS firmware updates block R4 but can be updated. Some really old cards can't update to work with newest 3DS firware but since yours says 3DS it probably will work if you update to the latest software.
     
  3. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    I'll give it a try. I'll see if I can find an adapter or something lying around.

    If updating doesn't work, do you have any alternative flashcards (Prefferably ones that allow for Paypal payments, as credit cards are rare here)
     
  4. nl255

    nl255 GBAtemp Addict

    Member
    2,582
    364
    Apr 9, 2004
    Assuming you haven't updated your 2DS firmware to 11.0 yet then I would suggest downgrading it and installing a9lh/luma which will make even the original R4 work.
     
  5. natanelho

    natanelho GBAtemp Maniac

    Member
    1,322
    345
    Apr 25, 2015
    Antarctica
    Between the Sacred Silence and Sleep
    Man if you'll a9lh it an use the 2nd launcher(or whatever its called) then most of even unsupported and old r4 cards and clones will work on your 3ds even if normally they wouldnt... I do it with my dstt
     
    Bubsy Bobcat likes this.
  6. blaisedinsd

    blaisedinsd GBAtemp Maniac

    Member
    1,023
    118
    Dec 6, 2012
    United States
    In my experience the best is the Super Card DStwo....costs a bit more but I haven't had it get blocked on 3DS in a loooong time. R4 I bought several times and had to update or hardware became outdates for 3DS or it even outright died on me.

    My Supercard had the plastic case kind of split but other than it works perfect and emulates more stuff.
     
  7. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    Whoops, can I still downgrade it?
     
    Last edited by deltascourge, Jul 26, 2016
  8. nl255

    nl255 GBAtemp Addict

    Member
    2,582
    364
    Apr 9, 2004
    Not without a hardmod or another 3ds/2ds that is already hacked. If it isn't too late I would suggest you try to return it for another unit (i.e. for an exchange rather than refund). You could always carefully put a little scotch tape over the battery contacts (in a way that won't show, of course) so that it won't boot up or something.
     
  9. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    That's quite a shame. However, does this mean R4 flashcards won't work anymore either? Or is that still doable?
     
  10. nl255

    nl255 GBAtemp Addict

    Member
    2,582
    364
    Apr 9, 2004
    It depends on the card. For a while there was an arms race between Nintendo blocking DS flash carts and flash cart makers working around the blocks. Eventually (around firmware 7.0 or so) Nintendo just stopped caring but depending on which one you have you may have to get a new R4 that is still supported. Or return/exchange your 2DS and then hack the new one which will let you do all sorts of other stuff as well.
     
  11. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    Well, as I stated in my OP, this is the card I have right now: http://www.r4i3d.com/

    If that doesn't work, is there any card that you know works and you do recommend? I've been looking at the R4i Gold, but it doesn't seem like any of the sellers accept Paypal and ship to Europe
     
  12. nl255

    nl255 GBAtemp Addict

    Member
    2,582
    364
    Apr 9, 2004
    Very few sellers will accept paypal because paypal doesn't like flash cart sellers and will lock their accounts (and keep all the money in them) if they find out about it.
     
  13. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    Oh damn, that sucks. I can always take a chance on Ebay as a last resort if this doesn't work. Do you know anything about the card I linked?
     
  14. nl255

    nl255 GBAtemp Addict

    Member
    2,582
    364
    Apr 9, 2004
    No I don't, sorry.
     
  15. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    Oh well, I'll just spend some money on an adapter. Worst case scenario, my younger brother has something to enjoy before he inevitably breaks it within a week
     
  16. deltascourge
    OP

    deltascourge Newbie

    Newcomer
    9
    0
    Jan 12, 2015
    Netherlands
    So I got myself an adapter, but the instructions on updating it are very confusing. Can anyone help me out?

    1. First, download the Corresponding kernel,unzip the kernel and copy the files to the root of MicroSD card. (Assuming that's the file I just downloaded)
    2. Download the upgrade Firmware,unzip and copy the files(fwUpdateAll_V7.00.nds) to the root of MicroSD card. (Its an .nds file, not a .zip. Or I may have gotten the wrong one)
    3. Insert MicroSD card into your r4i card, insert r4i card into nds\dsl\dsi\dsill\dsixl\3ds(less than V7.0.0-13). (Did I mess up by updating?)
    4.Turn on console and press ¡°A¡± button to run the upgrade file fwUpdateAll_V7.00.nds. (Not sure what these buttons are meant to be)
     
  17. blaisedinsd

    blaisedinsd GBAtemp Maniac

    Member
    1,023
    118
    Dec 6, 2012
    United States
    Do this on your DSi XL. Unzip the software and put it on the root of you SD card, then put it in the DS and run the update. After that it should work in your 3DS.