Do i need PopsLoader to plat PSX games? (5.00 m33-6)

Discussion in 'PSP - Games & Content' started by Vladimir, Aug 16, 2010.

  1. Vladimir
    OP

    Newcomer Vladimir Advanced Member

    Joined:
    Aug 4, 2010
    Messages:
    68
    Location:
    Guadalajara, Mexico
    Country:
    Mexico
    Hi, well, that's my question, Im on m33-6 and i can run lots of PSX games, just by saving them on ms0:/PSP/GAME/ as an eboot, but there are some games i can't, like Final Fantasy VII.
    I wonder if i need POPSLoader to play games like Final Fantasy VII.

    I really dont understand the difference between the included "official emulator" on my psp and POPSLoader. Thanks in advance.
     
  2. purechaos996

    Member purechaos996 GBAtemp Advanced Fan

    Joined:
    Nov 5, 2008
    Messages:
    765
    Location:
    Connecticut
    Country:
    United States
    ...I believe like you said popsloader is built into M33-6 so you should be able too but I would just download the newest POPs and try it out that way too. idk I dont play PSX games on my PSP that much
     
  3. GreatCrippler

    Member GreatCrippler Greatness Fallen

    Joined:
    Mar 27, 2010
    Messages:
    1,141
    Country:
    United States
    Pops is a plugin that allows the PsP to use better compatibility based on previous releases. For example... I think FFVII Ran better on 3.71-m33... thus you set the pops to that setting.
     
  4. Apex

    Member Apex GBAtemp Fan

    Joined:
    Sep 4, 2006
    Messages:
    361
    Location:
    茨城県
    Country:
    Japan
    Yeah, you more or less need it, I'd go for the multi-pops loader pack, let's you switch upon booting the game to compare and contrast platability.
     
  5. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    When you run a PSX game it uses the POPS version of your current firmware, but for some games you'll want to use an older version of POPS, so POPSloader allows you to switch POPS versions on the fly.
     
  6. fgghjjkll

    Member fgghjjkll GBATemp MegaMan

    Joined:
    Jul 7, 2008
    Messages:
    2,038
    Country:
    Australia
    For some reason, POPS 5.00 works with NOTHING that doesn't include that background, icon and stuff. Otherwise, the compatibility is pretty good.
     

Share This Page