Disc drive not being detected.

Discussion in 'Computer Games and General Discussion' started by triassic911, Dec 4, 2009.

Dec 4, 2009
  1. triassic911
    OP

    Member triassic911 Burst Mode

    Joined:
    May 9, 2007
    Messages:
    2,743
    Location:
    NYC, USA
    Country:
    United States
    Ok so ever since I installed windows 7 a while back, whenever I boot up the comp with a usb drive or usb drives, it takes the place of the my dvd drive which is drive D:. The only way to fix it is to reboot my comp with no usb drives plugged in. This gets really annoying. Is there a way to fix this so that drive D: is reserved ONLY for my dvd drive?
     
  2. soulreaper1981

    Newcomer soulreaper1981 Newbie

    Joined:
    Jan 14, 2010
    Messages:
    5
    Country:
    Australia
    Trassic,

    While I don't know for certain if this will solve your problem you can try assigning the drives a forced entry letter, which will then save it in the registry
    so all future uses of this device will be the same. I used this method for USB keys and had no problem.

    Short Version > Run > DISKMGMT.MSC
    Long Version > Open an explorer window, and right-click "My Computer", then select "Manage"
    On the left-hand side, you'll find "Storage" and under that will be, among other things, "Disk Management" ... select that.

    This will show your drives and partitions. In the upper part of the right-hand display, right-click the USB drive you have installed,
    then select "Change Drive Letter and Paths..." then select "Change..." and a drive letter starting from 'E' since you want D to be your CDROM.

    Now whenever you unplug/plug in that drive it will get the information from the registry rather than assigning one.
    You can also do this by editing registry but this is a lot safer.
     
  3. BlackDave

    Member BlackDave Official GBATemp "Cleanup Guy"

    Joined:
    Aug 27, 2009
    Messages:
    913
    Location:
    The Promised Land...
    Country:
    United States
    I'm not gonna quote the message above (using DSi's browser) but I just want to add a quicker way of reaching the partition manager.

    - Click the start button
    -Type "FDISK" in the search button
    -Press enter et voilĂ ! [​IMG]
     

Share This Page