ROM Hack CTGP-7 "CT-Online" Problem

Gaming796

Gaming since 4
OP
Member
Joined
Aug 24, 2016
Messages
561
Trophies
0
Location
Your head
Website
gbatemp.net
XP
439
Country
United States
I've tried getting help on this issue on the CTGP-7 Official Thread itself, but no useful responses as of now. So I'm posting a new thread so that I get more relevant and useful responses. Problem is I can't access Online Multiplayer Mode in CTGP-7. I'm using a 11.0.0-33 U System Firmware, Homebrew Launcher 1.1.1 with latest version of HANS. I've also installed ctr-httpwn Ver. 1.0.1. The icon on the Title Screen Menu of CTGP-7 shows Ver. 1.1 but when I launch it I get an error like this: "In order to use Online Services a newer version of this Software is required. Download the newest version from the Nintendo eShop or other supported software.". I was confused why I got this error. That's because I saw on the Official CTGP-7 Thread that HANS allows Online Play for CTGP-7 provided you are in the latest firmware version or if you use ctr-httpwn. Now don't tell me you need a pre-patched copy of Mario Kart 7.... with Ver. 1.1 pre-installed..... If that's the problem, then I'm not gonna waste $29.99 just for getting another pre-patched Mario Kart 7 copy to play CTGP-7. That doesn't seem to be a nice idea.

Awaiting useful responses...:mellow::mellow::mellow:
 
Last edited by Gaming796,

Giodude

GBAtemp's official rock
Member
Joined
May 17, 2015
Messages
5,093
Trophies
1
Age
22
Location
New York
XP
2,722
Country
United States
I've tried getting help on this issue on the CTGP-7 Official Thread itself, but no useful responses as of now. So I'm posting a new thread so that I get more relevant and useful responses. Problem is I can't access Online Multiplayer Mode in CTGP-7. I'm using a 11.0.0-33 U System Firmware, Homebrew Launcher 1.1.1 with latest version of HANS. I've also installed ctr-httpwn Ver. 1.0.1. The icon on the Title Screen Menu of CTGP-7 shows Ver. 1.1 but when I launch it I get an error like this: "In order to use Online Services a newer version of this Software is required. Download the newest version from the Nintendo eShop.". I was confused why I got this error. That's because I saw on the Official CTGP-7 Thread that HANS allows Online Play for CTGP-7 provided you are in the latest firmware version or if you use ctr-httpwn. Now don't tell me you need a pre-patched copy of Mario Kart 7.... with Ver. 1.1 pre-installed..... If that's the problem, then I'm not gonna waste $29.99 just for getting another pre-patched Mario Kart 7 copy to play CTGP-7. That doesn't seem to be a nice idea.

Awaiting useful responses...:mellow::mellow::mellow:
Yeaa, hans removes all updates from any game you load it with, and it showing 1.1 is a bug. You need it to be pre-patched. You need another copy/eshop download of mk7, a hardmod, or a second 3ds for dsi downgrade. Sorry. Though if you want you can join the official ctgp discord so you know the second theres a new update, you can click this link: https://discord.gg/EjX7W. Sorry about bein the breaker of bad news.
 
Last edited by Giodude,

Clector

Well-Known Member
Member
Joined
Mar 15, 2016
Messages
1,034
Trophies
0
Location
Not here
XP
409
Country
Bangladesh
Yes you need the update preinstalled as HANS can"t use installed updates, you need to buy another newer copy of Mario Kart 7 or try if using the RomFS from the newer version can make it work.
 

Giodude

GBAtemp's official rock
Member
Joined
May 17, 2015
Messages
5,093
Trophies
1
Age
22
Location
New York
XP
2,722
Country
United States
If you want to ask pablo mk7 hes on the discord sevrer. The romfs thing sounds intersting. I dont see why it wouldnt work but i'd ask.
 

Gaming796

Gaming since 4
OP
Member
Joined
Aug 24, 2016
Messages
561
Trophies
0
Location
Your head
Website
gbatemp.net
XP
439
Country
United States
Yes you need the update preinstalled as HANS can"t use installed updates, you need to buy another newer copy of Mario Kart 7 or try if using the RomFS from the newer version can make it work.
I tried using the ROMFS extracted from the Ver. 1.1 CIA of MK7. It still shows an error.

However, the Code from the ExeFS of the MK7 Ver. 1.1 Update File (not the game itself) can make it work.
 
Last edited by Gaming796,

PabloMK7

Red Yoshi! ^ω^
Developer
Joined
Feb 21, 2014
Messages
2,544
Trophies
1
Age
23
Location
Yoshi's Island
XP
4,154
Country
Spain
However, the Code from the ExeFS of the MK7 Ver. 1.1 Update File (not the game itself) can make it work.
That actually works, I'm working on a way to implement it so it's automatic for newbies.
For now:
1. Find a decrypted prepatched 1.1 cia.
2. Extract its exefs code section.
3. Rename it to ctgp-7.code and place it inside hans folder.
4. Launch CTGP-7 but holding L.
5. Enable code from SD option and save config.
6. Enjoy.
 

Gaming796

Gaming since 4
OP
Member
Joined
Aug 24, 2016
Messages
561
Trophies
0
Location
Your head
Website
gbatemp.net
XP
439
Country
United States
That actually works, I'm working on a way to implement it so it's automatic for newbies.
For now:
1. Find a decrypted prepatched 1.1 cia.
2. Extract its exefs code section.
3. Rename it to ctgp-7.code and place it inside hans folder.
4. Launch CTGP-7 but holding L.
5. Enable code from SD option and save config.
6. Enjoy.
Yes... So.... I FAILED!!!

1. I got a Pre-patched Ver. 1.1 MK7 CIA
2. Extracted the ExeFS and its contents using ctrtool
3. Renamed the code.bin
4. Changed HANS Config and saved config
5. Said OK, but it froze

What to DO???!!!!

Please help!

--------------------- MERGED ---------------------------

That actually works, I'm working on a way to implement it so it's automatic for newbies.
For now:
1. Find a decrypted prepatched 1.1 cia.
2. Extract its exefs code section.
3. Rename it to ctgp-7.code and place it inside hans folder.
4. Launch CTGP-7 but holding L.
5. Enable code from SD option and save config.
6. Enjoy.
Plus, did you try that out anytime (using Ver. 1.1 MK7 CIA Code)?
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    M4x1mumReZ @ M4x1mumReZ: 200 degrees fahrenheit. It's burning at the speed of light. +2