Cover Flow USB ISO Loader by Beardface

Discussion in 'Wii - Backup Loaders' started by Nullkill, Apr 29, 2009.

Thread Status:
Not open for further replies.
  1. JumpingDuck

    JumpingDuck Newbie

    Newcomer
    1
    Jul 19, 2009
    Gambia, The
    This loader is great, it looks so fine!

    but... for me only 1.2 works!
    Any version after 1.2 freezes at startup [​IMG]

    My wii:
    FW 4.1E (Waninkoko update)
    cIOS38 rev14 (249 install)
    BootMii beta2 (boot2 install)
    Preloader 0.29 + Hacks
    HBC 1.0.3

    Greetz JD
     
  2. skx7

    skx7 GBAtemp Regular

    Member
    2
    Apr 25, 2009
    why is there a edit button shown when selecting the 'infinite hearts' cheat for donkey kong jungle beat (ntsc-u)? the cheat works 100% and no editing is involved.

    just curious why [​IMG]
     
  3. fishears

    fishears fishears

    Member
    2
    Sep 28, 2008
    It's because some cheats use "B" as a variable for editable values, I've never found an instance where a single "B" is used so I check for "BB" as a possible editable value.

    Hope this makes sense. I thought it best to have the occasional false-positive (rare) rather than risk missing some genuine editable values....
     
  4. ridgecity

    ridgecity GBAtemp Advanced Fan

    Member
    3
    Nov 6, 2002
    Mexico
    is Guitar Hero 5 working? what about Metroid Prime Trilogy?
     
  5. Fiesty Panda

    Fiesty Panda Banned

    Banned
    1
    Oct 13, 2008
    United States
    Grrr. Starting today, I haven't been able to launch this app. It hangs on Initializing Disc, on every version now. I haven't changed anything, it just started doing this. I've tried changing cIOS between 13a, 12, and 11. To no avail, as well as trying version 1.0, 1.1 and 1.2a.
     
  6. pepxl

    pepxl GFX W!Z4RD

    Member
    3
    Jun 19, 2009
    there was no 11, try deleting CF config files and try using the original setup agian
     
  7. skx7

    skx7 GBAtemp Regular

    Member
    2
    Apr 25, 2009
    yes it made sense [​IMG]

    also, starting coverfloader and quitting (without having started a game) results in a code dump. this bug is reproducable. i have the latest release which was posted on previous page.
     
  8. Fiesty Panda

    Fiesty Panda Banned

    Banned
    1
    Oct 13, 2008
    United States
    Thanks for the advice, I let it sit for a while, and eventually, after 15 minutes or so, one time it booted fine. This leads me to believe its a hard drive problem /:(. No matter though, I'll start my usb-loader folder fresh again, and worst case scenario, turn my 80gb Classic into my Wii's hard drive.

    I do have an internet connection, but where I'm at, its a 56kb/s dialup connection. Its enough to install cIOS updates over network and CoverFloader has worked in the past with this connection. Any other tips? I'm not in much of a hurry, I probably won't play anything else until I can get back home and download MP Trilogy.
     
  9. rutny

    rutny GBAtemp Regular

    Member
    1
    May 23, 2009
    United States

    That is actually untrue. I just gave my brother his wii back after fixing it up, deleted my connection before he came over, and it worked almost flawlessly when I was showing him how to work everything.
    At least on 1.1 its good. Not sure about the higher revs.
     
  10. rutny

    rutny GBAtemp Regular

    Member
    1
    May 23, 2009
    United States

    I assume you are on NTSC-U. Grab cIOS rev 14, and Coverfloader 1.1 (This combo works just fine with my unit)

    When it hangs (this works almost everytime for me)..unplug the power from the hard drive. Sometimes CF will then throw the "HDD not detected" error. If it does, turn on the HDD and press OK, OK , I usually have go repeat the 2 popups then it gets recognized. If you dont get that error, then do a hard power off on the wii (The light should turn red). Turn the Wii back on, give juice back to the HDD, and hopefully you will be good.
    G'luck
     
  11. fishears

    fishears fishears

    Member
    2
    Sep 28, 2008
    UPDATE
    WiiTDB has changed the format of titles.txt to use the more reliable 6-digit game ID (rather than 4).
    Here are the updated dols for 1.2 and 1.2a:

    1.2 (Stable r940)
    1.2a (Unstable r941)
     
  12. fishears

    fishears fishears

    Member
    2
    Sep 28, 2008
    I'm not having this problem although there are various reports of instability around. We are looking into all of them but it's hard for me to debug when it runs flawlessly on my setup [​IMG]
     
  13. skx7

    skx7 GBAtemp Regular

    Member
    2
    Apr 25, 2009

    really? i have 2 wiis overhere. both are crashing when i open coverfloader without a working network connection. my setup is as follows:

    > fw 4.1E
    > cios38rev14
    > coverfloader 1.2a

    could the problem be caused by cios38 rev14 ??

    im not joking this time. each time i launch coverfloader without connection it is crashing after 5 seconds. other people are facing the same http://code.google.com/p/wiicoverflow/issues/detail?id=379
     
  14. fishears

    fishears fishears

    Member
    2
    Sep 28, 2008
    I've sent you a PM
     
  15. GexX2

    GexX2 Lurker

    Member
    3
    Oct 23, 2006
    United States
    Tennesee, US
    I also have this issue, I have a weak internet connection in my room, and it's hit or miss whether or not it will crash or not. Sometimes it stays open long enough to highlight a game, other times it crashes or just freezes with no code dump right after loading all the way. I have a 3.2u wii with CIOS38rev14 also using coverflow 1.2a. I used 1.2 briefly and I don't think I ever had crash issues.
     
  16. RolloS60

    RolloS60 Advanced Member

    Newcomer
    1
    Apr 13, 2006
    Gambia, The
    @all with v1.2a and "freeze"-issues...

    Please try CF_12a_r943 and report...

    LoudBob11
     
  17. skx7

    skx7 GBAtemp Regular

    Member
    2
    Apr 25, 2009
    great job! no more freezing without internet connection [​IMG]
     
  18. GexX2

    GexX2 Lurker

    Member
    3
    Oct 23, 2006
    United States
    Tennesee, US
    Tested, and so far no crashes. Thanks alot.
     
  19. antiaverage

    antiaverage GBAtemp Fan

    Member
    2
    Apr 1, 2008
    United States
    Just compiled CoverFloader for the first time and wanted to pass along a few tips for those having compile errors/issues.

    If you are using the latest libogc, you may be getting 'Vector' undeclared errors. To fix this, open:
    include/GRRLIB.h
    source/GRRLIB.c
    Find and replace all instances of the word Vector with guVector and you should be fine. (4 instances in GRRLIB.h and 18 instances in GRRLIB.c last I checked)

    If you are getting the above error due to using the latest libogc, then you are most likely also getting an error stating conflicting types for 'settime' in disc.c so open:
    source/core/disc.c
    Find the this line (line 163 last I checked):
    Code:
    ÂÂÂÂextern void settime(long long);
    Replace that line with:
    Code:
    ÂÂÂÂextern void settime(u64);
    The error should be cleared up now.

    If you are getting an error with version.h, open up Makefile and find this line:
    Code:
    ÂÂÂÂ@echo -n "#define SVN_VERSION " >> include/version.h
    Replace that line with:
    Code:
    ÂÂÂÂ@echo "#define SVN_VERSION \c" >> include/version.h
    The -n flag passed to the echo statement writes out the line without a trailing newline. This can also be achieved without the -n flag if you append a \c at the end of the string. Read the echo man page for more info.

    If you're having any other compile issues, you're welcome to post here and then PM me to notify me of your post. I'm lazy and might not notice if you don't PM me.
     
  20. fishears

    fishears fishears

    Member
    2
    Sep 28, 2008
    You mean "unstable", "SVN" or "unreleased", not "latest" [​IMG] but nice guide - it should help a lot of people who've installed a libogc from other projects.
     
Loading...
Thread Status:
Not open for further replies.