Chrono Trigger DS (USA) Piracy Fix!

Discussion in 'NDS - ROM Hacking and Translations' started by Narin, Nov 26, 2008.

  1. coren

    coren Newbie

    Dec 24, 2008
    United States
    I did this exactly as you said, and now No$GBA says it's not a gba/nds file and crashes at startup. Before, I could play to the first time warp, where it would hang. Meanwhile, if I used the cheats, I'd get an error every time I switched screens at the fair. Any suggestions?
  2. coren

    coren Newbie

    Dec 24, 2008
    United States
    Nevermind, I found a prepatched version of it somewhere on the magical internet. That's what I recommend to anyone who still can't get it running. And no, I won't tell you where, that's bad.
  3. Mimoy

    Mimoy Advanced Member

    Dec 31, 2008
    Ontario, Canada
    Thanks to 1ns0mn14 I patched Chrono Trigger and thanks to narin for the cheat code.
    What I want to ask though is, is it possible to add or make cheats for the patched version of Chrono Trigger, because I recently downloaded the new cheat database and later I found out that the patch made the .rom file had a new Game ID.
  4. DarthNemesis

    DarthNemesis GBAtemp Maniac

    Feb 19, 2008
    United States
    Just use r4cce to find the new Game ID (Add Game), then edit your cheat.dat accordingly.
  5. Raybrand

    Raybrand Advanced Member

    Jan 5, 2009
    United States
    I'm a bit confused

    I've got NO_GBA and the Chrono Triger rom (U) nothing else ds related (I got the r4cce)

    What do I do from there? I did this tutorial -;#entry1278822

    but that didn't do anything I just got another file laying around.
    What do I do from there? What more do I have to download?
  6. juntok_abot

    juntok_abot GBAtemp Regular

    May 22, 2008
    thanks coi..for the patch..
    i hope this one works with ysmenu
  7. Zane

    Zane Ace Wizard

    Mar 22, 2008
    Sweden, Falkenberg
    I'm having problems.

    I'm using r4 with Yasu. And when i start the game, i just get a white screen. The thing worked fine with Kernel 1.18

    I was using a patched game, so i got a clean (U) Rom, and applied the Piracy Fix on it. Still white screen, anyone know how to fix this using Yasu, or is the game unplayable on that?

    Also after i applied the cheat code using DSATM the rom got down to 85mb, is that supposed to happen, or did something go wrong, and that's why i got a white screen despite the cheat beeing there?

    I've already formated my card twice, so that's not the problem.
  8. Skyline969

    Skyline969 MENUdo Afficionado

    Nov 18, 2008
    I apologize if it's been said before, but all is well on the M3 Real running Sakura 1.12+1 and the M3 Real version of the anti-piracy fix. The door opened after I played the organ in the cathedral, and so far I haven't been stuck in any time warps.

    EDIT: Currently I am in prehistoric times, just got the pterodactyls.
  9. nyusuu

    nyusuu Newbie

    Jan 13, 2009
    United States
    I patched the game, but I think it's still getting hung up in certain areas.

    I'm in Site 32 right now, and I can't get past the first map (robots keep flooding in no matter what I do). Is that an anti-piracy glitch or just my own stupidity?
  10. Mishy

    Mishy Member

    Dec 16, 2008
    United States
    Some where in NJ.
    Sounds like you need to back track...Also, check out a website that has guides.

    Warning: Spoilers inside!
  11. Shin Akuma

    Shin Akuma GBAtemp Regular

    Sep 29, 2006
    Hello im really new here [​IMG]I have you know...the crappiest of the cards in my hands....DSX,,,:/ is there anychance to make it playable? Ive tried the patcher but it need the New amr7 fix to acces save file...i did it after the patching for the warp freezes.Still i cant bypass the warps :/ is there any chance?

    thanks all in advance.I have the latest firmware btw

    3 hours passed and....
    Oh sure there is no fix...ive tried 20 [​IMG] combinations from patches and amr7 fixes but no fun at all....
    i think i must give Chrono Trigger for dsx users then
  12. ZoDoS

    ZoDoS Newbie

    Jan 27, 2009
    United States
    ok so that fix actually worked for me but now im having problem...
    when i go to 65000000BC i cant get Alya...there are no one attakes me no FMV nothing...just drop from the gate and go down the stream go to the village yet no Alya,,,,i wana know if the problem is from the fix or somthing else....i use no$gba
  13. ZenSpi

    ZenSpi Newbie

    Feb 6, 2009
    United States
    Ive tried ALOT of patches and they dont seem to work on my DS firecard. i get two white screens.
    please help!
  14. Luxiel

    Luxiel Newbie

    Feb 18, 2009

    I only registred an acc here to thanks a LOT to all ppl here!!

    I finally got some good computer and I was eager to play nds emulated since I live in Brazil and NDS + a R4 are to expnsive =/

    So I needed to play CT again in this version and all went right until I got caught by the time warp loop!!

    Finally the cheat code on the first page solved it!!!


    cya ^^
  15. HoRRoR_X

    HoRRoR_X Newbie

    Mar 1, 2009
    Serbia, Republic of
    Arm9 fix, without cheats. Just replace arm9 code.
  16. Takomah

    Takomah Newbie

    Mar 4, 2009
    United States
  17. Nighteye

    Nighteye Newbie

    Mar 25, 2009
    I'm a DSTT user with the latest firmware. I'd like to confirm that patch from works.

    Here's what i did

    download XENOPHOPHIA version of Chrono Trigger
    download patch at

    Extract patch and rom

    Rename patch folder to "ct"
    put rom in folder ct and rename it to "chrono"
    folder ct should contain the following files:
    - chrono.trigger.(u)-patch_cracker.exe
    - instructions.txt
    - chrono.nds

    open/double click chrono.trigger.(u)-patch_cracker.exe
    click patch and wait
    when the window closes you should have chrono-patched.nds and xdelta.exe in your folder
    copy chrono-patched.nds to your DSTT micro sd card and you are good to play!

    NOTE: you have to use XENOPHOBIA's dump or it will not work!

    I am a newbie, I thought I'd share my experience since it was really frustrating for me to find the fix for this game. Please let me know if broke any rules. thank you!
  18. sherene2205

    sherene2205 Newbie

    Apr 2, 2009
    hi im really noob at this whole cheat code thing so some help pls.

    i downloaded and transferred the usrcheat.dat into my dstt. i can see the cheat option. i ticked backup activator/game fix code, loaded the game, and im still stuck in the warp zone.

    is there something im supposed to be doing but isnt?

    EDIT: nevermind i managed to get it to work. thanks for the file Narin! [​IMG]
  19. Raeven

    Raeven Newbie

    Apr 3, 2009
    [​IMG] When I use the Anti-Piracy fix for Chrono Trigger it loads but it stays on the white screen oh I'm using an R4 and its the (E) version I downloaded it from *snip [​IMG]
  20. IdleActivist

    IdleActivist Newbie

    Mar 26, 2008

    I have the exact same problem

    Chrono Trigger always stays on the white screen whether its the USA version, the usa fixed version, the euro version, and if I trimmed it or not.

    I always make sure the USRCHEAT.DAT/ CHEAT.DAT has the game ID

    Any help would seriously be appreciated, and I have been searching this thread and quite a few others