Certain R4 Card Not Working on DSi - Other is

hsr

Member
OP
Newcomer
Joined
Dec 10, 2015
Messages
7
Trophies
0
Age
59
XP
84
Country
United States
Hi. I’m new to this (and old), so take it easy on me please.

Yesterday, I CFW my dsi XL that is on 1.4.5U. It is successfully running twilight ++ and unlaunch installed.
Post automatically merged:

I have multiple r4i upgrade carts. (3) of them are v1.4.3 r4i carts and (2) of them v1.4.5 r4i carts. We have (3) unmodded dsi (two are on 1.4.3u and one on 1.4.5u) and (2) dsiXL that are both on 1.4.5u. One now with CFW. We’ve had these since my kids were <9 years old, now late teens/early 20’s and I wanted to get them back up running for Christmas.
Post automatically merged:

The dsi’s that do not have CFW and are on 1.4.3u will run any of the (5) r4i carts. The one that does not have CFW and is on 1.4.5u will only run the 1.4.5 r4i carts. I get the "An error has occurred trying to use v1.4.3 cart on 1.4.5u with no CFW, so I know the issue is not contact or dirty pins. All the carts have been tried with the latest 2018 1.8.9 kernel from original site THEN with correct YSMENU for the specific carts (meaning I’ve tried both kernels). 4GB micro SD properly formatted per the guide with 5.0 and settings verified, checked with h2testw 1.4.
Post automatically merged:

On the CFW XL, I was able to boot both a retail game and the v1.4.5 cart (which confirms the microSD noted above is good) from the DS menu Slot 1 in Twilight. However, the v1.4.3 cart only displays four colored blocks on the lower screen.

I thought the CFW would allow use of an older cart based on the comments I read in another thread with almost the same title as this one?
Post automatically merged:

My base system is on 1.4.5u. I was using the same mircoSD in both the v1.4.3 and v1.4.5 r4i carts which has the proper YSMENU on it. My end goal was to utilize the older v1.4.3 cart if possible, which is what led me to CFW my own dsiXL.

Does anyone notice my possible error(s)?

Thank you in advance.
 
Last edited by hsr,

Sypherone

Gaming Ninja
Member
GBAtemp Patron
Joined
Apr 28, 2019
Messages
1,660
Trophies
2
Age
44
XP
2,895
Country
Germany
Best post a picture of one them if they are all the same. On first attempt i will think its this R4i-sdhc.com upgrade flashcard. On this site you also can get the latest kernel. If iam wrong @M4x1mumReZ for sure will help to find the right kernel, too.
 

hsr

Member
OP
Newcomer
Joined
Dec 10, 2015
Messages
7
Trophies
0
Age
59
XP
84
Country
United States
Pics of the carts and the error message using 1.4.3 in stock DSi on 1.4.5
Post automatically merged:

Best post a picture of one them if they are all the same. On first attempt i will think its this R4i-sdhc.com upgrade flashcard. On this site you also can get the latest kernel. If iam wrong @M4x1mumReZ for sure will help to find the right kernel, too.
Thank you. Yes - that is the site I downloaded the latest kernel 1.8.9 and it's from 2018. That doesn't work, nor does YSmenu for the same specific cart

I've read elsewhere on the net that because the v1.4.3 cart is below the 1.4.5u the base system is on, the card is useless. But reading post #2 HERE made me think otherwise
 

Attachments

  • image0.jpeg
    image0.jpeg
    328.7 KB · Views: 74
  • image1.jpeg
    image1.jpeg
    358.2 KB · Views: 61
  • image2.jpeg
    image2.jpeg
    403.1 KB · Views: 74
Last edited by hsr,

Sypherone

Gaming Ninja
Member
GBAtemp Patron
Joined
Apr 28, 2019
Messages
1,660
Trophies
2
Age
44
XP
2,895
Country
Germany
  • On DSi firmwares higher then 1.4 exist a blocklist which doesnt allow to run a lot of such flashcards. The higher the firm, the more is blocked.
  • Therefore it needs a CFW like unlaunch and disables this checks.
  • It need always the latest kernel on the flashcard to be compatible with higher DSi firmware. You can try to get the card run in this row :
    1. The original R4i-sdhc.com kernel
    2. The v1.4/1.4.5 kernel (+fix for clones) in our download section.
    3. The latest YS-Menu (flashcard-archive)
    4. Or TWLmenu++ for flashcard (if supported)
  • In case still dont run, the workaround running them through TWLmenu++ is neccesary.
  • Or installing HiyaCFW addionally to CFW unlaunch which replaces the Sysmenu with TWLmenu++.
 
Last edited by Sypherone,

hsr

Member
OP
Newcomer
Joined
Dec 10, 2015
Messages
7
Trophies
0
Age
59
XP
84
Country
United States
On DSi firmwares higher then 1.4 exist a blocklist which doesnt allow to run such flashcards. Therefore it needs a CFW like unlaunch. In case still dont run, the workaround running them through TWLmenu++ is neccesary, or installing HiyaCFW addionally to CFW unlaunch which replaces the Sysmenu with TWLmenu++.

As info, instead running the original kernel/OS or YS-Menu on the flashcard can TWLmenu++ for flashcard run on them (if supported).
Thank you. I have tried through the unlaunch menu and the twilight menu. Neither work. I will have to investigate the hiyaCFW. Have heard of it but never tried.
Post automatically merged:

Sypherone,

I appreciate your help. I am down to the point of installing hiyaCFW. Nothing else has worked on the r4i v1.4.3 carts. I am thinking I will just buy newer carts to replace the (3) r4i carts that are the v1.4.3

Do you have a recommendation for a trouble free cart to use on a NON modded DSi please?

Thanks again.
 
Last edited by hsr,
  • Like
Reactions: SylverReZ

Sypherone

Gaming Ninja
Member
GBAtemp Patron
Joined
Apr 28, 2019
Messages
1,660
Trophies
2
Age
44
XP
2,895
Country
Germany
I get the "An error has occurred trying to use v1.4.3 cart on 1.4.5u with no CFW, I am down to the point of installing hiyaCFW. Nothing else has worked on the r4i v1.4.3 carts
Basicly you need the latest kernel (Operating System) on the cards that they work with higher firmware of the DSi. But the official may outdated because of ended support. And some require a updated firmware on the flashcard. As r4i-sdhc.com offers this maybe check if latest is installed.

As solution for kernels there are this possibiltys in this row (links are in post above) :
  1. Original Kernel
  2. Kernel of a same clonecard that still got support, as same flashcards got sell under different manufacturer names. (Didnt know for this card)
  3. Inofficial fixed Kernel
  4. modified Kernel
  5. TWLmenu for flashcards.
  6. In case the card is blocked a CFW on 2/3/DS system is required. On DS its unlaunch + Hiya CFW.
Just as info. TWLmenu offers the same possibilitys/features like a flashcards kernel does and can directly run on the system. But requires CFW and can set to autostart by unlaunch. Also be installed as standard by HiyaCFW as already mentioned.
 
Last edited by Sypherone,

hsr

Member
OP
Newcomer
Joined
Dec 10, 2015
Messages
7
Trophies
0
Age
59
XP
84
Country
United States
Thank you
Post automatically merged:

Basicly you need the latest kernel (Operating System) on the cards that they work with higher firmware of the DSi. But the official may outdated because of ended support. And some require a updated firmware on the flashcard. As r4i-sdhc.com offers this maybe check if latest is installed.

As solution for kernels there are this possibiltys in this row : (links are in post above)
  1. Original Kernel
  2. Kernel of a same clonecard that still got support, as same flashcards got sell under different manufacturer names. (Didnt know for this card)
  3. Inofficial fixed Kernel
  4. modified Kernel
  5. TWLmenu for flashcards.
  6. In case the card is blocked a CFW on 2/3/DS system is required. On DS its unlaunch + Hiya CFW.
Just as info. TWLmenu offers the same possibilitys/features like a flashcards kernel does and can directly run on the system. But requires CFW and can set to autostart by unlaunch. Also be installed as standard by HiyaCFW as already mentioned.

@M4x1mumReZ Whats about the DSONE Clone? I got one myself, but cant tell if CFW is needed on DSi or not. Or does some else may know?
Sypherone,

My point was I tried all of what you suggested and the lower firmware carts are just not working for me.

I really do appreciate all of your help.

PSP’s were so much easier to CFW lol
 
Last edited by hsr,

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    SylverReZ @ SylverReZ: Lol