Broken touchscreen but.....not really???

Discussion in 'Switch - Console, Accessories & Hardware' started by unvaluablespace, May 18, 2019.

  1. unvaluablespace
    OP

    unvaluablespace GBAtemp Regular

    Member
    6
    Aug 3, 2014
    United States
    Short version: touchscreen wasn't working even after replacement, but when booting into lakka, touchscreen works 100% fine.

    Long version: I bought a used, child owned switch for cheap to use for hacking. Since it was child owned, the screen was covered in scratches. I didn't mind cuz I wanted to mod the shells and was planning on taking the thing apart anyway so I bought a new touch panel. After swapping the touchscreen, I still had touchscreen issues. I wanted to update my switch using choidujournx, and realized the app uses the touch screen instead of controls. Since I had a nonhacked switch, I decided to swap the gamecard slot board between the two to see if that was where the issue was, and interestingly enough, the touchscreen worked. So I upgraded and replaced the swapped boards back in their respective units (I wasn't sure if swapping was a good idea so I put them back) and the touch panel stopped working again. I assumed the problem was just the board and planned on buying a new gamecard slot when I get the chance.

    However, here's the interesting part, since I haven't ordered the part yet, I recently tried lakka on my switch, which as I understand, runs off of Linux. To my amazement, the touchscreen works perfectly fine. Soon as I go back into the switch OS though, hacked or non-hacked, the touch panel stops again. Soon as I go back to lakka, once again the touch panel works fine.

    Any ideas? I have no idea why this happens. I'm still planning to order a new gamecard slot board, as I assume it's a hardware issue. It's just very weird that the touch panel doesn't work unless it's running under lakka. By the way, the gamecard slot and headphone jack (which are all on the same board that the touch panel connects too) seems to work fine.
     
  2. GalSilver

    GalSilver Newbie

    Newcomer
    1
    Aug 20, 2019
    United States
    Hey, I refurbish Switches and see this happen all the time. some game card readers are from after-hours makers and just won't support the after-hours touchscreens (digitizers) since Hekate and Linux doesn't use some of the original OS (no clue what) the touch screen would just work. in your case, the digitizer you have is an after-hours one and matched with the same type of game card. this would just not work together. buying a new game card reader is more of roulette than you would imagine. the original screen must've been an actual original which is why it worked in the first place. I hope all this information helps even though is a little late. if you do manage to find a way around that, please post something here, I would love to know what you did.
     
    unvaluablespace likes this.
  3. White_Raven_X
    This message by White_Raven_X has been removed from public view by linuxares, Nov 20, 2019, Reason: Don't bump threads.
    Nov 19, 2019
Quick Reply
Draft saved Draft deleted
Loading...