Hacking Bought used 3.60 Vita, added HENkaku - retail game carts ok?

esmith13

Well-Known Member
OP
Member
Joined
Aug 19, 2006
Messages
581
Trophies
1
Age
48
Location
South Jersey
XP
2,034
Country
United States
So I recently bought a used vita running 3.60 (freshly reset/restored, no PSN account registered/activated). I put a clean formatted 8GB card in in and installed HENkaku and all the fun stuff available to date for it, including vita-activator. I believe it's activated to my (crap) PSN account - not that I know how to be sure.

My question is, Can I pick up a few retail Vita cart games and play them fine? I'm interested in titles like God of War and Tearaway for example. (I know it has to be a game requiring FW 3.60 or older)

I'm not so much worried about online play (is that possible??), mainly just offline single player experiences...

Thanks in advance for any info.
 

Deleted member 370671

Ball of Kawaiiness
Member
Joined
Aug 23, 2015
Messages
1,435
Trophies
1
Location
Lowee
XP
1,601
Country
Korea, North
Yes, you can use retail games without any problem (for now, in the future newer games may require you to update your console).
As for online multiplayer, it uses PSN, so it won't be possible without updating.
 

VitaType

Well-Known Member
Member
Joined
Jul 16, 2016
Messages
1,043
Trophies
0
XP
1,457
Country
Germany
@TheKawaiiDesu, answer is completly correct. I just want to add that you can even update the games (just for the case that you wouldn't buy games like Minecraft (the US version hasn't a card, you have to import the EU version) or Borderlands II due to the idea that you can't update the games. You can.)
 

esmith13

Well-Known Member
OP
Member
Joined
Aug 19, 2006
Messages
581
Trophies
1
Age
48
Location
South Jersey
XP
2,034
Country
United States
Thanks to you both.

Just to clarify, you're saying I CAN update a retail cart game using the download update button from the game's live area and it will still work?

If so, I'm surprised Sony hasn't just released an update for every game (their's at least) that tells the Vita it needs to be updated to 3.61 to continue play (even though it would be total BS just to screw with HENkaku and other older FW users)...
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • ZeroT21 @ ZeroT21:
    still busy hackin' ps4?
  • K3Nv2 @ K3Nv2:
    If the damn script would work it'd be nice
  • ZeroT21 @ ZeroT21:
    maybe it's the incompatible model
  • K3Nv2 @ K3Nv2:
    No it's because I have a arch64 model tv it's just normal ps4 bs
  • ZeroT21 @ ZeroT21:
    yeah, the JB does not activate instantly, because it relies on a flaw showing up in a process
  • ZeroT21 @ ZeroT21:
    I'm on a older 6.72, still kinda tempted to upgrade, maybe a 9.00
  • ZeroT21 @ ZeroT21:
    i probably cant go higher than 9.00 becus i have the CUH-22XX model
  • K3Nv2 @ K3Nv2:
    I keep getting stuck on waiting for padi
  • ZeroT21 @ ZeroT21:
    hmmm, i got no clue, i need to re-check their step by step guide
  • K3Nv2 @ K3Nv2:
    11.0 hack is great if you got a webos tv
  • ZeroT21 @ ZeroT21:
    i dont have LG tvs around
  • ZeroT21 @ ZeroT21:
    all TCL
  • ZeroT21 @ ZeroT21:
    and a sony
  • K3Nv2 @ K3Nv2:
    You can map a button on your remote to launch the script call it a day
  • K3Nv2 @ K3Nv2:
    I'd stay on 9.0
  • K3Nv2 @ K3Nv2:
    I had a spare ps4 on 10.0 so decided to try it
  • ZeroT21 @ ZeroT21:
    i just want to play the psp resistance port
  • K3Nv2 @ K3Nv2:
    Psps are high tech
  • ZeroT21 @ ZeroT21:
    there is no backported version for me fw
  • K3Nv2 @ K3Nv2:
    Don't own the hardware?
  • ZeroT21 @ ZeroT21:
    both 2 psp busted
  • K3Nv2 @ K3Nv2:
    Hunt down a vita?
  • ZeroT21 @ ZeroT21:
    Tried, but the conditions i saw most of 'em left me reelin'
    ZeroT21 @ ZeroT21: Tried, but the conditions i saw most of 'em left me reelin'