2 problems: fonts and changing skins not working

Discussion in 'R4 DS' started by joe_user, Oct 11, 2007.

Oct 11, 2007
  1. joe_user
    OP

    Newcomer joe_user Member

    Joined:
    Sep 1, 2007
    Messages:
    21
    Country:
    Germany
    Hi there

    I have to problems with my R4 and can not find a solution to it:
    1st: Chaning fonts with select does not work. Actually I think, no theme is really used. Themes are stored in /_system_/themes/themeXX
    2nd: If I try to open a *.txt file and error message popups: "Can't find FONTs of eBook. Please re-install these FONTs".

    Using v1.11.
    My OS is linux; Ubuntu 7.04

    Any help is very much appreciated! Thank you.
     
  2. KarmaUK

    Member KarmaUK GBAtemp Regular

    Joined:
    Aug 29, 2007
    Messages:
    136
    Country:
    United Kingdom
    I dont think you can change the font, how are you trying to change it?
     
  3. Infinitus

    Member Infinitus GBAtemp Regular

    Joined:
    Mar 20, 2007
    Messages:
    217
    Country:
    United States
    And I have at least one solution..

    For the .txt file, make it Times New Roman or something equvilant in Unix's text editor.
    That, or in the /_system_/ebook/ folder, make sure FONTL.dat, FONTM.dat, and FONTS.dat are all there.

    Second, pressing select doesn't change fonts, but holding select changes themes overall (images)
     
  4. joe_user
    OP

    Newcomer joe_user Member

    Joined:
    Sep 1, 2007
    Messages:
    21
    Country:
    Germany
    Thanks for the fast reply's!

    KarmaUK: I have not tried to change the fonts, as I could not figure out how. That's my problem ;-)

    Infinitus: I know, holding select should change themes, but this does not work. I do not know if the 2 problems fit toghether. But holding/pressing select in the mainmenu does not do anything at all....

    PS. sorry, if these are lame questions. Got the R4 new, trying to learn.
     
  5. Infinitus

    Member Infinitus GBAtemp Regular

    Joined:
    Mar 20, 2007
    Messages:
    217
    Country:
    United States
    I recommend re-downloading (or simply downloading, if you haven't already) version 1.11 of the firmware, and possibly reformatting the card. Starting from a clean slate usually solves things.
     
  6. Rayder

    Former Staff Rayder Mostly lurking lately....

    Joined:
    Jan 14, 2007
    Messages:
    6,613
    Location:
    USA
    Country:
    United States
    Also, when you re-update, completely delete the file called _DS_MENU.SYS. This is important. It will be automatically re-created the first time you boot the R4 with the new firmware. Not deleting that file when you update the firmware can cause strange things to happen. Possibly like the things you are describing.

    Hope that helps.
     
  7. KarmaUK

    Member KarmaUK GBAtemp Regular

    Joined:
    Aug 29, 2007
    Messages:
    136
    Country:
    United Kingdom
    Ah, I see, sorry. [​IMG] Then I dont think you can.

    The problem with opening the .txt might be it's saved in an unusual font, but don't quote me on that. As mentioned, a format is always good to iron out any unusual behaviour.

    Good luck.
     
  8. DarkAura

    Member DarkAura Offline

    Joined:
    Aug 20, 2007
    Messages:
    2,388
    Location:
    Over there.
    Country:
    Canada
    If you have tried to put some themes on your R4, you should have a themes folder in your _system_ file. There should be 12 folders in there named Theme 1, Theme 2 and so on. Do NOT rename these folders. Just copy the theme images from your computer into the folders. And there is a maximum of 12 themes. If you add anymore, it may not read it. And the theme should include a background 1 and 2, logo and icon images, as well as a theme.ini.

    I think that should cover the theme settings.
     
  9. joe_user
    OP

    Newcomer joe_user Member

    Joined:
    Sep 1, 2007
    Messages:
    21
    Country:
    Germany
    I reformated the card and installed everything new; but this time with a Windows box. This solved the problem. Looks like the R4 or linux got confused with upper and lower cases.

    Hmmm, might be worth installing XP on an old box. Thanks god I got my company notebook here ;-)

    Thanks for your help, guys!!

    Edit. Damn, my Zelda savestate is corrupt. Any chance to fix it? Or just replay? hmmm
     
  10. Kuro_Shinigami

    Newcomer Kuro_Shinigami Member

    Joined:
    Oct 5, 2007
    Messages:
    14
    Country:
    United States
    I don't think you can save fonts in .txt files
     
  11. matriculated

    Member matriculated GBAtemp Advanced Fan

    Joined:
    Sep 27, 2007
    Messages:
    598
    Country:
    Canada
    When copying the files from the CD, Ubuntu makes the filenames all in lowercase - they needed to be renamed all in uppercase. Windows copies the files all in uppercase and that's why it worked.
     

Share This Page