Why did my GBA mode stop working?

Discussion in 'NDS - Flashcarts and Accessories' started by GameGeek, Oct 17, 2015.

  1. GameGeek
    OP

    GameGeek GBAtemp Regular

    Member
    166
    10
    Mar 14, 2009
    Argentina
    Some years back, I used to use a Slot 2 card, "GBA & EXPLOADER 2 IN 1 FOR NDSL - TTDS", along with GBAldr to load GBA ROMs in my DS Lite. Later, I switched to EzFlash V and Rudolph's GBA ExpLoader. It worked well for the most part (at some points corrupted saves or whatever caused it to hang at the GBA boot screen, but I got that sorted out). However, I recently picked my DS Lite again and whenever I run GBA ExpLoader, I get the following message:

    "Slot2 expansion pack not found
    Please redo from start.
    (A) : Confirm"

    I press A and get then get:

    "May I set this Slot2 expansion pack for GBA ExpLoader?
    (A) : Run, (B) : Cancel"

    Pressing A or B makes it show the GBA ROM list. Then running one makes it go to the GBA boot screen and freeze after showing "GAME BOY".

    I decided to try switching back to my previous Slot2 card, but GBA ExpLoader produces the same result with it, and GBAlrd won't even detect it :(

    WTF? Has my DS Lite's GBA mode been bricked or something?

    Edit: I just tried running GBA ExpLoader without any Slot 2 card and the result was the same. So it looks like neither GBA ExpLoader not GBAldr is detecting any Slot2 card...
     
    Last edited by GameGeek, Oct 17, 2015
  2. rctgamer3

    rctgamer3 GBAtemp Fan

    Member
    302
    94
    May 5, 2008
    Netherlands
    Do real GBA game cartridges still work?
     
  3. GameGeek
    OP

    GameGeek GBAtemp Regular

    Member
    166
    10
    Mar 14, 2009
    Argentina
    ...Nevermind, it just started working again :blink:

    I put my EzFlash back and booted my DS without any slot 1 card and it detected the card and ran the game stored in the NOR. I then tried GBA ExpLoader and it detected it and loaded my ROMs correctly.

    I guess the most logical explanation is that it was a contact issue. Though that's still really weird, as I had never removed and reinserted my EzFlash before the problem happened :mellow:
     
    cocoPika likes this.
  4. Coto

    Coto GBAtemp Addict

    Member
    2,343
    396
    Jun 4, 2010
    Chile
    could be cold joint pads on the GBA Slot. Because from what I read , its not related to arm7bios but gba carts not mapped correctly.