[W10 After update] Emulator problems (VBA + Desmume)

Discussion in 'General Gaming Discussion' started by Rick Astley, Mar 12, 2018.

  1. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    Hey !

    So first, it's for my friend, so maybe i'm missing some informations. But he wants to play Pokemon again and he has strange issue with his computer.

    To do simple the two emus (vba-rr + desmume) are just ignoring the game he's trying to open :
    - Doing File => Open => Select game will act as no game were loading (to do simple, it ignores the fact that a game is selected)
    - Making the right emulator opening the right emu is not working either, it opens the emu... Without any game loading.

    In both cases, they are RIGHT configurated (Checked everything since I play a lot on emulators) and worked before without any problem. He has a really good PC so well.

    Important thing : He needs special version of emulators, so using others is not possible. And anyway he tried with No$GBA same issue.

    The only thing that changed is his W10.

    He updated to the 1709 update and got a LOT of issues with his games etc (fps related etc).

    [​IMG]
    (the result of the emulator after loading a game)

    The only thing we can see is to restore his W10, but he can't because of bad internet speed etc.

    Any clue ?

    Thanks o/
     
    Last edited by Rick Astley, Mar 12, 2018
  2. Flame

    Flame Me > You

    Member
    GBAtemp Patron
    Flame is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,239
    5,871
    Jul 15, 2008
    why dont you use https://mgba.io ? the best GBA emu there is at the moment
     
    Sinon likes this.
  3. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    He needs specific version for Lua Scripting, Debugging stuff so as i've said, it's really to fix these emulators that works well in general.
     
  4. migles

    migles GBAtemp Guru

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,412
    5,046
    Sep 19, 2013
    China
    Earth-chan
    give it a try to "windows 7" or xp compatible mode, might fix that issues...
     
  5. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    Just tried, didn't work :/
    Thanks o/
     
    migles likes this.
  6. migles

    migles GBAtemp Guru

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    7,412
    5,046
    Sep 19, 2013
    China
    Earth-chan
    am just throwing ideas... but you pointed out that the same thing happens with no cash gba emulator as well?
    then something really going on with the OS... the files are not corrupted or something right? they might gotten get corrupted...
    does theese emulator use dependencies like net framework? if they do, try reinstall them...
    HO, in compatible options like i said earlier, run them in administrator mode! that might be it?
     
  7. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    Oh yes we know it's related to OS in fact, we even know it's due to the update, so that's why we're looking for OS solutions in order to fix that :/
    The OS seems not to be corrupted, he checked with cmd for that
    Tried in administrator mode too, nothing.
    And these two don't use .net (almost sure)

    But really thanks for throwing ideas, i'm looking for that o/
     
  8. Flame

    Flame Me > You

    Member
    GBAtemp Patron
    Flame is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,239
    5,871
    Jul 15, 2008
    why dont you do windows or linux in a virtual box and run the emu like that.
     
  9. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    I told him that but he's so okay do to that
     
  10. Sakitoshi

    Sakitoshi everything is going according the plan...

    Member
    1,544
    685
    May 8, 2012
    Chile
    behind a keyboard or a gamepad
    it seems a lot like a corrupted rom rather than problems with the emulators itself.
    I downloaded said version of vba and it's working without any issue.
    upload_2018-3-15_16-15-39.png
     
  11. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    13,882
    6,413
    Mar 17, 2010
    Norway
    Alola
    Hm... Bizhawk?
     
  12. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    ROMs are clean, personnal dumps and tried them myself and I use them for years. Settings are correct. Not this sure at 100% :/

    These scripts are not working on Bizhawk
     
  13. Sakitoshi

    Sakitoshi everything is going according the plan...

    Member
    1,544
    685
    May 8, 2012
    Chile
    behind a keyboard or a gamepad
    assuming that video and audio drivers are up to date (or lets say, in a stable revision because of nvidia hit and miss drivers) looks like a clean install is in order then.
    rule of thumb on windows is that if something doesn't work but before did and everything seems to be in order, then something that the windows repair system can't detect broke.

    if your friend can't afford to reinstall right now he can install windows on a spare hard drive or an usb drive to test if that solves the issue, it should work.
     
  14. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Legend

    Member
    11,356
    6,051
    May 27, 2016
    United States
    New York
    Maybe try this one? Delete all of the current one first and try this one. Load the emulator and load the rom. Don't change any settings until you confirm the rom works.

    I have no problems using it, I have been for a year. Also if he is using a system with multiple graphics cards, tell him to try loading it with the onboard integrated one.

    https://github.com/TASVideos/vba-rerecording/releases
     
  15. Rick Astley
    OP

    Rick Astley The real one !

    Member
    376
    101
    Apr 1, 2015
    Yeah almost sure it's a Windows problem... He has issues in others games too (Before they were working in HQ, and now even in normal it lags a lot and stuff like that)
    He's thinking about redoing a clean install of windows

    The emulator is fine. I use the same for more than 8 years, it's clean, i've checked the config and gave the right emulator. And he has issues with Desmume too and other stuff.

    Thanks both for the answer o/
     
Loading...