vWii semi-brick IOS58

Discussion in 'Wii U - Hacking & Backup Loaders' started by Janglez311, Jun 7, 2014.

  1. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
    So here's my headache. I stupidly installed Wii IOS58 on my vWii not knowing it was different. After installation my console rebooted and my homebrew channel
    refused to boot. I tried to reinstall HBC via smash stack and it froze on the first warning screen. I've tried to reinstall the real vWii IOS58 with wad manager, YAWMM, Multi-mod manager. None of them work. Someone please help me!
     


  2. julialy

    julialy Homebrewer

    Member
    1,665
    577
    Nov 26, 2012
    United States
    United States
    We need a easy tool to fix IOS58 problem!
     
  3. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Isn't going to be a tool since any tool would probably require copyrighted code. And technically the problem shouldn't be happening since vWii is patched on the fly.

    When you say none of them work, you mean it refuses to install the WAD?

    Can you try reloading the IOS to 249-251? Same result?
     
  4. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
  5. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Did you install the CIOS d2x into 249-251 before all this happened? YAWMM should have an option to choose IOS. I'll know exactly when I get home from work

    Edit:

    When you first load YAWMM - you should get a message about HW_AHBPROT is disabled - Do you want to load another IOS anyway? Choose YES.

    Then it should ask you what IOS to use, try 249.
     
  6. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
    I don't recall ever installing any cIOS' s on my Wii U. Really the only thing I know I installed was HBC and some wads.
     
  7. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
  8. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    Why does this keep happening? I realize you didn't know it was different, but what led you to think you needed to reinstall IOS58? Is there some guide people keep following?

    The only way to re-install a vIOS is by packing a wad from a NAND backup you made. Hopefully that was the first thing you did after installing the HBC.
     
  9. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
    I'm on 4.1.0 U I believe. It's the one before the newest 5.0 update. How do I do a syscheck?
     
  10. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Well I guess it's irrelevant if you didn't install any CIOS. Not sure if there's a way out unless you can maybe install IOS36 into slot 236 and run from there. Someone else may have some insight. Do you have a NAND dump? Most ways to recover is using other IOS with access to install WADS, however it looks like you may not have any.
     
  11. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
    This is what happened. I was trying to get the GameCube emulator "nintendont" to work. it said I needed a patched ios58 and it didn't work so I thought I needed to reinstall ios58 and thus the problems began. I don't have a backup of my system. However I have vwii ios58.wad but it won't install.
     
  12. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    1. Nintendont isn't a GameCube emulator. I should know, I worked on it.
    2. You need an unpatched vIOS to have it work.
    3. Use this to install the vIOS58 wad, then immediately do a NAND backup.
     
  13. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
    I get Installing Ticket... Error! ( Ret =- 2001) when I try to install the vwii ios58.wad I booted YAWMM_EN through smash stack.
     
  14. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Doesn't that method require a vulnerable IOS? He doesn't have d2x installed.
     
  15. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,970
    3,755
    Apr 2, 2011
    United States
    The Twilight Zone
    Hmm, without HBC access he might be screwed.
     
  16. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
  17. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Exactly. He has no vulnerable IOS, so no way of installing anything. Update probably won't work since 58 is patched and at worst it will fail. Only thing you could hope for I imagine is when a game with a 5.0 update comes on the disc.
     
  18. Janglez311
    OP

    Janglez311 Member

    Newcomer
    31
    4
    Jun 6, 2014
    United States
    Phenix City, Alabama
    I have tried updating my wii u several times I always get a error. What's the difference between a network and disc update? Wouldn't they have the same result?
     
  19. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    They usually do, however, the last time vWii was touched by an update was back on 4.0 I believe. There was some success with people using MarioKart 8 to update to 4.1 and fixing the issue of incorrect IOS. However, with you being on 4.1, the only logical thought is to find a disc with 5.0. Which to my knowledge won't exist for a couple of months.

    I know it's really a long shot and a destructive process, but can you uninstall the Wii IOS58 you put it in there? My thought is it will probably throw the same ticket error. I do know some people were able to delete the wrong IOS and then update. In your case though, it may not be possible since you don't have 236, 249, 250, or 251 available for use. Your best bet would just be to wait till a disc based game with v5 comes out and hope for the best. If it fixes it, then follow the guide I listed above.
     
  20. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,274
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    In nintendont thread, I wrote in RED BIG BOLD LETTERS to never install or touch IOS58 on vWii !
    I also wrote that the IOS58 issue is NOT A vWII ERROR, only a WII. If you don't see the message "your IOS58 is wrong" then it's not wrong. don't try to fix it. If nintendont doesn't work, it's another issue.
    I really don't know how to prevent users from installing Wii IOS on their vWii :(


    Where did you read that? Did you follow a guide on another website (which one)?
    because on the contrary, you need a clean, unpatched IOS58.