iOS58 brick, no HBC!Need help

Discussion in 'Wii U - Hacking & Backup Loaders' started by Baringo, May 28, 2014.

  1. Baringo
    OP

    Baringo Newbie

    Newcomer
    5
    2
    May 28, 2014
    Gambia, The
    Hey guys! Some time ago I bricked my wiiu. I "accidently" installed the Wii iOS58 on my vWii. Therefore my HBC doesnt work anymore. I tried to reinstall it but I can't get past the scam screen.

    While searching for a solution I stumbled across these two threads:
    1. http://gbatemp.net/threads/and-now-...to-an-earlier-situation-and-a-warning.357956/

    2. http://gbatemp.net/threads/vwii-semi-bricked.353595/

    In both cases the problems could be solved by installing a V58I.wad using either one of the following iOS: 236, 249 and 248.

    I wanted to try these solutions but the highest iOS my YAWMM shows is 80... I would like to attach a syscheck but i couldn't find a syschecker which contains a boot.elf so i could start with smashstack.

    But basically it's a wii on which i only installed the hbc once and the next step i made was fucking my iOS58 up. Without further change to any other iOS or installing a cIOS.

    I hope somebody can help me.

    Thanks in advance,
    Baringo
     
  2. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
  3. Baringo
    OP

    Baringo Newbie

    Newcomer
    5
    2
    May 28, 2014
    Gambia, The
    Yes but the problem is, I don't have the IOS 236 or 249. If i choose another IOS (in the range from 9-80 which are the ones YAWM shows me) it doesn't work and i get an error...
     
  4. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    Try IOS236 installer ;) But the one for vWii ! Maybe you will have to recompile it by yourself to get the elf.
    Here is the dol and the sources http://www.mediafire.com/download/4y7vebckurr2m9c/IOS236_Installer_MOD_v8_for_vWii_FIX94_dmm.zip
    (took from a google search)
    If you don't have IOS36 (vWii) you might be able to dump it from your own nand with FSTOOLBOX (with the elf as usual...) and extract it and then convert it to wad with ShowMiiWads.
    When you completely mess up with your IOS it's a long road to repair it on your own ;)
    But this may help you to understand how the whole thing works...


    to summarize :
    - Compile FStoolbox to get the elf (or dowload it if you can find it, or find someone who can give it to you)
    - Dump your nand with FStoolbox (run it from your favourite game hack)
    - Extract the IOS36 from you nand
    - Compile IOS236 installer from the link above
    - Install IOS236 with IOS236 installer (run it from your favourite game hack)
    - Then launch some wad installer and use it with IOS236
    - Install IOS58
    - Your HBC should work anew !
    If you had previously installed some cIOS (236, 249,250...) you can use them with your wad manager to install IOS58...
     
  5. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    double post, internet connection failed...
     
  6. Baringo
    OP

    Baringo Newbie

    Newcomer
    5
    2
    May 28, 2014
    Gambia, The
    I was trying to install IOS236 using the .dol in the files you linked (i don't know how i can compile stuff :/), but i always get: "FATAL ERROR: Unable to initialise the initial patches.". I started everything using boot.elf of wiixplorer (hope this doesnt change anything for the rights).

    I was also able to create a sysCheck using the WiiXplorer
    Warning: Spoilers inside!

    P.S. And thx for the help so far!
     
  7. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    All version seems ok to me except IOS58 and IOS59.
    But I checked from an old syscheck of mine so your IOS59 may be the right one. (I don't have my wiiu with me and I only have a 2.0.0 check with me...)
    your IOS58 is the one for the wii.

    For the access right, I don't know... wiixplorer seems to check for AHBPROT but I don't really see if it sets it up...
    IOS236 installer sets it up, but I don't know if it's blocked by wiixplorer or not.
     
  8. markehmus

    markehmus GBAtemp Maniac

    Member
    1,092
    293
    Jul 26, 2008
    Canada
    in the GAME
    when running IOS236 Installer v8 MOD Special vWii Edition from HBC without the meta.xml in the apps folder with it i get a failure to patch and 'hit any button to exit'
    but with the meta.xml i have no trouble , will this be a problem running the IOS236 Installer boot.elf from sd root?
     

    Attached Files:

  9. Baringo
    OP

    Baringo Newbie

    Newcomer
    5
    2
    May 28, 2014
    Gambia, The
    I was able to solve the Problem :D Today Mario Kart 8 arrived and it forced an disc upgrade which solved the IOS58 Problem :D already installed IOS 236 and 249-251 !

    Thx guys for all ur help!
     
    TeamScriptKiddies likes this.
  10. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    Glad to read you finally get out of this situation (thanks Nintendo in the end ;) )
    But maybe the loaders in hacks should be updated to manage AHBPROT.
     
  11. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013
    baffled how mario kart 8 would update or do anythin to vwii?
     
  12. TheChield

    TheChield Ugly Troll

    Member
    210
    29
    Jul 10, 2013
    France
    This should be a "global" update, if he was on a non updated Wii U maybe ? Baringo can you tell us what was your Wii U version before using MK8 ?
     
  13. Baringo
    OP

    Baringo Newbie

    Newcomer
    5
    2
    May 28, 2014
    Gambia, The
    Well i don't know what my version was before... But i was unable to update due to the wrong IOS58! That was the reason why i wanted the IOS fixed (error 162-0002)... so i could enter the eShop again :D
     
    TeamScriptKiddies likes this.
  14. TeamScriptKiddies

    TeamScriptKiddies Licensed Nintendo (indie) Game Developer

    Member
    1,900
    1,317
    Apr 3, 2014
    United States
    Planet Earth :P
    That's awesome man! Good to know, in case I ever semi-brick my vWii XD