USB Port Questions/idea?

Discussion in 'Wii - Emulation and Homebrew' started by WildWon, Feb 9, 2010.

Feb 9, 2010

USB Port Questions/idea? by WildWon at 3:38 AM (1,101 Views / 0 Likes) 7 replies

  1. WildWon
    OP

    Former Staff WildWon EXTERMINATE!

    Joined:
    Apr 4, 2008
    Messages:
    2,814
    Location:
    8-Bit Heaven
    Country:
    United States
    Hey guys,

    I have a current problem that i'm working through here:
    http://gbatemp.net/index.php?s=&showto...t&p=2580037

    In which i can load everything off of my external USB drive (Wii games off a WBSF partition, and all kinds of homebrew off of the Fat32 partition) except for emulators. The .apps will load fine, however in the emulators, they cannot locate the USB drive. (i've set primary/active/etc, but that's not what i'm looking for here).

    Would i be possible to set ANOTHER usb drive to Fat32 to plug in to the UPPER usb slot for everything Emulator related (x:/snes/roms, x:/snes/covers, etc etc).

    Then, i can run all emulators off of the main HD (plugged into the lower), but have all emulators look towards the upper port?

    I know that the upper is USB 1.0/1.1 but i don't think that'd matter too much.

    Lemme know whatcha think! Thanks [​IMG]
     
  2. psiko

    Newcomer psiko Advanced Member

    Joined:
    Jun 30, 2009
    Messages:
    60
    Country:
    United States
    just quick q, are you using a forwarder with the emulators or are you loading them through the homebrew channel?

    -psiko
     
  3. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    well, yes, you should be able to use 2 HDDs. but you should be able to fix your issue without needing 2 drives.

    the USB1.1/2.0 stuff should only apply for apps that are using a cIOS. it is the echi module that treats the ports differently. regular IOS should treat both ports as 1.1. (remember back in the day how people said usb loading would never happen since the USB speed was too slow? and it wasnt until the release of the homebrew USB 2.0 stuff that wanin and marcan made the first couple usb loaders).

    there was a bug in tantric's emulators where it could not see the USB HDD if it was loaded from one. im not sure if it ever got fixed. it may also be a bug in the forwarder that is loading the emulator where the forwarder leaves the HDD is a improper state for the emulator to detect it.

    i would try to use a different forwarder first. you can use the usb loader GX forwarder to test. we have some different USB detection code in there and maybe it will help.
     
  4. julz1

    Member julz1 GBAtemp Regular

    Joined:
    Sep 12, 2009
    Messages:
    140
    Country:
    Australia
    God damn man i seriously cant figure it out
    i know it sounds kind of stupid but can you change the settings to reset or auto detect
    i moved all of my roms from SD to my HD but my drive isnt partition just Fat 32 anyway like the first 3 times i opened snesgx it kept saying folder not found despite the fact that i changed it manually so i set it auto detect...it failed then i hit reset and it finally found em

    sorry i could help figure this problem out but that's all i got
     
  5. WildWon
    OP

    Former Staff WildWon EXTERMINATE!

    Joined:
    Apr 4, 2008
    Messages:
    2,814
    Location:
    8-Bit Heaven
    Country:
    United States
    My problem isn't finding the emulators. I'm using forwarders that point to the USB drive /apps/ folder for the emus, and all emulators run FINE! Its just that the emulator itself cannot find the USB drive (for games/saves/etc) It finds all info off of the SD card fine, but if i select auto and just have the USB hooked up w/ no SD, "USB Cannot be found" or if i force to USB, same thing. But its only a problem IN the emulator.

    I'll try other things when i get home. And i'll let you know if i come up with anything.

    Julz: No worries, mate [​IMG] Thanks for the ideas so far. The "active" thing i hadn't read before, so that was something new [​IMG]

    EDIT:

    Figured i'd toss this info here too:

    Physical Order of Partition (actual order on drive, in a partition manager, this is the order shown)/Partition Type:
    K: WBSF(500gig) - Wii games
    J: FAT32(50gig) - Wii Homebrew/etc
    Z: NTSF(50gig) - Extra CPU Backup Space
     
  6. psiko

    Newcomer psiko Advanced Member

    Joined:
    Jun 30, 2009
    Messages:
    60
    Country:
    United States
    @WildWon - as far as I am aware, that is your problem. The GX emulators by Tantric do not work properly when loaded through a forwarder. Try loading it through the homebrew channel and it would probably see your USB drive.

    -psiko
     
  7. WildWon
    OP

    Former Staff WildWon EXTERMINATE!

    Joined:
    Apr 4, 2008
    Messages:
    2,814
    Location:
    8-Bit Heaven
    Country:
    United States
    Well what do you know? That is my exact problem. I run them through the HBB, and i'm good. Try through a forwarder, and... no USB drive found.

    So, are there any good forwarder compatible Nes/Snes/Genesis emus you can recommend? Preferably with cover support... but if not, what works?

    OR, are there special forwarders available that WILL work?

    Thanks for pointing out the Forwarder problems, i wasn't aware of that at all [​IMG]
     
  8. julz1

    Member julz1 GBAtemp Regular

    Joined:
    Sep 12, 2009
    Messages:
    140
    Country:
    Australia
    Dude i think i got figured out. I dont know why i didnt do this
    I switched from SD card to Fat32 Drive and my Visualboy advanced picked it fine and worked on multiple efforts
    however the Snes and Fceu gx cover mods would not recognize the Hard-drive so i went back to the original app and it works fine now. however no Covers [​IMG]
     

Share This Page